VOGONS

Common searches


Search results

Display options

Re: Far Cry

As said previously, you'll want to use patch 1.32 to avoid that bug. My question is... if I am playing in the native OS of Windows XP 32-bit is there any reason to use community patches or should I just stick to pre 1.4 ? Should I patch at all? I'm running the 5-disc (yes 5!) retail version.

Re: The Outer Worlds releases in 2 days

Fallout NV is one of my favorite games -- love that shit. I only buy DRM-free however and I can't play FPS games with a controller so no console will work either. If they would just give me locked 60 FPS and a k&m I would largely abandon modern PC gaming right now. At least until another 1-2 …

Page 1 of 28