VOGONS

Common searches


Search results

Display options

Re: VMware acquisition by Broadcom?

in Milliways
I also noticed the latest Symantec Ghost tools now have the Broadcom brand in their title. Broadcom bought that in 2019. So I only care for the core Ghost imaging executable and Ghost-Explorer. I see no real difference except that they changed compiler to make them NT6 only, and they are now 3-times …

Re: Windows games on reactos.

in Windows
ReactOS is not ready for anything much yet, except testing of course. I would say; that is my opinion, but it is generally the developers opinion as well. Sound improved a bit some months ago, but midi got borked again. Memory manager is in a state of overhaul. Things like that.

Re: Dune II HD port at last!

in Milliways
There is some new development activity around the Dune Dynasty project, here: https://github.com/1oom-fork/dunedynasty Yeah, 1oom, the Master of Orion 1 project, is there too. There are no new binaries available AFAIK, just source code. Suspect the original Dune Dynasty developer Mr. Wang has the …

Re: VOGONS github

in Milliways
Nah, I was just hoping that MS fixed it and no one ever noticed. Still broken. Here are the 14.28.29213.0 files: https://gitlab.com/stdout12/adns/-/releases/v2.15.0 When I do a search on my computer for system32\ dll files dated 12-08-2020, which is the v14.28.29213.0 files date, I also get 40 …

Re: VOGONS github

in Milliways
Was going through and testing as well: https://github.com/abbodi1406/vcredist/blob/7056a4faf989625647f9b5cc7f853442b610a87f/source_links/README.md Seems to confirm this version 14.28.29213.0 - last version compatible with Windows XP It's likely the breakage wasn't noticeable until 29917 for that …

Re: VOGONS github

in Milliways
DosFreak wrote on 2022-05-14, 11:39: https://gitlab.com/stdout12/adns/-/releases/v2.21 Downloaded this "vcredist_x86_2019_WinAll_14.29.29917.WA.7z" and tried "msvcp140.dll" v14.29.29917.0, from 16-02-2021: It contains about 32 different calls to Kernel32 NT6-only functions. No good. To be continued …

Re: VOGONS github

in Milliways
FWIW PCem v17 could still compile with GCC 4.7.2so that's a lot of leeway right there. All of my PCem testing (for my entire time) was gcc472 builds, and that's only recently changed since Michael Manley changed the building system and axed the makefiles. I remember your remark about that in the …

Re: VOGONS github

in Milliways
I had always assumed pcem was XP compatible since it ran on 2000 with BWC kernel but I tend to forget that BWC allows Vista or higher programs to run. Of course the last ver I've tried is v17 so mabye something changed. You remember correctly that PCem v17 was surprisingly compatible with older …

Re: VOGONS github

in Milliways
Here's Doom (obviously not all Doom ports in existence are listed here). Haven't gotten yet to updating the repos with the packages and issues: Thanks again. very useful! For GzDoom the OpenGL requirements are also quite severe. The mentioned GzDoom 4.1.3 version does not even allow me to start in …

Re: VOGONS github

in Milliways
I tried the current SVN version of PCem this evening. By downloading the Win32 "artifacts" from here https://github.com/sarah-walker-pcem/pcem The executable is XP compatible, but four of the included DLL files are not. Some of those DLL files are a bit obscure. I had to build a new libzstd.dll …

Re: VOGONS github

in Milliways
Visual C++ redist I have the below vers along with this note "I’ve investigated a bit further - The 2015 to 2019 Visual C++ redistributable ( version 14.29.29917) that shipped with VS 2019 Update 10 Preview 1 does work correctly with a VS 2017 XP app (v141_xp) - so the breakage occured somewhere …

Re: VOGONS github

in Milliways
For less than 2000 need to see what the latest build of eduke32 that compiles with SDL 1.2 and work from there. Did anyone ever try to build an SDL2.dll for Windows 98? I checked it the other day, and some of the older SDL2 versions have only a few calls that are unrecognized there. (I made some …

Re: VOGONS github

in Milliways
It's been awhile since I've had to use it but there is always EDITBIN which could be tried with the v141 target EDITBIN from VS2005 C++ Command prompt "editbin /subsystem:windows,4.00 /osversion:4.0 filename" Yes that would be a more proper way, compared to the PE-header hex-edit that I do manually …

Re: VOGONS github

in Milliways
Again thanks for testing compatibility, and sharing your findings. So was checking out Vista 64 and decided to see if Ion Fury would run. The build with 11-17-2021 grp does run but it has the same issue as later builds of eduke32, ran it through dependency walker and saw this: https://docs.microsoft …

Re: VOGONS github

in Milliways
It looks like DevilutionX 1.4.0 requires Windows 7 now. You are right, it appears the newly required discord integration dll adds most of the NT6 calls. I build a DevilutionX v1.4.0 Windows XP compatible package yesterday. It is on my website . No discord integration in that one, I disabled the …

Re: VOGONS github

in Milliways
I haven't looked at stratagus but yes should definitely be possible assuming github still allows a XP target for their environment, it did last I checked months ago. From what I read regarding the Microsoft tools, (first summary from Wikipedia): 32-bit and 64-bit: Visual C++ 2015 (also known as …

Re: VOGONS github

in Milliways
I've restored my XP image to my test desktop and am going through all the ports now and testing compatibility. Soon will be updating them in vogonsorg with last working versions for XP and then up, then back around to 9x. .... Looks like nblood was affected as well by the eduke32 breakage so …

Page 1 of 143