VOGONS

Common searches


Search results

Display options

Re: DOSBox-X branch

Error on OSX: Copy code to clipboard 1 configure: error: conditional "LINUX" was never defined. 2 Usually this means the macro was only invoked conditionally. Using master branch.

Goal

I got it compiled sukas! The problem above was solved by compiling with C++, but although it was happy with the tbb headers it couldn't find the library at the end. It took me while to figure out how where that goes. All of that can be solved with one line: export CXX="/opt/local/bin/g++ -std=c++0x …

Re: OSX DOSBOX SVN Daum w/ dylibs linked

Alright. I have all of the libraries installed, patched, etc. Here's as far as 'make' gets: In file included from sdlmain.cpp:51: ./xBRZ/xbrz.h:43: error: expected identifier before ‘class’ ./xBRZ/xbrz.h:45: error: ISO C++ forbids declaration of ‘ARGB’ with no type ./xBRZ/xbrz.h:46: error: ISO C++ …

Re: OSX DOSBOX SVN Daum w/ dylibs linked

I get it now. I think he meant not to do a 'make install' What you do is download the source and 'make arch=ia32 tbb_build_dir=usr/local/lib' That gives you the "ia32" directory in /usr/local/lib Within it is the elusive "libtbb.dylib" EDIT - or apparently you can download the OSX .dmg and …

Compiling on OSX

I'm real close to compiling this and I want to make a nice .app to share with everyone. Here's where I'm stuck....in the original instructions we have: ******** libtbb This library will be used by xbrz scaler. (Don't compile it!) Get the latest version of tbb from the official website http:// …

FluidSynth Question

Does this look right for Fluidsynth to work? *************************************************************** Summary: libsndfile: no (raw audio file rendering only) D-Bus: no PulseAudio: no JACK: no ALSA: no PortAudio: no OSS: no MidiShare: no CoreAudio: yes CoreMIDI: yes LADSPA support: no LASH …

OSX DOSBOX SVN Daum w/ dylibs linked

I spent some time compiling libraries and trying to make a nice .app for OSX users. I grabbed the latest build dated 20150125. For some reason now that I'm done I'm getting Bus error: 10 If anyone is interested in taking a look at it and offering a solution I would be grateful. EDIT: NEVERMIND... …

Page 1 of 1