VOGONS


First post, by Kloht

User metadata
Rank Newbie
Rank
Newbie

Hi there.

I´m trying to play the original ROTT in WinXP using VDMS 2.1.0beta5.
My system is a P4 2,8 ghz w/ 1024 MB ram and a Realtek AC '97 onboard sound chipset. Windows is WinXP Home Edition w/ SP2 installed.

Currently, I´m emulating a SBpro 2.0 on 220/7/1, General Midi at 330

Before using VDMS, I tried my luck with XP´s SB emulation, it works, but the sound is sputtering and the midis are played wrong; not too fast or slow, but it sounds like all instruments are played at different speeds.
Ingame, everything slows down when a sound is played, with the sound itself sputtering like mad. Speedups occur when less or no sounds are played.
The game runs just fine if I select "None" as soundcard during setup; apart from the crappy midi performance.

VDMS cured the strange midi glitch, so they´re now playing like they should, but the sound sputtering and the speedups and downs are still present. Even worse, sometimes, sounds are not played at all, though there´s still the accompanying slowdown. The latter is most notable on the game menus, when you move the triad emblem cursor from option to option.
Again, if I select "None" as soundcard during setup, the game runs just fine and fluid, without speedups or downs.

I searched the forums thoroughly for similiar problems and tried every suggestion to cure them, but to no avail... Reducing CPU usage or capping the timer frequencies doesn´t have any significant effect, it just increases the sputtering frequencies of the sounds. Selecting a different type of Soundblaster to emulate does similiar things.

I hope someone can give me a hint on how to solve this annoying problem or at least tell me what causes it.

------

Btw, I already tried to run ROTT in DosBox; sound is great, but performance is less than acceptable.

WinRott is not an option for me, since it crashes randomly and generally plays different from the original, with some weird gameplay changes and missing features... for example, pushwall in WinRott kill you as soon as you touch them, while in the original, they simply push you around until they change direction or squish you against a wall.

Reply 1 of 9, by Lofty

User metadata
Rank Member
Rank
Member

Don't know about VDMS, but when you tried it with dosbox, did you tweak it for maximum speed? I get average about 12 fps on my computer, and it's only a P3/1.15Ghz, so you should be able to get 30-35fps if set up optimally.

'course, VDMS is still way faster, but fixing timing issues under NTVDM seems to be a real pain.

Reply 2 of 9, by Kloht

User metadata
Rank Newbie
Rank
Newbie

Well, it is playable under Dosbox, but I have to set details to medium, turn off light diminishing and halve the viewport size. With all that, I can play at 30-50 fps, but it still gets jerky when there are lots of masked textures (window panes, decorative grating, metal walkways) on screen or if there´s large rooms.

It´s not like I want to have the game run under WinXP at any cost, but I´d sure like to know just why VDMS keeps screwing up just like WinXp´s integrated Soundblaster emulation does...

Reply 3 of 9, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

ROTT shouldn't run that slow in DosBox...

Download a CVS build from my signature.

Verify that you are using Dynamic core.
Make sure that you increase the amount of cycles appropriate for your processor.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 4 of 9, by Kloht

User metadata
Rank Newbie
Rank
Newbie

How high should I be able to set the cycles? With normal, I can go as high as ~25000 until the sound starts to get choppy and midi slows down.
With dynamic, I can go only to ~22000 cycles.

I tried some CVS builds already, but they yielded no noteable improvement, besides some crashes or the game not running at all for some reason... I don´t really know how to use DosBox properly without resorting to some GUI (I use D-Fend), so maybe that´s to blame.

Last edited by Kloht on 2006-03-26, 13:23. Edited 1 time in total.

Reply 5 of 9, by Lofty

User metadata
Rank Member
Rank
Member

Weird. For me, dynamic core is faster, though admittedly only by about 20%, which is an unusually small improvement. I get about ~11000 cycles, so ~25000 sounds about right for your computer...but that should be more than playable even with all the detail settings and everything on full.

Reply 6 of 9, by Kloht

User metadata
Rank Newbie
Rank
Newbie

Using dynamic also has the annoying side effect that the game slows down just like with VDMS when there´s a lot of sounds played at once or in quick succession, like on the intro demo´s credit screens.

But this is about my problems with getting ROTT to run using VDMS...

Reply 7 of 9, by jbailey8

User metadata
Rank Newbie
Rank
Newbie

If your still trying to run the original rott, you have to run this utility on it
first:

cli2nop -p rott.exe

Or just type 'cli2nop' by itself to get options

File is attached, this fixed almost all of the stutter in rott on xp for me...
😁

The last time I ran the original rott, I was not running any emulation...

Attachments

  • Filename
    CLI2NOP.zip
    File size
    31.88 KiB
    Downloads
    277 downloads
    File license
    Fair use/fair dealing exception