VOGONS


Seeking Help to run TIE FIGHTER with VDMS

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by CrisGer

User metadata
Rank Member
Rank
Member

I am trying to run SW TIE FIGHTER using VDMS and found a guide that the poster said worked....so i loaded up TIE into C drive where the old DOS version goes, and did the compatabilty thing on both exe...s the auto run and the regular one

i did the sound card settings for Sound Blaster and the other settings as instructed.... i tested the music and the sound and both work

but now when i try to start the game, i get a black screen saying my CD drive does not have its drivers loaded. I have a DVD player, btw.

so can anyone help from their experience? i can get the newer 95 version but wanted to try to see the original first. It did run without sound ....when i first installed so i know the files work...but now with the VDMS in, it wont.

there was one part of the tutoiral i am following that said the following:

"After you’ve done that, go ahead and install VDMSound on your computer, then browse to the directory where you installed it. In the VDMSound folder, there should be a file called “autoexec.vdms” that you can open and edit in notepad.

Open the file in Notepad and delete the “REM” before the line about CD drivers, like we have here:"
picture follows that is hard to figure out, but it does not matter as there is no autoexe.vdms file in my install of VDMS....

Pic attached...

then the tutoiral says...

"Now you need to go to your TIE Fighter install directory. The default is usually C:/tiecd/, but it really doesn’t matter where you installed the game. Right-click the file called “Tie.exe” and select Properties from the drop-down menu that shows up.

Then select the “Compatibility” tab and click to enable the compatibility options just like we have

Next, do the same for the file “tieauto.exe” in the same directory. After you’ve done that, right click on Tieauto.exe, and select “Run with VDMS.” This should bring up a DOS window and load the TIE Fighter autolaunch program. Select “Install” from the prompt it gives you.

Now select “Set up sound card” from the install menu, and hit “C” for “Custom setup.” In the fields available, select the following information:

Sound Card: SoundBlaster Pro
Port: 220
IRQ: 7
DMA Channel: 1
Stereo Reverse: 0
Then use the “test” options to test both the Sound and the Music. They should work without any problems. Once they do, Quit and Save the configuration. Then quit the installer (not “Play TIE Fighter”).

You can now run TIE Fighter from XP by right-clicking on TIE.exe and selecting “run with VDMS.” The emulator should automatically recognize USB joysticks, and of course you can always use your mouse.

On some computers, flight will not display properly unless you have it set to 320×200 resolution, which you can do from in-game at any point by hitting escape, then selecting “320X200″ under the “Flight Res” option. You may also have to play around with how many other applications are running to get good performance, but on our system it ran fine without really having to shut anything down.

For reference, we ran TIE Fighter on:

3Ghz Pentium 4
1GB of RAM:

http://www.jason-preston.com/index.php/2007/0 … -on-windows-xp/

any help much appreciated.

so i am stuck, got sound in the set up test but game wont run... YET 😀

Attachments

  • VDMSautoexec.png
    Filename
    VDMSautoexec.png
    File size
    7.99 KiB
    Views
    33787 views
    File comment
    PIcture of VDMS Autoexe from tutoiral
    File license
    Fair use/fair dealing exception

Admin
3D Worlds and Game Developers Group Linkedin
http://3dworldandgamedevelopers.blogspot.com/

Reply 1 of 1, by CrisGer

User metadata
Rank Member
Rank
Member

i got it to run by adding a line to the shortcut to force it to recognize the CD player. but still no sound. tried to uninstall and re install but now no sound in the test part of the set up.

Admin
3D Worlds and Game Developers Group Linkedin
http://3dworldandgamedevelopers.blogspot.com/