Common searches

RB3D works 99%

Topic actions

  • This topic is locked. You cannot reply or edit posts.

Reply 40 of 177, by Hentzau

User metadata

What about chat Craig? Does that work for you? You should get a GUI graphic box that displays at the bottom of the screen when you hit "backspace" and be able to select who to send to with the arrow keys directly to the bottom right of the main keyboard. When you hit "enter" the text should show up at the top of the main screen.

I'm still running a voodoo 3000 on an old PIII 450, but looking forward to an upgrade someday. Seems like I can test it on my card though as I get the occasional corrupt terrain tile, flashes of various shades of green screen, no fog, no chat GUI or words displayed once entered, have to "alt" "F4" to get out because can't get exit menu properly, terrain looks like a cross between direct draw and glide (ie its less pixelatted SP? than DD), runs pretty slow on my system(but then it is old), no FPS counter.

With voodoo cards it was important to limit texture memory to 2MB in the tools when using larger user made bitmaps for the terrain. Don't know if that might be a helpful fact or not.

Reply 42 of 177, by CraigG

User metadata
Rank Member

As far as I'm aware, the 3dfx RB patch didn't include Multiplayer support.

If I run BaronMP.exe, it just runs in a window in software mode with no options

Athlon 64 3000+ stock
MSI NForce 4 K8N Neo Platinum
nVidia Geforce 6800GT stock clocks
SBLive! Platinum + Audigy ZS2 Drivers
WinXP Pro SP2

Reply 43 of 177, by Thor

User metadata
Rank Newbie

Hi Guys,

Using RB3D not a patched RB_2 so maybe the problem is here I dunno. NP though cause maybe the report I can give pinpoint the troubles. All modifications/third party patches removed - full install of RB3D game.

In summary:

installed Glidos v1.18
using explorer copied the Openglide config changes made per CraigG earlier post (re: options EnableMMx=1, CreatWindow=1,...)

copied the 2x.dll file into the RedBaron root directory

goto game via desktop

Error message at start of game "older glide...contact/see card manf...etc"

Set preferences of game to glide mode, 800x600, no shadows, clouds, low prop animation, large tiles, smooth terrain, slider bars for detail set to max, combat details on, max detail box off.


Entry into campaign mode ok, able to navigate all windows for pilot simulation game info.

Went to 'next mission' and flight briefing screens ok

Started flight

no Start up screen but the engine sound was there (all sounds normal btw) - a solid pale grey blue appeared with cursor like a Voodoo card (had a Voodoo3 years ago)

plane then appears normal on field but field tile is missing in exterior view. Joystick (M$ FF2 programmed to emulate keyboard) Hat switch views make it appear.

started takeoff terrain files are normal

Trees! Yahoo! my seeing eye flight dog Spike went nuts 😁 and so did I when he saw the trees like the old glide days.


during flight some tiles vanished/reappear intermittent and replaced with sky like colors

no texts available or fps counters..., unable to call up map and mission kneeboard (keypad #5) Instead it (screen) here started to lock up and flash to the pale blue/grey.

was able to exit via screen and cursor buttons (still no text) return to pilot details or campaign 'rooms' ok

So slap me silly that was close enough I sent Laser Point a payment for the unlock request as a tribute. Hey it is worthy of the efforts you all have/are making here <g> 😀 to me. So no guilt trips here about sending it.

enough said on that back to report.

System information:
Processor: P4 Intel Family 15 Model 0 1.3 GHz Stepping 10
BIOS: Phoenix Technologies
Ports: 1 Parallel, 1 Serial
Memory: 768 MB (28% Utilized)
Video: 800x600 in 32-Bit Color, 64MB DDR NVIDIA GeForce3 (Dell) Ver.

< Operating System >
Windows: WinMe 4.90 (Build 3000 )
DOS: 8.0

Hope this helps and again you have my thanks for putting forth this time and energy

Good Luck and write direct if you all want to...

Now time to get a drink, reload the machineguns, get Spike into his flight suit and away I go for a bit of gaming.

Have Fun All!


Reply 44 of 177, by Hentzau

User metadata

The very last patch for RB2 was rb3d_spr.exe http://www.wings-of-valor.org/files/patches/rb3d_spr.exe

There should be a Baronmmp.exe that you can run in order to see if chat works. Just try a "solo" in the GUI

RB3D can hold more players in MMP than any other boxed sim and it has a dynamic single player campaign so it still has a good following in both single and multiplayer.

Reply 46 of 177, by Glidos

User metadata
Rank l33t

Fixed it... well mostly.

There's a new Red Baron page on the Glidos web site. From there you can download a new version of Glide2x.dll and OpenGLid.INI (don't ignore the ini file). It should select the correct screen mode now, and the dropped textures and green flashes are gone. The menus still have missing text.

Reply 47 of 177, by Thor

User metadata
Rank Newbie

S! All,

Glidos - I tried the files as presented at your site. Installed and the missing or invisible problem resolved 😀

GUI for the in flight plus kneeboard in campaign mode (keypad unlocked and the #5 key) no longer locks/freezes but simply goes for me to a gray screen. Also on screen texts of fps counter and game speed (x2,x4...to x16), etc... not visible.

Oddly also in three tries with all 'Preferences" set to Max or Highest & glide box checked of course, I get the simulation of the SP campaign as a full windows box screen not full screen.

Upsides are that no DTD and no need to change the desktop res of course the interdimensional travel gone too - 🤣.

Another + is that the exceptional visuals are back. Fog, clouds, shadows, blazing flames and smoke (using BerryFX patch FYI to RB heads reading this;) )

Finally biggest plus I finally have some trees again. 🤣 Spike the Wonder Dog finally has a place to "go" 😁

So was most challenging to fly without maps or inflight postion markers. Made that empty guns feeling and the simulation of being lost that much more real. "Is that really the friendly trench lines?" very frightening sense when your compass is shot out and you are wounded:eek:

RB'rs that want a taste should definitely have a go at these files.

Have Fun!

Last edited by Thor on 2002-09-07, 14:40. Edited 1 time in total.


Reply 48 of 177, by Bruno_Stachel

User metadata
Rank Newbie

I don't have the reported success. I use the settings outlined earlier in the thread and receive the following error when going to Fly Now

BARON caused an invalid page fault in
module GLIDE2X.DLL at 016f:0351a394.
EAX=005d90d0 CS=016f EIP=0351a394 EFLGS=00010212
EBX=00000000 SS=0177 ESP=00aef628 EBP=00aefa34
ECX=ffffbe67 DS=0177 ESI=00000000 FS=48ff
EDX=03554ffc ES=0177 EDI=005b8f80 GS=0000
Bytes at CS:EIP:
0f 7f 0a 83 c2 08 49 75 d1 0f 77 a1 9c d7 54 03
Stack dump:
005b8f80 00fd3180 00000000 42700000 00aef678 00000d20 0625f008 000002d4 bff7a3a0 00e20000 0625f2dc 00000d20 00000000 00e2000c 00e20000 0625f008

after a snippet of engine sound.

Running Win98 on a PIV @2GHz, with GeForce 3 Ti 500.

Reply 50 of 177, by Thor

User metadata
Rank Newbie

Salute! Bruno,

Glidos is a program for DOS but the two files placed into the RB root directory that are at the RB specific site link listed:


Seem to be an excellent start on the RB'rs "Holy Grail" for those of us with non voodoo type cards.

Glidos/moderator has been more than gracious, as also CraigG. and others to approach this matter.

I can say that it works for the most part except the campaign GUIs are still the issue.

The key is that the two files you locate at Glidos site of RB section are in the root. Do not need the entire Glidos v1.18 just the Openglide file and Glide2x.dll.

Not a techhead just a crazy old guy and his dog 😉 But give it try again. Be sure you have no other third party patches like WFP or Beery just a basic RB load.

If you have no problem with it maybe a fresh reinstall. Maybe you have other UOP installed or modified DATA files like Garp's or Direct Draw terrains? After I pulled these with my CM1.1 I got back to the basics and it does work except those items above.



Reply 51 of 177, by rens

User metadata
Rank Newbie

being a Voodoo5 user, that is a compliment 😀)

I tested this on an old TNT2 with only 32 mbyte on a duron 750 mhz.
Very playable, very good graphics. even the transparent cockpit works 😀)

If the in-game- text - disappearing can be fixed, this openglide rework is the holy grail for many disappointed Red Baron pilots that had to 'upgrade' to a geforce or such......

especially in online play, you do not have chat possibilities, cuz you cant see what people are saying... or what you are typing yourself......

for Single Play, the text issue is a minor thing

keeping my finger x-ed and hoping paul gets to fix the chat-line real quick 😀)
If need be, I am 200% willing to provide him with info/help


Reply 52 of 177, by Thor

User metadata
Rank Newbie

Salute! All,

Glidos, Rens here is one of the elite techs we got he and others of his skill have brought many great things to the community.

I urge communications between you two sirs. He may have some insights for you about the tech stuff and RB.

Rens see you over the Front!



Reply 53 of 177, by Thor

User metadata
Rank Newbie

S! All,

I will try to less long winded here - 🤣. Just a update of observations.

dsktp at high color 1024x768 16 bit OS WinMe, Geforce3 DDR, Direct v 8.1b

Campaign tests: using only BeerySpFx, 800x600 no shadows or props setting intentional


Appears as full screen now.

GUI, enough said I know. Note freeze or lock when keypad#5 or map/kneeboard inflight attempted if keypad5 used again returns to sim.

Some blotch or irregular terrain present. ocassionally plane parts are blocks (not angled or rounded) not the proper textures. Note that upon emergency landing at bridge the bridge appeared as blocks no shape definitions so did some trees this intermittent depending on angle I viewed these.

Can send OpenGLid.log from RB root directory if email requested will not post here unless asked.



Reply 59 of 177, by rens

User metadata
Rank Newbie

i am curious to hear what soundcard you guys are using.

i had *none* whatsoever (win98se UK version), and that is a miracle.

i am testing this on a via chipset motherboard, you see 😈

the card is an ordinary turtlebeach daytona....
nothing great about that..