FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

General information and assistance with GliDOS.

FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-24 @ 07:15

Hi!

Ich use Windows 7 Ultimate 64 bit and tried to get the German version of Tomb Raider 1 + Addon running. I proceeded as follows:

01. I removed all removable mediums safely via Windows and took them off.
02. I filled CD drive D: with the Tomb Raider CD
03. I filled my virtual CD drive G: with an ISO (Star Wars - Dark Forces)
04. I installed the preconfigured game to C:\TOMBRAID (via "TrAndUbForGlidos.exe")
05. I installed Glidos 1.49 (C:\Eigene Dateien\Spiele\Emulatoren\Glidos)
06. I installed "DOSBoxForGlidos_1_1.exe" (C:\Eigene Dateien\Spiele\Emulatoren\Glidos)
07. I installed the audio pack "TombRaiderAudio_v1_6_DE.exe" (C:\Eigene Dateien\Spiele\Emulatoren\Glidos\Audio)
08. I installed the FMV Pack "TombRaiderFMV_v1_2.exe" (C:\Eigene Dateien\Spiele\Emulatoren\Glidos\FMV)
09. I opened "Glidos.exe"
10. I chose "Adjust..."
11. "DOS" --> "Dos Emulation" --> "DOSBox" activated
12. "Enable Glidos's VESA emulation" activated (it already was by default)
13. "Audio & Movies" --> "Use Audio Pack" activated --> "Use FMV Pack" activated
14. Display --> "Full Screen" activated
15. Select: "Tomb Raider" --> "Start game"

Overview INI:

Name: Tomb Raider
Executable: C:\Tombraid\Tomb.exe
ExeSizes: 873739
CDCheckFile: data\Level10c.phd
Driver: Direct3D
DosGraphics: Yes
VESASupport: Yes
ControlJudderFix: 1
Resolution: 3
FullScreen: Yes
TrShadowHack: Yes
RedbookEmulation: MP3
FMVPack: Yes
DosEmulation: DOSBox

My problem:

FMV videos are skipped! There's no Eidos logo, no intro before the start menu and no intro between start menu and the first level. I directly go to the menu and then straight to the game. If i deactivate the FMV pack all videos load smoothly.

General problem:

I had a look at the Avi files: They all are in English language without a second dubline. Do you have a German version of the FMV pack? In theory I could dub them with German language, if I somehow manage to achieve the dublines.

If you can instruct me how you extracted the FMV of the playstation game, I could even get the complete FMV videos of the German version and provide them to you.

My questions summarised:

1.) How about my settings in Glidos.ini? Are they in need of improvement?
2.) The only additional setting that I have activated is "TrShadowHack: Yes", do you recommend any further fix, hack or option that is available for optimum gameplay?
3.) Does a German FMV pack exist?
4.) If not: Can you help me to get videos in German language by myself (I could dub them or I could extract them from the German playstation game)
5.) Why does the FMV pack not work for me?

I would be grateful for any help. Thanks in advance!
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-24 @ 07:55

Hmmm. You are the second person to report a problem, both from Germany, although I can't think why there would be a connection.

Can you play the movies in WMP? It is possible that you have a codec missing because of perhaps not being on the latest version of WMP. But if the movies play in WMP, then they should play through Glidos.

It would be great if you could get hold of a German Playstation version of TR and pull the fmvs off. You should be able to just open the FMV folder on the disc and drag out the files. I can then convert them.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-24 @ 08:34

Yes, I already talked to Volker from laraunlimited.net. He told me that he has the same problem (he tried it with Win XP SP3 and Win 7 Professionell 64bit - both methods had the same issue).

I will have a look at my Windows Media Player this evening. But as I have installed the K-Lite Codec pack, I can't believe it's a codec problem...

Can you help me about my first two questions?

1.) How about my settings in Glidos.ini? Are they in need of improvement?
2.) The only additional setting that I have activated is "TrShadowHack: Yes", do you recommend any further fix, hack or option that is available for optimum gameplay?


Okay, I will upload the German fmv files as soon as I can!
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-24 @ 09:58

On your settings, and your installation procedure, they look to be perfect.

I wonder if the K-lite codec pack could be the problem? I guess what I need to do is improve the error reporting so that Glidos will tell us what the problem is.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-24 @ 21:13

Hi!

So, here's the news: I opened the Avi files via WMP and had no problem. No codec was missing.

However, I uninstalled K-Lite to see if something changes, but I was getting the same result afterwards.

Here's the log of Glidos (I don't know if it helps you):

Starting Glide Server v1.49 (c) Paul Gardiner 2001-2008
VESA mode 0x101
VESA mode 0x101
Open core.avi
Open core.avi
Play FMV
WinClose
VESA mode 0x110
VESA cmd 4F07, 0, 0, 0
Open escape.avi
Open escape.avi
Play FMV
WinClose
VESA mode 0x110
VESA cmd 4F07, 0, 0, 0
Open cafe.avi
Open cafe.avi
Play FMV
WinClose
VESA mode 0x110
VESA cmd 4F07, 0, 0, 0
VESA mode 0x101
Resolution = 640x480
Refresh rate = 60Hz
Color format = ARGB
Number of color buffers = 2
Number of aux buffers = 1
Resolution = 640x480
Refresh rate = 60Hz
Color format = ARGB
Number of color buffers = 2
Number of aux buffers = 1
Resolution = 640x480
Refresh rate = 60Hz
Color format = ARGB
Number of color buffers = 2
Number of aux buffers = 1
Resolution = 640x480
Refresh rate = 60Hz
Color format = ARGB
Number of color buffers = 2
Number of aux buffers = 1
Resolution = 640x480
Refresh rate = 60Hz
Color format = ARGB
Number of color buffers = 2
Number of aux buffers = 1
GlideShutdown


And last but not least:

Here you go, the unconverted German fmv files:
http://rapidshare.com/files/3401746684/FMV.rar

Hope I was helpful.
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-26 @ 10:35

Thanks for the FMVs.

Can you try out the attached app to see if it will play the movies from the English FMV pack?
Attachments
Movie.exe
Glidos' internal movie player in standalone form.
(140 KiB) Downloaded 537 times
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-26 @ 16:54

Thank you! I tried... but unfortunately I failed just by opening the application!

This is what I got by running the app:

http://bayimg.com/BaIOeAaDe

(I downloaded an English language pack for my Windows 7 to make it more understandable for you)

Just for fun I also tried it with my Windows 98 Virtual Machine:

http://bayimg.com/baioGaaDe

(It says that a DLL file is missing)

Well, then I followed the advice of the error message:

http://bayimg.com/baiOIaAdE

...and received the MySxSTrace.txt file which you can find in the attachments. I hope it's useful for you.

(btw: Googling made me believe that all I have to do is installing "Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)" and "Microsoft Visual C++ 2008 SP1 Redistributable Package (x64)". Unfortunately it didn't help.)

Thank you again for helping me! Maybe you can make out the error by reading the enclosed textfile.
Attachments
MySxSTrace.txt
(28.53 KiB) Downloaded 216 times
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-26 @ 18:07

Oops! Sorry. I sent you the debug version. No, you wouldn't have the dlls needed for that. This version should be better.
Attachments
Movie.exe
Release version
(52 KiB) Downloaded 523 times
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-26 @ 18:23

Thank you, but I receive exactly the same error with that version. Shall I create a new logfile?
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-26 @ 20:36

I created one (see attachment).
Attachments
MySxSTrace.txt
(16.97 KiB) Downloaded 396 times
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-26 @ 23:36

Oh ok. Maybe this version then. This one is statically linked.
Attachments
Movie.exe
Statically linked release version
(316 KiB) Downloaded 541 times
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-27 @ 03:04

At least I can start the player now. Unfortunately this is what I get:
http://bayimg.com/pAiPfAADe
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-27 @ 11:44

That's result we want. So at least we now know that the problem is with playback of the movie, and not the monitoring of the game and triggering of playback.

Here's another version that may give more information concerning why playback failed.
Attachments
Movie.exe
Player with better error reporting
(316 KiB) Downloaded 533 times
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-27 @ 12:58

Nice to hear. So here's the more detailed error:
http://bayimg.com/oAIBMAAdf
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-28 @ 10:45

Hmmm. Strange. That error says the format isn't supported, but I'm using DirectShow which is the same method as WMP. I am supporting two different methods, one that falls back to another if not supported. Here's a version of the player that goes directly for the fallback.
Attachments
Movie.exe
Movie Player forcing use of VMR9
(316 KiB) Downloaded 528 times
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Agent of the BSoD » 2011-5-29 @ 04:15

Hi! I've got the same problem with the FMV's on my Windows 7 32bit system. My properties for it are the same as on the first post actually, and my issues are the same as Ryu_Battousai is having. Using DOSBox on Direct3D and VESA emulation. I tried switching the properties around to see if it would magically work, and nope. Didn't think it would anyway.

I also tried out the applications you've linked. The first two failed to open the file, and the second two both reported the same error code identical to the one Ryu_Battousai gave. It seems that both of us have the same problems. (also, there is one movie in the FMV's that's missing that's called ESCAPE, one of the startup FMV's)
K6-III+ 400MHz | FIC PA-2013 | Matrox Mystique 220 | Yamaha Audician 32 Plus | Windows 98SE
Other: S3 Virge GX2 | SB16 Vibra CT2940 | 3dfx Voodoo 1 & 2 | Matrox m3D | Rendition Vérité V1000
MT-32 (old) | SC-8820
User avatar
Agent of the BSoD
Member
 
Posts: 110
Joined: 2011-3-11 @ 01:26
Location: Oregon

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-29 @ 12:32

That's bad news that the thrid version gives the same error. And do you also find that the movies play in Windows Media Player?

None of the Glidos settings will have any affect on this. It is some sort of difference in our DirectShow systems. I have them working fine on both Windows 7 64bit and on Windows XP 32bit, but they aren't completely clean installations. Possibly other DirectShow filters/codecs have been added as parts of other programs.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Glidos » 2011-5-29 @ 12:34

And I forgot to say: the missing ESCAPE.AVI is intensional, so that isn't the cause either (although thanks for mentioning it - it might have been).
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Agent of the BSoD » 2011-5-29 @ 18:17

Yeah, they play fine in my media player. (Windows Media Player) When I play the game through DOSBox, the FMV's don't appear, but try to. I get a blank white screen that stays for a few split seconds, and closes, for each FMV.
K6-III+ 400MHz | FIC PA-2013 | Matrox Mystique 220 | Yamaha Audician 32 Plus | Windows 98SE
Other: S3 Virge GX2 | SB16 Vibra CT2940 | 3dfx Voodoo 1 & 2 | Matrox m3D | Rendition Vérité V1000
MT-32 (old) | SC-8820
User avatar
Agent of the BSoD
Member
 
Posts: 110
Joined: 2011-3-11 @ 01:26
Location: Oregon

Re: FMV pack does not work! Tomb Raider + Unfinished Business on Windows 7 64 bit

Postby Ryu_Battousai » 2011-5-29 @ 19:02

Hi, so now we are three people having the same error (I counted Volker from laraunlimited.net).

I gave your last movie player a try too. I receive the same error as before - the format is not supported.

Uhm, what about the escape.avi? I didn't quite understand what you mean by "intensional"... Why is it missing?
Ryu_Battousai
Newbie
 
Posts: 15
Joined: 2011-5-24 @ 06:30

Next

Return to GliDOS General

Who is online

Users browsing this forum: No registered users and 1 guest