Redbook emulation (analog CD Audio)

General information and assistance with GliDOS.

Redbook emulation (analog CD Audio)

Postby Sardoc » 2012-9-21 @ 13:51

I have an issue with Redbook emulation (analog CD Audio) in Glidos/DOSBox (talking specifically about Tomb Raider and UB).

Basically, the software correctly plays music, regardless if it's from the audio pack or normal game disc ('Control CD' option in the audio tab of Glidos settings). However, there's no way in the world to change its volume. It's pretty annoying when the music is so loud I can't hear my thoughts. Is there any way to do this without having to manually edit all the sound files?
User avatar
Sardoc
Newbie
 
Posts: 38
Joined: 2012-9-21 @ 13:11

Re: Redbook emulation (analog CD Audio)

Postby Glidos » 2012-9-21 @ 14:28

Not from within the game or Glidos, but you should be able to change the setting in your computer's audio mixing settings, I'd have thought. Strangely it's never been a problem for me, and no one else has mentioned it before. I wonder what is different on your system - assuming it isn't just that you like it quieter than most.

BTW, interesting to hear that Core probably left out many of the audio tracks because of unreliable CD drives. Never knew that, but makes perfect sense.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: Redbook emulation (analog CD Audio)

Postby Sardoc » 2012-9-21 @ 14:58

The thing is... I can adjust the volume of sound effects just fine, but not the music or level sound background. I know for sure DAEMON Tools no longer supports Redbook emulation (the last version to do that was 3.47), so I think it's handled internally by either Glidos or DOSBox. I will try other software like DT and post feedback.
User avatar
Sardoc
Newbie
 
Posts: 38
Joined: 2012-9-21 @ 13:11

Re: Redbook emulation (analog CD Audio)

Postby Kaminari » 2012-9-21 @ 21:37

Daemon Tools is still compatible with Redbook, but only in digital mode. You need analog playback to control the CD volume, and Windows 6/7/8 don't support it at all.
User avatar
Kaminari
Oldbie
 
Posts: 768
Joined: 2002-12-06 @ 01:54

Re: Redbook emulation (analog CD Audio)

Postby Glidos » 2012-9-22 @ 14:53

If you are using the audio pack, then the cd isn't actually playing of course: it's mp3 tracks. I know that Glidos doesn't set the volume when playing back those tracks - I guess maybe it should.

Since you've first posted, I've thought a bit about what would be involved in making the in-game setting work, but I've realised I don't really know how CD volume is set via DOS. I'd guess it's via the sound card. Glidos doesn't hook any of the SoundBlaster ports or interrupts. VDos32 does: it has it's own SoundBlaster emulation, but it doesn't handle CD volume changes, and in any case, you aren't using it.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: Redbook emulation (analog CD Audio)

Postby Sardoc » 2012-9-23 @ 23:17

Right. So is it DOSBox that handles sound and music?

I've prepared a special game CD, where I included all the game files from the original disc and all audio, even the missing tracks. Then, I tried running the game in pure DOSBox. I used these attributes to mount the CD so it would play the music:

mount d: e:\ -t cdrom -usecd 1 -ioctl

It played the music, but again, only on maximum volume. Turning it down in-game didn't do anything.

Maybe it's DOSBox's inability to emulate analog audio in games using digital data? Could be interesting.
User avatar
Sardoc
Newbie
 
Posts: 38
Joined: 2012-9-21 @ 13:11

Re: Redbook emulation (analog CD Audio)

Postby Glidos » 2012-9-24 @ 09:54

Assuming you are using DOSBox emulation under Glidos, the SoundBlaster sound card support will be supplied by DOSBox, so digital sounds such as foot steps, gun blasts, etc. will be handled by DOSBox.

If under Glidos's audio settings you select None, then redbook will also be handled by DOSBox (provided I haven't broken that mode and not realised it).

If under Glidos audio settings you select Control CD, then Glidos hooks the redbook calls and turns them into Windows-based CD commands.

If under Glidos audio settings you select Use Audio Pack, then Glidos hooks the redbook calls and turns them into commands to play the mp3 tracks.

Yes it's a shame about VDos32. 64bit Windows has sort of killed it. 64bit Windows allows 32bit programs to run, but doesn't support use of a thing called the LDT (Local Descriptor Table). Few programs would need that, but VDos32 does. I've never been able to find a workaround.
User avatar
Glidos
l33t
 
Posts: 3114
Joined: 2002-8-08 @ 02:55

Re: Redbook emulation (analog CD Audio)

Postby Sardoc » 2012-9-24 @ 22:49

Right. That's what I wanted to know.
Well... in any of those settings (Control CD, Audio Pack or None) the music is always played at maximum volume.

Anyway... I'll just leave it for now. If there's any future version of either Glidos or DOSBox which could do something about it, I'll gladly update.
User avatar
Sardoc
Newbie
 
Posts: 38
Joined: 2012-9-21 @ 13:11

Re: Redbook emulation (analog CD Audio)

Postby Sardoc » 2012-10-01 @ 00:39

Ok, after some huge research, I managed to find quite a good solution to this.

The problem exists because our dearest Microsoft (who even asked them to! -.-) changed the way sound card drivers work in Vista/7/8. The systems no longer support analog audio at all, so it's all handled digitally (on a sidenote, lack of EAX support on those systems also comes from this change). This is why lowering audio cd volume in old games does nothing.

But, I recently learned that DOSBox can cap the audio volume internally if the CD image is in .cue/.bin format. Here's how it works.

For this method, I'm using my prepared game CD, with fully restored audio tracks (they are played properly when they should be, because the triggers were never removed in the PC version, despite the tracks weren't included on the disc). It is important that the image is in .cue/.bin format, because DOSBox can adjust the audio volume only when a .cue file exists (.iso/.nrg/.mds will not work). I'm NOT mounting it at all (neither in DAEMON tools nor in a physical drive), and I'm just using DOSBox's imgmount command instead.

So, to use imgmount, I edited the dosbox.conf file in Glidos directory, and added the following lines:

[autoexec]
imgmount d "d:\CD_location\CDimg.cue" -t iso -fs iso
mixer cdaudio 50:50

Finally, I set Glidos's audio settings to None, so that DOSBox handles audio tracks.
The two values after cdaudio control the volume of the left/right audio channel, in percentages. I found that 50% on both right/left channel works just great for me. So even though changing the volume in-game still does nothing, the audio volume is capped permanently on my desired level. Hooray, my ear drums are safe now.

Whew, that was quite some wall 'o' text. Now please excuse me, it's time for an all-nighter marathon of geeking TR1 with beautifully working audio and great Glidos graphics. *me gusta face*
User avatar
Sardoc
Newbie
 
Posts: 38
Joined: 2012-9-21 @ 13:11

Re: Redbook emulation (analog CD Audio)

Postby dr.zeissler » 2015-10-31 @ 11:55

I have a fully installed Win98se Installation. With this I get Audio-CD's support from mounted Images in Win98se with deamon-tools.
If I make a clean install of Win98se and mount the same image I get no audio-playback.
I have not found out which software provides that audio-playback support.

any idea?

It's not Win98se it is not DX, it's not deamon-tools. It's something different.
Perhaps one installed game of the full installation provides it?
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): Matrox G200 8MB
dr.zeissler
Oldbie
 
Posts: 998
Joined: 2011-9-28 @ 15:33

Re: Redbook emulation (analog CD Audio)

Postby vitalm » 2015-11-03 @ 05:05

Use VXD driver for your sound card, "Analog audio" must be checked in Daemon Tools 3.4.7 options. You can change CD audio volume in Daemon Tools in drive settings. For DOS games running in Windows 9x, use 2 sound cards, when "Win" sound card emulates CD audio and "Dos" sound card (like ISA SB) with VXD driver produces other game sounds. In this case "Dos" sound card Line-Out is connected by cable with "Win" sound card Line-In, so game sounds' volume can be changed by Line-In slider and CD audio volume can be changed by Wave Out slider of "Win" sound card.
W98SE+NUSB3.3, 7AJA2 (KT133A+686B), Athlon XP-M (3x100-16.5x150 MHz), FX5900, Voodoo1, AWE64 ISA (VXD) connected to Line-In of Vortex2 rev.B0AAAA (VXD 2041) for DOS games CD Audio emulation by Daemon Tools 3.47 (volume can be changed in DT drive settings)
vitalm
Newbie
 
Posts: 2
Joined: 2014-1-29 @ 15:52

Re: Redbook emulation (analog CD Audio)

Postby innuendo1231 » 2015-12-12 @ 11:27

Sardoc wrote:Ok, after some huge research, I managed to find quite a good solution to this.

The problem exists because our dearest Microsoft (who even asked them to! -.-) changed the way sound card drivers work in Vista/7/8. The systems no longer support analog audio at all, so it's all handled digitally (on a sidenote, lack of EAX support on those systems also comes from this change). This is why lowering audio cd volume in old games does nothing.

But, I recently learned that DOSBox can cap the audio volume internally if the CD image is in .cue/.bin format. Here's how it works.

For this method, I'm using my prepared game CD, with fully restored audio tracks (they are played properly when they should be, because the triggers were never removed in the PC version, despite the tracks weren't included on the disc). It is important that the image is in .cue/.bin format, because DOSBox can adjust the audio volume only when a .cue file exists (.iso/.nrg/.mds will not work). I'm NOT mounting it at all (neither in DAEMON tools nor in a physical drive), and I'm just using DOSBox's imgmount command instead.

So, to use imgmount, I edited the dosbox.conf file in Glidos directory, and added the following lines:

[autoexec]
imgmount d "d:\CD_location\CDimg.cue" -t iso -fs iso
mixer cdaudio 50:50

Finally, I set Glidos's audio settings to None, so that DOSBox handles audio tracks.
The two values after cdaudio control the volume of the left/right audio channel, in percentages. I found that 50% on both right/left channel works just great for me. So even though changing the volume in-game still does nothing, the audio volume is capped permanently on my desired level. Hooray, my ear drums are safe now.

Whew, that was quite some wall 'o' text. Now please excuse me, it's time for an all-nighter marathon of geeking TR1 with beautifully working audio and great Glidos graphics. *me gusta face*


Thanks so much for this! I never knew the real cd tracks would work! My ears are sensitive for mp3. I heard that it wasn't the real thing. Also the volume problem hothered me as well. Im gonna go get the tracks from the psx disc and combine them to my PC image file. That's how you do it, right?
User avatar
innuendo1231
Newbie
 
Posts: 11
Joined: 2013-2-06 @ 21:15

Re: Redbook emulation (analog CD Audio)

Postby innuendo1231 » 2015-12-12 @ 22:48

Hmm. I can't get this to work. If use the autoexec lines you described to mount the CD iso, dosbox returns and error: Unable to load dll.

If I set glidos to "control CD" the wrong tracks are played back....

How did you do it?
User avatar
innuendo1231
Newbie
 
Posts: 11
Joined: 2013-2-06 @ 21:15

Re: Redbook emulation (analog CD Audio)

Postby innuendo1231 » 2015-12-13 @ 12:10

Update:
Glidos's "Control CD" function works well, and by that I mean that the music tracks activate at the right spots, though the volume issue persists. But the wrong tracks are played, and I realized why.
While the PC disc only contains the different ambient souns tracks and no music tracks the psx disc has only ONE type of ambient track plus the music tracks. How strange, that it's the ambient tracks that are missing from the psx disc?... So I need to combine the audio tracks of the Psx disc and the audio tracks of the PC disc plus the data track of thr PC disc. Also I need to arrange the combined audio tracks based on the mp3 audio pack as a template.
I might as well lower the volume of the tracks too...
Some adventure... xD
User avatar
innuendo1231
Newbie
 
Posts: 11
Joined: 2013-2-06 @ 21:15

Re: Redbook emulation (analog CD Audio)

Postby dr.zeissler » 2015-12-13 @ 14:38

Does not work for me, can't get it running. Always the same, CD-Music while jumping to Desktop from the running game,
instandly no music when switching back to the game. That's STUPID.
Last edited by dr.zeissler on 2015-12-13 @ 21:30, edited 1 time in total.
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): Matrox G200 8MB
dr.zeissler
Oldbie
 
Posts: 998
Joined: 2011-9-28 @ 15:33

Re: Redbook emulation (analog CD Audio)

Postby innuendo1231 » 2015-12-13 @ 21:10

@ dr.zeissler: Did you check Glidos's "Control CD" option on the audio/fmv tab? Also are you using bin/cue image format?

Okay so I made a disc image that contains the right tracks in the right order and with normalized tracks with volumes that I think fits the game. (I used different values for different tracks, as some of them were louder or quieter...)
If anyone wants it, I could share I guess. It also contains the braid mod.

PS. I tuned all the music tracks to 432 hz because my ears like it better this way :D (with the lossless method without any lossy speed corrected pitch alteration...)
User avatar
innuendo1231
Newbie
 
Posts: 11
Joined: 2013-2-06 @ 21:15

Re: Redbook emulation (analog CD Audio)

Postby dr.zeissler » 2015-12-13 @ 21:33

Sorry, what is that ? (Control CD"-Option)

I am trying to play "OUTCAST" with a mounted "AudioCD"
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): Matrox G200 8MB
dr.zeissler
Oldbie
 
Posts: 998
Joined: 2011-9-28 @ 15:33

Re: Redbook emulation (analog CD Audio)

Postby innuendo1231 » 2015-12-14 @ 12:27

dr.zeissler wrote:Sorry, what is that ? (Control CD"-Option)

I am trying to play "OUTCAST" with a mounted "AudioCD"


Image
User avatar
innuendo1231
Newbie
 
Posts: 11
Joined: 2013-2-06 @ 21:15

Re: Redbook emulation (analog CD Audio)

Postby dr.zeissler » 2015-12-14 @ 14:10

Ok, that seems to be other software that I do not need for my purposes.
I already use a native Voodoo1 combined with a Voodoo3 in my retro PC.
It's difficult to find the piece of software or Option that provides the
Audio-CD playback of Mounted Audio-CD Images with Deamon-Tools.

It worked before (I never used Glideos or something like that), but I can't
find where it was activated.

Doc
CPU: PII 133-333 MOBO: SNI-D981 RAM: 512- FDD: Dualfloppy 3,5"HD/5,25"HD - 3,5"HD - 5,25"DD ISA-Catweasel HDD: 2x40GB - DVD
ISA(3): Audician32-S2Dreamblaster - GusACE PCI(3): Monster3D- Intel NW AGP(1): Matrox G200 8MB
dr.zeissler
Oldbie
 
Posts: 998
Joined: 2011-9-28 @ 15:33

Re: Redbook emulation (analog CD Audio)

Postby Stiletto » 2015-12-14 @ 19:41

dr.zeissler wrote:Ok, that seems to be other software that I do not need for my purposes.
I already use a native Voodoo1 combined with a Voodoo3 in my retro PC.
It's difficult to find the piece of software or Option that provides the
Audio-CD playback of Mounted Audio-CD Images with Deamon-Tools.

It worked before (I never used Glideos or something like that), but I can't
find where it was activated.

Doc


Dude, you're in the wrong thread (this subforum is about GliDOS) and not being particularly helpful. I'll see if I can fork off your posts to a different thread.
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 3677
Joined: 2002-7-01 @ 21:57

Next

Return to GliDOS General

Who is online

Users browsing this forum: No registered users and 1 guest