VOGONS


PCEm. Another PC emulator.

Topic actions

Reply 980 of 1043, by Battler

User metadata
Rank Member
Rank
Member

About https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=2&t=2989 - I confirm the bug. Basically, when I draw in Paintbrush with the S3 Trio64 1.70.04 drivers in Windows 3.1x, I can't see what I'm drawing.

Reply 981 of 1043, by jm2k7

User metadata
Rank Newbie
Rank
Newbie
Battler wrote:

About https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=2&t=2989 - I confirm the bug. Basically, when I draw in Paintbrush with the S3 Trio64 1.70.04 drivers in Windows 3.1x, I can't see what I'm drawing.

Right, I just tried and have that problem.
At the end of the post I read that he has released a new rev 1156, but I do not see where to download.
Well, let's wait while it progresses and wait for the author to publish the update.

== Another Problem ==

and there's another problem that I do not know if it's the emulator or the game, but I think if it's the emulator:
"Need for Speed Special Edition", the accelerate key "up key" stops working when you switch to the first speed. It is a very strange error.
With dosbox working properly, I was perplexed.

Reply 982 of 1043, by Jo22

User metadata
Rank l33t
Rank
l33t
jm2k7 wrote:
Right, I just tried and have that problem. At the end of the post I read that he has released a new rev 1156, but I do not see w […]
Show full quote
Battler wrote:

About https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=2&t=2989 - I confirm the bug. Basically, when I draw in Paintbrush with the S3 Trio64 1.70.04 drivers in Windows 3.1x, I can't see what I'm drawing.

Right, I just tried and have that problem.
At the end of the post I read that he has released a new rev 1156, but I do not see where to download.
Well, let's wait while it progresses and wait for the author to publish the update.

Oh, this S3/Paintbrush issue is still a thing ? 😮 First noticed it about a year ago.
(Last time I checked, Paintbrush worked just fine on a real Trio64V/Virge325.)

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 983 of 1043, by Battler

User metadata
Rank Member
Rank
Member

Yes, it seems to be. Though I have to correct one thing - the Virge 235 2D engine is shared with the Trio64V (which means it should technically be easy to implement the Trio64V emulation on top of the Virge325 code), but on PCem the issue was on the emulation of the original Trio64, which has an entirely different 2D engine. :p Of course, the issue is fixed now.

Reply 984 of 1043, by Jo22

User metadata
Rank l33t
Rank
l33t

I see, thank you very much for explaining. 😀

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 985 of 1043, by hail-to-the-ryzen

User metadata
Rank Member
Rank
Member

Lost access to menu and title bar of PCem window where switching back and forth between fullscreen and windowed modes. Caused by window shifting upwards on screen in Windows 10. Tested with latest version of emulator and SDL2.

Reply 986 of 1043, by SarahWalker

User metadata
Rank Member
Rank
Member

PCem v14 is now available. Changes from v13.1 :

  • New machines added - Compaq Portable Plus, Compaq Portable II, Elonex PC-425X, IBM PS/2 Model 70 (types 3 & 4), Intel Advanced/ZP, NCR PC4i, Packard Bell Legend 300SX, Packard Bell PB520R, Packard Bell PB570, Thomson TO16 PC, Toshiba T1000, Toshiba T1200, Xi8088
  • New graphics cards added - ATI Korean VGA, Cirrus Logic CL-GD5429, Cirrus Logic CL-GD5430, Cirrus Logic CL-GD5435, OAK OTI-037, Trident TGUI9400CXi
  • New network adapters added - Realtek RTL8029AS
  • Iomega Zip drive emulation
  • Added option for default video timing
  • Added dynamic low-pass filter for SB16/AWE32 DSP playback
  • Can select external video card on some systems with built-in video
  • Can use IDE hard drives up to 127 GB
  • Can now use 7 SCSI devices
  • Implemented CMPXCHG8B on Winchip. Can now boot Windows XP on Winchip processors
  • CD-ROM emulation on OS X
  • Tweaks to Pentium and 6x86 timing
  • Numerous bug fixes

As ever, it's at http://pcem-emulator.co.uk/

Reply 988 of 1043, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Excuse my ignorance, I haven't paid attention to PCEm besides knowing it exists. But now I have the Japanese Ultima 8 for DOS/V and PC9801. Can I play that with PCEm?

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 990 of 1043, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Thanks, now I need to read up on PCEm, I have no clue what I need to run it. But I'll figure it out 😀

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 993 of 1043, by kolano

User metadata
Rank Oldbie
Rank
Oldbie
James-F wrote:

Thanks Sarah!

Added dynamic low-pass filter for SB16/AWE32 DSP playback

This is great, might be the most accurate SB16 emulation yet.

Still hoping for eventual addition of mic / cd / line-in support.

Eyecandy: Turn your computer into an expensive lava lamp.

Reply 996 of 1043, by JSO

User metadata
Rank Member
Rank
Member

PCEm works great! Tested many DOS, Windows 3.x, 9x games and applications!

But I facing an issue with Fifa 94, which I think it was present on the first DOSBox versions also.

The program doesn't runs because of the following error :

Abnormal program termination : Memory protection fault
CS:EIP = 000Fh :0009C4E7h

Any solution? It is related with a bios setting? This occurs with various mb's and cpu's and using MS DOS 6.22 and PC DOS 2000.

DOS IS THE POWER OF OUR CHILDHOOD MEMORIES!

Reply 997 of 1043, by Destroy

User metadata
Rank Newbie
Rank
Newbie
leileilol wrote:

ATTN expert Voodoo owners: Recently I've been working on this patch and I desire technical feedback to perfect it further..

Thank you very much for your efforts but when a file is put out there with no instructions on how to install or use it, it's hard to give feedback.

Reply 999 of 1043, by hail-to-the-ryzen

User metadata
Rank Member
Rank
Member

15/16bpp low resolution modes display only left half of video in Windows 95. Testing with Bearwindows 9x vesa driver while s3vbe20 and sdd53a are running via autoexec.bat. Changes below restore full video.

--- vid_svga_render-2.c
+++ vid_svga_render-1.c
@@ -521,8 +401,8 @@ void svga_render_15bpp_lowres(svga_t *sv

dat = *(uint32_t *)(&svga->vram[(svga->ma + (x << 1) + 4) & svga->vram_display_mask]);

- p[x] = video_15to32[dat & 0xffff];
- p[x + 1] = video_15to32[dat >> 16];
+ p[x + 2] = video_15to32[dat & 0xffff];
+ p[x + 3] = video_15to32[dat >> 16];
}
svga->ma += x << 1;
svga->ma &= svga->vram_display_mask;
@@ -585,8 +465,8 @@ void svga_render_16bpp_lowres(svga_t *sv

dat = *(uint32_t *)(&svga->vram[(svga->ma + (x << 1) + 4) & svga->vram_display_mask]);

- p[x] = video_16to32[dat & 0xffff];
- p[x + 1] = video_16to32[dat >> 16];
+ p[x + 2] = video_16to32[dat & 0xffff];
+ p[x + 3] = video_16to32[dat >> 16];
}
svga->ma += x << 1;
svga->ma &= svga->vram_display_mask;

Edit: disregard the above suggested change to the code. Can no longer reproduce the original issue.