Falcosoft Soundfont Midi Player + Munt VSTi + BassMidi VSTi

Schedules and announcements about program releases.

Re: Falcosoft Soundfont Midi Player

Postby K.A.R.R. » 2016-10-20 @ 18:00

its a normal hdd with ntfs
os is w10 pro


seems the command does not work

i got this messages

Image


but the 64 bit version works
so its not a big deal


but with fsmp and loopmidi and sound canvas va i have some probs with dosbox

i tested just a few games:

the 7th guest works without probs
wing commander pirvateer works also perfect

but:
test drive 3 creates strange tones when i use fsmp with "use patch info for capital tone fallback" enabled
i have to disable it and press reset ones even when it is disabled to make midi sound ok with test drive 3


wing commander 2 (deluxe cd version and floppy version)
midi sounds not good wrong instruments are used
(with savi host sound is wrong too)

privateer 2
with soudblaster and with gravis ultrasound midi works
but with general midi and soundcanvas midi works in setup porgramm
but game hangs during the 3rd video to joes bar
(at that point no midi is played, so a crash there makes no sense to me)

i have to test if it will crash with normal ms wavetable synth


i can record the wrong test drive 3 and wc2 music
K.A.R.R.
Newbie
 
Posts: 26
Joined: 2014-7-28 @ 19:08
Location: Germany

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 18:20

Hi,
Have you read the command's output message? The command worked perfectly :) I do not speak German, but I do understand that 'deaktiviert' means disabled. So you, or some kind of 'tweaking software' disabled 8.3 filename creation on your D: volume. Note, the factory default of this setting on Windows is enabled. That's why 32 bit midiplayer cannot load unicode filenames on your system. You can enable/set default state on your D: volume by this command:
fsutil 8dot3name set D: 0
Last edited by Falcosoft on 2016-10-20 @ 18:32, edited 3 times in total.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 18:31

"test drive 3 creates strange tones when i use fsmp with "use patch info for capital tone fallback" enabled
i have to disable it and press reset ones even when it is disabled to make midi sound ok with test drive 3"


'Use patch info for capital tone fallback' do more harm than good if you do not set up SC-VA and Midiplayer correctly.
1. You should set SC-VA to SC-55 mode.
2. In Midiplayer-> Instruments->Custom Patch Definitions you should set Roland_SCVA.ins and set melodic to Roland SCVA 55 and drum to Roland SCVA 55 Drumsets.
3. Enable Use patch info for capital tone fallback
4. Also make sure Midiplayer's Reset type is set to 'GS'.

James-F has written about these settings:
http://www.vogons.org/viewtopic.php?p=502706#p502706

PS: I'm not a big gamer myself, so I cannot really help with your gaming issues.
Last edited by Falcosoft on 2016-10-20 @ 18:49, edited 1 time in total.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby K.A.R.R. » 2016-10-20 @ 18:48

Falcosoft wrote:Hi,
Have you read the command's output message? The command worked perfectly :) I do not speak German, but I do understand that 'deaktiviert' means disabled. So you, or some kind of 'tweaking software' disabled 8.3 filename creation on your D: volume. Note, the factory default of this setting on Windows is enabled. That's why 32 bit midiplayer cannot load unicode filenames on your system. You can enable/set default state on your D: volume by this command:
fsutil 8dot3name set D: 0



i enabled it with the command
but it still don't work with the 32 bit version
i dont use any tweaking software
may be its the pro version of windows



Falcosoft wrote:
'Use patch info for capital tone fallback' do more harm than good if you do not set up SC-VA and Midiplayer correctly.
1. You should set SC-VA to SC-55 mode.
2. In Midiplayer-> Instruments->Custom Patch Definitions you should set Roland_SCVA.ins and set melodic to Roland SCVA 55 and drum to Roland SCVA 55 Drumsets.
3. Enable Use patch info for capital tone fallback
4. Also make sure Midiplayer's Reset type is set to 'GS'.

James-F has written about these settings:
http://www.vogons.org/viewtopic.php?p=502706#p502706



i did this but sound is still wrong with "Use patch info for capital tone fallback"

james is using 2 loop midi ports
hmmm
i use loopmidi only for midi in for out i use bassmidi setting
may be i have to change this

i saw he is using savi host too
hmmm not sure if this makes sense using fsmp AND savihost
but without savi host u cannot use loopmidi for output in fsmp
there will be no conenction to the sc va that way
Last edited by K.A.R.R. on 2016-10-20 @ 18:56, edited 1 time in total.
K.A.R.R.
Newbie
 
Posts: 26
Joined: 2014-7-28 @ 19:08
Location: Germany

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 18:56

enabled it with the command
but it still don't work with the 32 bit version
i dont use any tweaking software
may be its the pro version of windows


I'm using Win 10 pro also, it has nothing to do with it.
Please, try the following:
1. Copy your 'Münchner Freiheit - Ohne dich (pr).mid' file and paste it to a different location on your D: drive.
2. Clear Midiplayer's playlist or delete the previous 'Münchner Freiheit - Ohne dich (pr).mid from the playlist.
3. Now open 'Münchner Freiheit - Ohne dich (pr).mid with Midiplayer from the new location.

The reason is, you have just enabled 8.3 short name creation NOW, the existing files do not have this.
Last edited by Falcosoft on 2016-10-20 @ 19:08, edited 1 time in total.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby K.A.R.R. » 2016-10-20 @ 18:59

thx now its working

hmm i guess for dosbox it doesn't matter if i use 32 or 64 bit version of your player
K.A.R.R.
Newbie
 
Posts: 26
Joined: 2014-7-28 @ 19:08
Location: Germany

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 19:36

I have checked TestDrive 3 and it really sounds bad with capital tone fallback, but I have found the reason.

@James-F:
We have decided that drums/percussion fallback should follow the way of using the last valid program. In case of Test drive 3 the used program on channel 10 (drums) is 115. There is no defined drum program 115 on the SC-55. The last valid program is 56 that is SFX. So Midiplayer sets program to 56 SFX, but it sounds bad. Is this simply a programming error of TD3 or should we alter the drum channel Capital tone fallback mechanism? How does TD3 behaves on your real SC-55?
Thanks in advance.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby James-F » 2016-10-20 @ 20:04

Our decision of how capital tone fallback should work is based on well documented Yamaha XG and Roland GS standards.
A single flawed midi file is absolutely no reason to even think about it.

EDIT:
Here are some observations of how Drum CTF behaves on various Roland models:
http://www.vogons.org/viewtopic.php?f=46&t=37047&start=20#p501846

All Roland units including SC-VA will use last correct Drum program if the desired one is non existent.
Capital Tone Fallback is there to correct lazy or missed programming and should not be relied on to play corrupt midi files like they are not, especially for the drum track.
Program 115 is nowhere near any drum patch I know of on any midi standard... definitely corrupt midi.

EDIT2:
Maybe a NONE/Disable setting for the drum section of the CTF will be useful to retain the native behavior?
Last edited by James-F on 2016-10-20 @ 20:51, edited 1 time in total.
User avatar
James-F
Oldbie
 
Posts: 1384
Joined: 2015-11-30 @ 04:10

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 20:50

All Roland units including SC-VA will use last correct Drum program if the desired one is non existent.


I cannot confirm this. SC-VA definitely uses the last USED program on drum channels. But we use the last (latest) EXISTING program for fallback. So you do not have a consistent behavior in SC-VA. If you have selected e.g. program 48 orchestra and then program 115 you will still get orchestra. But if you have selected program 0 standard and then program 115 you will still get program 0 standard.
Last edited by Falcosoft on 2016-10-20 @ 20:52, edited 1 time in total.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby James-F » 2016-10-20 @ 20:52

This is what I said.
Yamaha S-YXG50 behaves the same.

Maybe it would be wise to include DISABLE option individually for Instruments and Drums.
Last edited by James-F on 2016-10-20 @ 20:53, edited 1 time in total.
User avatar
James-F
Oldbie
 
Posts: 1384
Joined: 2015-11-30 @ 04:10

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 20:53

Ah, OK.
I have edited my post : "But we use the last (latest) EXISTING program for fallback".
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby K.A.R.R. » 2016-10-20 @ 20:53

wing commander 2 sounds also wrong

seems its more complex to get midi working with all games than i thought

hmm may be munt would be an alternative for mt32 emulation
K.A.R.R.
Newbie
 
Posts: 26
Joined: 2014-7-28 @ 19:08
Location: Germany

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 21:04

Maybe it would be wise to include DISABLE option individually for Instruments and Drums.

I think you are right.

hmm may be munt would be an alternative for mt32 emulation

It's definitely worth a try.
Last edited by Falcosoft on 2016-10-20 @ 21:07, edited 1 time in total.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby James-F » 2016-10-20 @ 21:06

K.A.R.R. wrote:wing commander 2 sounds also wrong

WC1 and WC2 are composed on the MT32 so use MUNT.
The MT32 emulation on the SC-55 (hardware or software) does not sound good.
User avatar
James-F
Oldbie
 
Posts: 1384
Joined: 2015-11-30 @ 04:10

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-20 @ 21:38

Hi,
@James-F:
According to Cloudschatze investigation:
So, circling back to this, the problem is that the SC-55 does allow for the selection of non-existent drum sets. Not only that, but, having done some thorough testing, I've discovered that the program change behavior for the drum sets is different between the 1.xx and 2.xx SC-55s.

SC-55 1.00 - 1.21
------------------------
PC# 001-008: STANDARD
PC# 009-016: ROOM
PC# 017-024: POWER
PC# 025: ELECTRONIC
PC# 026: TR-808
PC# 027-032: ELECTRONIC
PC# 033-040: JAZZ
PC# 041-048: BRUSH
PC# 049-056: ORCHESTRA
PC# 057-064: SFX
PC# 065-127: <<silence>>
PC# 128: CM-64/32L


deriving some conclusion from this, the current Drum CTF implementation in midiplayer is not strictly correct beetween PC# 65 - 127. I think a good compromise would be to use PC# 0 STANDARD in this range. That would also correct the bug with TD3.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby K.A.R.R. » 2016-10-20 @ 21:39

yep its working :-)
test drive 3 sounds a bit better with mt32 compared to sc-55 from sc va

but for midi file playback sc va sounds better
but mt 32 is not too bad
K.A.R.R.
Newbie
 
Posts: 26
Joined: 2014-7-28 @ 19:08
Location: Germany

Re: Falcosoft Soundfont Midi Player

Postby James-F » 2016-10-21 @ 05:37

Well Falco, first we must understand what we are dealing with here.
A midi file or game that that has a programming mistake which the developers missed, but on their midi module it sounded correct is very rare.
What is even more rare is a drum patch number that is far from any usable patch in the GM, GS or XG standard, and can probably be considered a big programming mistake that sounded like STANDARD drum patch because that is what the unit is booted with, a correct "last used correct drum patch" is the standard behavior on all modern midi modules.

We have several options:
1. Disable = Bypassed CTF on Drums, let the plugin/module retain its behavior.
2. CTF to lowest available patch (what we are using now).
3. Return to #00 Standard, if patch not available.
4. A combination of 2 and 3 like you suggested after the highest usable drum patch 56 on the SC-55.

The solution we choose to implement depends on what will fix the largest amount of programming mistakes or corrupt files and sound closer to what the composer intended.

Number 1 of the above list is already a good solution if we assume that the file/game is played without a "correction software" in between the source and destination, so if the music sounds wrong to the end-user he just accepts that the source is bad and doesn't proceed to annoyingly complain to the "CTF correction software" developer that his midi sounds bad. :happy:
But, Number 4 is the solution that would cover the most ground in terms of documented CTF behavior and Corrupted source both combined.

Keep in mind that more options in FSMP is more reasons for new users to complain about FSMP making their corrupt midis sound bad, or not display a lyrics text.
User avatar
James-F
Oldbie
 
Posts: 1384
Joined: 2015-11-30 @ 04:10

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-21 @ 07:22

Hi,
That's exactly what I think about the situation, especially this sentence is the one I most agree with :)
Keep in mind that more options in FSMP is more reasons for new users to complain about FSMP making their corrupt midis sound bad, or not display a lyrics text.

Thanks for making this clear and explicit.
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby Falcosoft » 2016-10-24 @ 22:26

Hi,
New test version uploaded.
http://falcosoft.hu/midiplayer_41_test.zip
1. Added Bass/Treble configuration. You can invoke it by right clicking the corresponding trackbar.
2. Fixed drum CTF by sending default program 0 in 56 -127 range.
3. Auto remove non-existent files from playlists at load time.
4. Fixed regression pressing reset not resetting instruments.
5. Fixed Esc handling in modal dialogs (even if 'Esc to Quit' is enabled pressing Esc in modal dialogs does not close the application, only the dialog).
User avatar
Falcosoft
Member
 
Posts: 313
Joined: 2016-5-21 @ 13:46
Location: Hungary

Re: Falcosoft Soundfont Midi Player

Postby James-F » 2016-10-25 @ 12:28

Great, Thank you!
The EQ frequency is a nice addition to those who understand.
User avatar
James-F
Oldbie
 
Posts: 1384
Joined: 2015-11-30 @ 04:10

PreviousNext

Return to Release Announcements

Who is online

Users browsing this forum: Google Feedfetcher and 3 guests