ScummVM support for <=Windows 2000 dropped

Schedules and announcements about program releases.

Re: ScummVM support for <=Windows 2000 dropped

Postby DosFreak » 2018-12-15 @ 16:18

Okay mabye I'm crazy but now I think XP support has been dropped. Can someone try the latest 32bit development build on XP to confirm?
https://buildbot.scummvm.org/builds.html

The stable build from Jan 2018 works fine for me.

Does no one test anything anymore?

Checked the ticket for the 9x issue and looks like the fix was commited. I'd like to compile a ScummVM build with SDL1 to verify since buildbot only builds ScummVM with SDL2 now and I guess only supports Vista and above.
User avatar
DosFreak
l33t++
 
Posts: 10054
Joined: 2002-6-30 @ 16:35
Location: Your Head

Re: ScummVM support for <=Windows 2000 dropped

Postby DosFreak » 2018-12-20 @ 13:00

Good news! That commit fixed it. Details here:
https://bugs.scummvm.org/ticket/10613#comment:21

I've attached a binary as proof but don't use it for anything serious since I didn't add all the dependencies. This will work on 95,NT4 and above.

For a future guide:

Scummvm built with Mingw-W64 w/ gcc 7.3.0 and 8.0 are incompatible with ScummVM for <XP:
https://sourceforge.net/projects/mingw- ... n32/dwarf/
https://sourceforge.net/projects/mingw- ... n32/dwarf/

error:
___mb_cur_max_func in msvcrt.dll
https://sourceforge.net/p/mingw-w64/mai ... /36106593/

Think I already checked but need to verify that the above doesn't exist in the latest v6 msvcrt

Use this version:
https://sourceforge.net/projects/mingw- ... v5-rev1.7z


Need to track down when committed after 7.2.0



From MINGW shell:

git clone https://github.com/scummvm/scummvm.git scummvm
./configure --disable-sparkle
make
strip scummvm.exe



UNTESTED
From MSYS2 shell:
pacman -S --needed --noconfirm git mingw-w64-i686-{curl,faad2,freetype,flac,fluidsynth,libjpeg-turbo,libogg,libvorbis,libmad,libmpeg2-git,libtheora,libpng,nasm,readline,toolchain,zlib}
REMOVE SDL2,SDL2_net,winsparkle
Attachments
Scummvm2.1.0-12202018.zip
(15.89 MiB) Downloaded 2 times
User avatar
DosFreak
l33t++
 
Posts: 10054
Joined: 2002-6-30 @ 16:35
Location: Your Head

Re: ScummVM support for <=Windows 2000 dropped

Postby DosFreak » 2019-1-16 @ 21:54

Looks like the development builds support XP again. Also works on Windows 2000 with Blackwingcat Extended Kernel 2.9b w/ QindieGL in Vmware v14. Still need to compile a SDL1 build with all the dependencies. (Last build I posted has some missing).
User avatar
DosFreak
l33t++
 
Posts: 10054
Joined: 2002-6-30 @ 16:35
Location: Your Head

Previous

Return to Release Announcements

Who is online

Users browsing this forum: No registered users and 3 guests