Peixoto's patches for a few old games

Schedules and announcements about program releases.

Re: Peixoto's patches for a few old games

Postby Zaphero » 2019-1-08 @ 20:22

Peixoto wrote:
Zaphero wrote:I'm having problems with trying to get Mysteries of the Sith working. Every time I enable 3D acceleration the HUD is present but the rest of the screen is pink. I am using the Steam Release and the unofficial patch (JKM.exe, I have been using that exe and have not renamed it). Can you please help?



Try to update your drives (long shot). Color key is not working on directdraw blits for some reazon

It seems like all my drivers are already up to date. More specifically the ammo counter is staying on screen while the rest of the screen is pink.
Zaphero
Newbie
 
Posts: 2
Joined: 2019-1-07 @ 22:29

Re: Peixoto's patches for a few old games

Postby giovannilucca » 2019-1-13 @ 23:00

giovannilucca wrote:
giovannilucca wrote:
giovannilucca wrote:Hey Peixoto!

I'm having an weird issue since yesterday..
I click the Help.exe and nothing happens... the patch don't open...

I reinstalled my windows machine some days before, but after that I used the patch and it was working normal
I installed the Dependencies written on the readme.txt, but nothing happens...
I download the updated version that you upload yesterday and is no Working too...
I disable the windows 10 antivirus, and nothing...
I never had this issue before...
Do you have any clue of what can be?

Idk if it helps, but here is the text on error.log:



Well, I had to format and reinstall WIndows 10 for everything to work!
I'm almost sure that the Windows 10 native antivirus blocked the file, even though I have disabled that crap!

Anyway... It's all fine now! :)



It happens again! :(
I was using the patch this morning and everything was working fine...
My windows 10 antivirus is blocked, the smart screen too...
I now the patch doesn't launch... even as administrator or with different compatibility modes.

Maybe is something in the new version of the patch?
I never had this issue before...

I don't have here an older version of the patch to test it, but if you can send me, we can test this theory!


giovannilucca wrote:
Peixoto wrote:The last update only included an small change in the tomb2.ahk file. Help.exe wwas not changed

Have you checked the task manager to see if it is running or not?

In any case try this: https://1drv.ms/u/s!ApHOE-Ru-xkG5UxYLSM0V_BHTZQw Press the F5 key until there is no change
then post here what it shows


I solved the problem for good now!
I installed Windows 7, and everyting is running smooth!
The thing is that is a bug in Windows 10 that make some .exe unexecutable... I made a research about this matter and I found a lot of guides to solve the problem, but none of them solved... So I said good bye to that **** that is Windows 10, and reinstalled my machine with W7.

Before I tried to run your patch on Linux using steam proton... It almost worked... The game open and all... but the screen is black!
I'll try again later when new versions of steam proton is available!

Thanks for the help anyway! ;)

Hey Peixoto!
It happened again, even on Windows 7, with firewall disable and with no anti-virus... :(
I tried to reinstall everything (I downloaded the latest update from 03 jan 2019) and even so it doesnt work...

I tried this trick on the windows reg file:

Code: Select all
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
"exefile"=hex(0):


But even so, don't launch the program...
I checked if there is another instance of the program already running (which doesn't). I rebooted the system... nothing seems to help...

I just wanted to inform you so you can check this when you have the time! ;)
giovannilucca
Newbie
 
Posts: 6
Joined: 2018-10-09 @ 16:00

Re: Peixoto's patches for a few old games

Postby Peixoto » 2019-1-15 @ 19:08

giovannilucca wrote:
Hey Peixoto!
It happened again, even on Windows 7, with firewall disable and with no anti-virus... :(
I tried to reinstall everything (I downloaded the latest update from 03 jan 2019) and even so it doesnt work...

I tried this trick on the windows reg file:

Code: Select all
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
"exefile"=hex(0):


But even so, don't launch the program...
I checked if there is another instance of the program already running (which doesn't). I rebooted the system... nothing seems to help...

I just wanted to inform you so you can check this when you have the time! ;)



You got to find what changed in your system. Maybe some program you installed
User avatar
Peixoto
Member
 
Posts: 197
Joined: 2013-6-13 @ 23:48

Re: Peixoto's patches for a few old games

Postby giovannilucca » 2019-1-16 @ 16:55

Peixoto wrote:
giovannilucca wrote:
Hey Peixoto!
It happened again, even on Windows 7, with firewall disable and with no anti-virus... :(
I tried to reinstall everything (I downloaded the latest update from 03 jan 2019) and even so it doesnt work...

I tried this trick on the windows reg file:

Code: Select all
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
"exefile"=hex(0):


But even so, don't launch the program...
I checked if there is another instance of the program already running (which doesn't). I rebooted the system... nothing seems to help...

I just wanted to inform you so you can check this when you have the time! ;)



You got to find what changed in your system. Maybe some program you installed


Yeah, I know it's not normal this happens, And there's nothing you can do about it...
The only thing that leads me to alert you about this, is because it is happening only with your patch... everything else is working fine...
And this happens in 2 different operacional system, WIndows 10 and 7...
Even tho I don't have install any antiviruses, I suspect that that windows firewall is blocking assuming that it is a virus.
I'll do another system reinstall now and block completly the windows security system... Let's see what happens...

Did you have another one complaining about this issue? or I'm the only one?
giovannilucca
Newbie
 
Posts: 6
Joined: 2018-10-09 @ 16:00

Re: Peixoto's patches for a few old games

Postby Deffnator » 2019-1-18 @ 00:04

hey peixoto, have you tried to speak with the PGXP guys about the code?
maybe it can be ported to yours for RE and such
Deffnator
Newbie
 
Posts: 38
Joined: 2018-9-05 @ 01:03

Previous

Return to Release Announcements

Who is online

Users browsing this forum: No registered users and 2 guests