Reply 20 of 31, by HunterZ

User metadata
Rank l33t++

Well, I got Daggerfall working under WinXP with VDMS v2.0.4 + update1 + emuadlib v1.0.4.4 + launchpad v1.0.0.7. I did the following:
1. Installed the CD I mentioned
2. Copied to the hard drive all files from the ARENA2 directory (and subdirectories) that were on the CD but not the hard drive
3. Edited the z.cfg file to point the cd path at the hard drive and changed the install size from dfall_large to dfall_huge
4. Made a batch file that says:
set dos4gvm=@dagger.vmc
fall.exe z.cfg
5. Ran the sound config program with VDMS to set up Sound Blaster sound and Roland Sound Canvas MIDI (I have a GM/GS soundfont installed)
6. Ran the batch file with VDMS via launchpad

The game runs as well as it did under Win9x on this computer, which is to say that everything is fine except for some major bugs:
- Walking is too slow
- Jumping is too weak
- Climbing is too hard

I tried using speedset v1.0.2 in the batch file, but it seems to have little effect. If I go much lower than -25 the game doesnt seem to want to load. I'm not sure how well other slowdown utilities will work. Under Win9x or pure DOS, moslo never worked very well (sometimes it would fix the problem but the game would be choppy). I had another program called SLOW (a hack oif AT-SLOW) but I dont know that it would work too well in WinXP.

I tried emailing Bethesda about this years ago when I first got this PII-450, but they never believed the problems I continue to have with Daggerfall to this day. Maybe I could underclock my CPU on the fly or something, but that would make VDMS run worse probably. Oh well.

Reply 21 of 31, by HunterZ

User metadata
Rank l33t++

Just wanted to add another tidbit: I dut out that SLOW.COM utility and experimented with using it in conjunction with SPEEDSET (is it redundant to use them together? Seems to be doing the job...). If anyone is interested in trying or examining SLOW.COM, I've attached it here (along with some other utilities someone emailed me once to help me get Daggerfall working on my PII-450). Also, here's the batch file I launch Daggerfall with:

@echo off
set dos4gvm=@dagger.vmc
speedset -20
slow /t30000 /8
fall.exe z.cfg
slow /r

I get random crashes sometimes, but the game was always buggy anyhow. It also doesnt seem to like when other Windows apps steal focus - the game often dies when I try to switch back to it.

I'm not sure, but maybe I shouldn't be using speedset at all? I'm not sure what the difference between it and other slowdown utilities is. I'm assuming most slowdown utilities either generate lots of interrupts to bog things down, or else they throttle system timers, so I guess I don't know much about slowdown utilities period :p

Reply 22 of 31, by Bile Demon

User metadata

Hey, i also tried to get Daggerfall to work on my NT5 system.
I'd appreciate some help, thanks in advance.

Installation from CD doesn't work for me, so i used DagNt5x or whatever its called and some other installation helper. I got it to run with both of em and used VDMSound with the game. Sound and everything is great, it even plays the Flics from the CD and i see the main menu. As soon as i start a new game and select a land on the map for my char and i click on it the PC beeps and Daggerfall shows an error code 201 to 210 or so, depending on which land i choose. Loading savegames also shows the corresponding error. The game wants me to either continue or reboot. VDMSound closes the game on continue.

This error appears on all configurations of VDMSound, even if i switch sound off and use minimal configuration. I'd really like to play Daggerfall.
The No-CD hint didn't work for me either. Daggerfall showed an error 1 and closed. I guess i didn't forget any step, but on the other hand ... i think i got it to work some time ago under Win98.

Well, my system specs, if that's helpful:

Windows 2000 SP2
AMD Duron 600 MHz
256 MB PC-133
Soundblaster ISA AWE 64 Gold (Daggerfall detects correctly on VDMSound and sound works, as stated above)
ATI Rage 3D 4 MB + Voodoo2 12 MB.
(ATI works for Daggerfall and Voodoo is unused but that's obvious, just a matter of my complete list 😉 )

Well, that's it. I hope it's not some kind of software conflict or something like that. I use motherboard monitor for example and i heard VDMSound doesn't like that tool. Duke 3D worked with it, but without sound - Daggerfall runs with sound but crashes at the point of creating a char.

I read about many people getting Daggerfall to run on their systems. Pity it's not my chance to see it work correctly. I'd easily accept the fact that the game will crash randomly - it did that on Win98 as well. But the main menu is not enough for me 🙁

Reply 23 of 31, by HunterZ

User metadata
Rank l33t++

I've never been able to get it running 100% either. My guess is that maybe you need to copy some files from the original game CD to your hard drive to use the no-cd trick? (like all the files from the FALL folder if I remember correctly)

I don't know what you mean by no-cd trick though. The batch file I posted will run it without the CD, *if* you have all the needed files copied from it (be sure not to overwrite files with older versions - the game is buggy enough as is)

Last edited by HunterZ on 2003-05-26, 20:27. Edited 1 time in total.

Reply 24 of 31, by Bile Demon

User metadata

Nope, not for me.
I know that "Fall.exe z.cfg" starts Daggerfall without using the CD unless you didn't forget to change the path and copy over the files from the CD (ARCH3D.BSA and that soundfile too).
I use that "The Elder Scrolls: Daggerfall Setup Windows Installation" tool (dfinstall.exe - 128 kbyte size) that has options to alter z.cfg and install the patch plus let it run without CD and so on. I check all options, it installs the game and patches it. I even check the z.cfg file and try to run Daggerfall - it detects an error 0 and closes, like before.

I tried to do a "perfect" reinstall once again. This is the result (using your batchfile, without the slowdown tools since i don't believe the problem appears due to too fast CPU):

(i click on Hammerfell on the map for example)

"Daggerfall has encountered an internal error at 0.
The error reported was: Code: 210 not found in

The exact error, when trying to run without CD:

"Daggerfall has detected the error 0.
Press RETURN TO quit...

Chaining to default exception handler..."

Any idea what i'm doing wrong?

Reply 25 of 31, by HunterZ

User metadata
Rank l33t++

This is the result (using your batchfile, without the slowdown tools since i don't believe the problem appears due to too fast CPU):

You might change your mind once you realize that you can't walk backwards due to CPU speed sensitivity issues in the game that are solved (or at least greatly helped) by a slowdown utility. Without a slowdown utility I can barely climb, jump, or walk any direction other than forwards. With one I can do all of them. Anyways:

Any idea what i'm doing wrong?

I've never got that error - well, at least not consistently enough to remember it. Maybe your VDMSound settings are different than mine? Are you using a fully-updated version? Here are my LaunchPad settings for Daggerfall (NOTE: any field not mentioned is blanked/unchecked!):

Program: D:\DAGGER\dagger.bat
Fast Paste
All shortcuts checked

Enable DPMI
(may need to enable low-level CD-ROM if trying to run without no-CD)

DOS Env:
Allow UMBs
Additional options
Additional options

Polling period: 5/15

Enable MIDI
Port 0x330 IRQ 2
SysEx Scroll Lock
Mapping identity.map
Output Dev Microsoft MIDI Mapper

Port 0x388
Synth 11025Hz
Dev Primary (DirectSound)
Buffer 75ms

Port 0x220 IRQ 7 8bit DMA 1
DSP 4.05 16-bit DMA 5
Dev Primary (DirectSound)
Buffer 75ms



Note that Daggerfall does not need EMS or XMS because its built in DOS extender (CauseWay) can use Windows DPMI memory services, which are probably more stable anyways. Also note that I am using SB16/AWE32 as the digital device and Roland Sound Canvas as the MIDI Device in the Setup program. Also, here is my Z.CFG for comparison:

type dfall_huge
path d:\dagger\arena2\
pathcd d:\dagger\arena2\
fadecolor 0
mapfile d
rendergame 1
user 1
startMap 179
region 17
helmet 0
maxSpeed 200
controls betaplyr.dat
maps mapsave.sav

Good luck.

Reply 26 of 31, by Bile Demon

User metadata

YES!!! It works! I just made it out of Privateer's Hold for a test run 😁

It struck me like hell when i read your z.cfg-file. I prolly did the stupidest thing one could do to a DOS game: I installed it to a non 8.3-char compliant path and tried to get it to run like that.
(i think i can remember now that i already stumbled into that trap some years ago...)
Damn me, i wouldn't have found out if you had not pasted your config here. Dunno how many more vain daggerfall-installs i would have needed to get the clue finally.
I thank you so much for your efforts to help me and solve my problem, HunterZ. I CAN play Daggerfall now on my system and i'm incredibly happy 😀

That one stupid mistake even solved both errors. It runs without the CD and doesn't show any errors when selecting sth. on the map. (I guess these were simple file not found errors, but that wouldn't have helped me anyway). The game is completely playable ... at least for now, maybe after the first crash i'll think about this once more 😉

Btw. my CPU doesn't seem to be fast enough to be a problem for Daggerfall's control timing or whatever. I could walk into any direction and jump and climb and anything without the use of a slowdown tool. I assume it's more of a matter of "modern" GHz-monsters or so rather than my good old Duron 600, heh. Guess i'm lucky regarding that topic ...

Anyway, thanks again to you, i greatly appreciate your efforts.
Don't forget to "rest well this night - for tomorrow you'll sail for the kingdom of Daggerfall" 😉
Daggerfall is 7 years old, but it's an alltime-classic and i'm sure i'll still play Daggerfall in five years and even later.

Bye for now,
Bile Demon

Reply 27 of 31, by HunterZ

User metadata
Rank l33t++

That's great news! Hmm... I wonder if perhaps you don't have the problems I have due to the fact that yours is an AMD CPU... I've had this problem both on Intel PII-450 and PIII-550 systems 🙁 It seems to work fine with the slowdown utils though so I guess it's not a huge deal.

I've been playing Morrowind lately, and I miss a lot of things that didn't carry over from Daggerfall (bright colourful graphics, tons of good music, random quests, doesn't run slow on a PIII-550 😉) I never beat Daggerfall (but then again I haven't managed to beat any TES game), so maybe I'll come back to it soon.

Reply 29 of 31, by HunterZ

User metadata
Rank l33t++

Yes but it might not be a raw speed issue. It may instead be some other issue, such as the timing of various instructions, or the optimizations that the processors do internally (caching, pipelining...), or even different quirks in backwards-compatability with older instuction sets (Daggerfall runs on a 486, and for all I know only uses 386-specific instructions).

Here are some of the commonalities I can think of between my two systems (or rather one system evolving over time):
- AGP nVidia graphics card
- Intel 440BX motherboard chipset
- USB mouse (I used to have a PS/2 but I don't remember if I tried it at that time or not)
- PS/2 keyboard
- Intel CPU
- Creative Labs PCI sound card

And some differences:
- Pure DOS 7, Win98, Win98SE, Win2K, WinXP
- Intel PII-450 and PIII-550
- 192MB RAM, 384MB RAM, 512MB RAM (all PC100)
- Gigabyte vs. Gateway mobos (same chipset though)
- SB PCI128, SB Live
- Aztech vs. 3Com/Gateway winmodem vs. no modem at all
- nVidia TNT1 vs. GF2MX

In my mind it's most likely related to one or more of the following:
- Intel PII/PIII-era CPUs
- Intel 440BX chipset
- nVidia video card
- Having lots of RAM (like maybe more than 32, 64, or 128 or something?)

I would also suggest that it might be the PCI sound card, but that doesn't make sense when running under VDMSound.

So as you can see it's perfectly logical 😜

Reply 31 of 31, by HunterZ

User metadata
Rank l33t++
Snover wrote:

Make an MD5 checksum of the files on the CD and upload that file, please. Get an MD5sum program here

What did you want that for anyways? Did you ever use it for whatever evil scheme you had?

Nah, dude, I'm afraid I'm gonna hafta revoke your title, as that is clearly not at all logical.

Heh, I think that *still* has a good shot at qualifying as "More Logical than Nicht".