A fast 486 that isn't (a 486)

Showcase your Retro PC / Build logs.

A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-15 @ 09:41

I've been putting this thing together over the last few months as the mood strikes me - a nice way to do things compared to my usual rabid push to get things done ASAP. It came about because I spotted an AT flip top case locally and I've been on the lookout for a replacement for years after an attempt to paint my last one ended in tears.

Hey, that rhymes.

This one is just another classic early 90’s clone. Cheaply made, functional, and sent to landfill in droves when the WWW took off and people upgraded to Pentiums. They’re getting hard to find around here these days and the condition of this one was a little rough, so it took some patient cleaning-up to get into a useable state. The drive bay covers - which I suspect aren't original - were the only yellowed plastic but came up OK with some sanding / respraying with clear semi-gloss.

The PSU was a challenge because where I'd usually just toss the old one and install a new StarTech AT unit, this case is a side-switcher (one of the reasons I bought it)(nostalgia), so I ended up gutting the original unit and switching in the contents of a StarTech unit instead. That worked well in the end but was fiddly, with some removal of components / soldering required.

The motherboard is the mighty ASUS VLI-486SV2GX4 rev. 2.1, which is almost too easy to work with to be considered a real 486 board. Still lots of jumpers, but they're clearly layed out and the board works like a charm with all 486, 586, and POD CPUs I've thrown at it over the years. For this machine I went with a POD83 I've had sitting around for a while - I already have an SX33 machine so I was looking for something a little more exotic here. The CPU fan was noisy which was dissapointing considering it's new-old-stock, but opening it up and giving it a lube sorted it out.

The VGA card is another NOS item I've had sitting around - it's a no-name S3-805 based VLB number which I upgraded to 2MB of RAM. I've been really impressed with this thing so far - VESA 1.2 out of the box (3.0 with SDD) and the image quality is beautiful in VGA and low-res SVGA. I need to copy the driver off the 5.25 floppy and max out the resolution in Windows 3.11 to see how that image quality holds up, but this is a DOS gaming machine so it's perfect in that context.

For sound I've dropped in an AWE64 Value that I've been avoiding for years for no reason other than it's just too easy. The AWE64 sounds amazing I think, the drivers / software are great, and CQM sounds really good with some reverb and chorus added. The AWE side of things is OK - not a patch on a half decent GM device in most titles but easily holds its own when it's used properly; X-Wing is a good example of how good it can sound. And just in case I'm in the mood for loading up some sound fonts in Windows 3.11 (very unlikely!) I've snuck in a 32MB memory expansion (28MB useable) via the amazing SimmConn, which is out of production now I think but used to be available for 20 bucks or so.

I'm using a period correct HDD for the boring stuff like OS, etc, but I always like a IDE->CF adapter for games, machine specific drivers, etc so that I can easily transfer files and back it all up. I usually use an externally accessible unit but I didn't have one handy, and given it's so easy to flip the lid on this thing I thought the internal option was just fine. There's a 50% chance that these things don't work in my experience but I got lucky with this one.

Performance wise it's pretty impressive for a "486". DOOM runs smoothly and Duke3D is quite playable, though you can notice some slowdown even in VGA mode. C&C is OK-ish but Warcraft II doesn't feel playable to me - I played all of these games and more on my trusty DX2 66 back in the day but it's hard to un-see everything that's happened since the mid 90's. Pixelated graphics I can do, low frame rates are a bridge too far.

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby Skyscraper » 2018-4-15 @ 15:17

Nice!
Main PC: Dual Xeon X5690@4.6ghz, Evga - SR-2, 48gb memory, Intel X25-M g2 SSD and a Nvidia GTX 980 ti.
Retro PC #3: K6-2 450@500mhz, PC-Chips m577, 256mb sdram, AWE64 and a Voodoo Banshee.
Skyscraper
l33t
 
Posts: 3314
Joined: 2013-9-18 @ 15:36
Location: Sweden

Re: A fast 486 that isn't (a 486)

Postby amadeus777999 » 2018-4-15 @ 15:51

Beautiful machine - the original boxes are a nice touch.
A "wolf in sheep's clothing" processor wise.
User avatar
amadeus777999
Member
 
Posts: 416
Joined: 2013-7-04 @ 17:04

Re: A fast 486 that isn't (a 486)

Postby keropi » 2018-4-15 @ 17:05

very nice build and new stuff used! jealous! :D
User avatar
keropi
l33t++
 
Posts: 6349
Joined: 2003-9-08 @ 06:45
Location: Greece

Re: A fast 486 that isn't (a 486)

Postby SW-SSG » 2018-4-15 @ 17:34

Nice build!

badmojo wrote:I'm using a period correct HDD for the boring stuff like OS, etc, ...

Hmm, which one?
[ThinkPad A30] PIII-M 1133MHz, 256MB PC-133, 30GB 4200RPM, ATI R7000 16MB, 15" 1024x768px, WinXP Pro+Win98SE
User avatar
SW-SSG
Member
 
Posts: 338
Joined: 2016-9-29 @ 03:44
Location: Canada

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-15 @ 21:05

SW-SSG wrote:
badmojo wrote:I'm using a period correct HDD for the boring stuff like OS, etc, ...

Hmm, which one?


Ha, this is a bit embarrassing but I can’t remember! I went through 3 or 4 before I found one without bad sectors so I lost track - a 850MB Quantum Pro something-or-other I think.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby MMaximus » 2018-4-16 @ 11:33

Great build and congratulations on the refurbishment... Looks like new! This flip-top model of case is quite cool as it doesn't require any screws to pop it open. I have what looks to be the exact same model for my turbo XT:

Image

I also like the idea of having a cable adapter for the AT-PS/2 connection. I've always used standalone adapters but it makes for a very long connection at the back of the chassis. Ideally I'd like to find a short cable like the one you're using, but AT to AT, in order to preserve the connector on the motherboard as I unplug my AT keyboard often and the connector is quite stiff. I've been thinking of using a short midi cable for this purpose, not sure if it would work though.
User avatar
MMaximus
Member
 
Posts: 411
Joined: 2014-3-30 @ 20:28

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-16 @ 23:03

Yep that's it! Different buttons I notice so there's a chance that it's just another clone that looks very similar - I've seen a few lately that look identical at first glance but turned out to be fundamentally different on closer inspection.

Yes the cable is great - I used those hard adapters for a while but it puts a lot of pressure on the motherboard connector if you bump it so the cable is good from that perspective too.

Amazing looking XT BTW!
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby jheronimus » 2018-4-17 @ 00:07

Awesome build! Congratulations!

badmojo wrote:For sound I've dropped in an AWE64 Value that I've been avoiding for years for no reason other than it's just too easy. The AWE64 sounds amazing I think, the drivers / software are great, and CQM sounds really good with some reverb and chorus added. The AWE side of things is OK - not a patch on a half decent GM device in most titles but easily holds its own when it's used properly; X-Wing is a good example of how good it can sound. And just in case I'm in the mood for loading up some sound fonts in Windows 3.11 (very unlikely!) I've snuck in a 32MB memory expansion (28MB useable) via the amazing SimmConn, which is out of production now I think but used to be available for 20 bucks or so.


Now this is very interesting. You can actually load sf2 soundfonts under Windows 3.11? Can you also play protected mode games that way? What are the limitations compared to Win95?

I'm currently working on a DX4-100/16MB RAM/S3 805 machine that will host an AWE32 with 32MB and GUS with 8MB. I've already finished the build itself and I've installed Win95 RTM on it. The Windows itself runs sort of okay. But Doom is absolutely unplayable if I run it through Windows! I would really love to go back to DOS 6.22+Windows 3.11 if that means I get to use AWE32 properly. It's definitely a more appropriate Windows version for any 486.
Socket 7: Pentium 166; 64MB RAM; Matrox Millenium+Voodoo 1; AWE32 PnP w/28MB + GUS PnP Pro w/8MB
Slot 1: Pentium III 500; 384MB RAM; Voodoo 5 5500 AGP; AWE64 Value w/8MB + Diamond Monster Sound MX300 + SoundBlaster Live!
User avatar
jheronimus
Oldbie
 
Posts: 815
Joined: 2015-12-10 @ 00:09
Location: Moscow

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-17 @ 12:06

Indeed you can load sound fonts in exactly the same way as you can in Win95, i.e. via the AWE control panel. However I couldn't get DOOM to make a peep with General Midi selected for music and a sound font loaded. I only tried for all of 15 mins so it might still be possible - DOOM's performance appeared to have taken a bit of a hit when running in Windows 3.11 so that's another factor.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby James-F » 2018-4-17 @ 15:36

A slick build !
Very nice badmojo !

*Peroxide 40 Vol 12% for the Yellow plastic.
User avatar
James-F
Oldbie
 
Posts: 1428
Joined: 2015-11-30 @ 04:10

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-17 @ 23:03

James-F wrote:Very nice badmojo !

*Peroxide 40 Vol 12% for the Yellow plastic.


Thankyou!

Yes I did try retrobrite-ing the plastic as I've done a few times before, but the results are always unimpressive. Someone on another forum suggested a different method though - peroxide only (I used a solution of peroxide, water, and oxi powder), parts go into a ziplock bag and placed in direct sun. I might try that one day.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby chinny22 » 2018-4-19 @ 15:59

Cant have a POD lying around doing nothing can you!

AWE64 is probably good match really, Games that want adlib sound are better off with one of your slower PC's anyway and its always fun to compare OPL to CQM just like AWE to GM.
I grabbed a simmconn adapter for my AWE64 value as well when I found out no were been made but still haven't even opened it yet. Soundfonts, even the AWE really is just a curiosity now decent midi devices are decent prices.

Also a fan of a real HDD for the OS and CF for games. that way you get the nostalgic HDD sounds during boot but the speed and realilibility when playing games.

I was bit underwhelmed with my Pod 83 compared with my DX2/66. I was thinking game like Duke3d and Terminal Velocity which ran ok on the 66 would be smooth as butter on the POD. Despite these late CPU's I guess socket 3 was well and truly outdated once SVGA gaming was a thing.
User avatar
chinny22
Oldbie
 
Posts: 1795
Joined: 2011-8-26 @ 12:02
Location: Australian but living in the UK for now

Re: A fast 486 that isn't (a 486)

Postby amadeus777999 » 2018-4-19 @ 18:48

Regarding retrobrite-ing - the 8bit guy said in a vid that the best method was putting the plastic pieces into a pot filled with peroxid and heating it up to around 60 degrees celsius.

The Pentium Overdrive has to work on a castrated bus.
I also read, on a site i forgot the name of, that the second pipeline is disabled, which furthermore decreases performance in addition to the low clock speed. This doesn't get mentioned often, but would make perfect sense in light of only having a 32bit wide bus available.
User avatar
amadeus777999
Member
 
Posts: 416
Joined: 2013-7-04 @ 17:04

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-20 @ 06:08

chinny22 wrote:Soundfonts, even the AWE really is just a curiosity now decent midi devices are decent prices.

I was bit underwhelmed with my Pod 83 compared with my DX2/66. I was thinking game like Duke3d and Terminal Velocity which ran ok on the 66 would be smooth as butter on the POD. Despite these late CPU's I guess socket 3 was well and truly outdated once SVGA gaming was a thing.


Yep spot on regarding sounds fonts - they're fun to play around with but I haven't ever gotten serious enough about any of them to use it over my various other hardware GM options. And given how slowly they load with that era hardware I'd have to wait an extra 30 seconds and I'm too old for that :lol:

Gah, now you've got me wanting to ditch the POD and slap a DX2/66 in there! I have way more nostalgic attachment to those and they're fan - and therefore noise - free.

That's the beauty of the flip top case and ZIF socket - I could make the switch in seconds.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby DonutKing » 2018-4-20 @ 08:59

badmojo wrote:
Gah, now you've got me wanting to ditch the POD and slap a DX2/66 in there! I have way more nostalgic attachment to those and they're fan - and therefore noise - free.



That's basically what I did. I ran a POD, then a 5x86-133 but I ended up going back to the DX2/66 because that was the 'sweet spot' CPU for the platform, in my eyes.

Anything much more intensive than Doom, I'd rather play on a faster machine. Even Duke3d, while it can be done on a 486, is just a much nicer experience on a Pentium with SVGA.
If you are squeamish, don't prod the beach rubble.
User avatar
DonutKing
Oldbie
 
Posts: 1783
Joined: 2008-1-03 @ 03:23
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby feipoa » 2018-4-22 @ 04:35

Exciting to see a POD83 build. Not many of these. If I had one more empty 486 era case, I'd probably put a POD in there.

Are you able to use the POD on this motherboard with L1 in write-back mode?

Have you tested your POD at 100 MHz? For my speed preference, running the POD at 83 MHz is just too disappointing compared to Cyrix and AMD 5x86 chips. The ALU of the POD is noticeably slow in comparison. You might want to consider the diode trick to getting your POD running at 100 MHz if it doesn't do so naturally. When paired with a Voodoo2, a POD100 can probably play many 1998 and earlier 3D games.

For games that only use General Midi for music, how do you get the AWE64 to play the music in MS-DOS 6.22 without using an external device on the game port? I had to run the games from within Windows 95 to get the GM emulation working. There is some writeup on Vogons about someone loading sound fonts in DOS, which seem to work, but the computer hangs when trying to play the music.

For my level of patience, I can tolerate up to an 8 MB soundfont file to load at boot. The 8 MB GM soundfont from Creative sounded pretty good to me. I tested it with Abuse and Duke3D.
User avatar
feipoa
l33t++
 
Posts: 5100
Joined: 2011-3-07 @ 13:54
Location: Canada

Re: A fast 486 that isn't (a 486)

Postby badmojo » 2018-4-22 @ 08:43

feipoa wrote:Are you able to use the POD on this motherboard with L1 in write-back mode?

For games that only use General Midi for music, how do you get the AWE64 to play the music in MS-DOS 6.22 without using an external device on the game port? I had to run the games from within Windows 95 to get the GM emulation working. There is some writeup on Vogons about someone loading sound fonts in DOS, which seem to work, but the computer hangs when trying to play the music.

For my level of patience, I can tolerate up to an 8 MB soundfont file to load at boot. The 8 MB GM soundfont from Creative sounded pretty good to me. I tested it with Abuse and Duke3D.


Yes this motherboard can do L1 write-back - I'm sure I wrote about it around here a few years ago, will see if I can dig up the thread.

And yes you need to run AWEUTIL to the the GM emulation going in pure DOS but it's very much hit-and-miss, not worth bothering with I'd argue as it doesn't sound great anyway. In DOS I'd either go with AWE if it's supported by the game, or just settle for CQM with some reverb / chorus added - it's a different sound to a real OPL3 obviously but not as bad as people here make out. Worth experimenting with IMO.
If it's broke, then fix it!
User avatar
badmojo
l33t
 
Posts: 2815
Joined: 2011-10-11 @ 04:14
Location: Australia

Re: A fast 486 that isn't (a 486)

Postby feipoa » 2018-4-22 @ 09:09

Interesting that L1 WB works on a VLB/ISA board. Even with PCI boards, the L1 usually gets shoved into WT mode, although some BIOSes still claim it is in WB mode. The benchmarks reveal that it wasn't in WB mode.

Yea, AWEUTIL... my tests revealed that it is usually a 'miss' rather than a 'hit'. For some DOS games which only have the option in setup.exe for general midi or MPU-401, how are you getting music out of the AWE64? When I hit the TEST button, I hear nothing.
User avatar
feipoa
l33t++
 
Posts: 5100
Joined: 2011-3-07 @ 13:54
Location: Canada

Re: A fast 486 that isn't (a 486)

Postby Jolaes76 » 2018-4-24 @ 06:27

The EMU8000->MPU-401 redirection is very limited under DOS as AWEUTIL can only work with real-mode stuff, not with late DOS-era games where you would expect/need it the most.
These later games use either the quasi-standard DOS4GW or their own proprietary extender (for example JEMM(?) in Strike Commander).
On the other hand, for older games, like DUNE 2, GM emulation works but sometimes it gets tricky... AWEUTIL should be loaded high to provide over 620k(!) free conventional RAM.

Very few are the games that support the AWE32/AWE64 with soundfonts, like Magic Carpet 2.

On topic: a very impressive build again, I am always amazed how pristine these components look... :)
"Ita in vita ut in lusu alae pessima iactura arte corrigenda est."
Jolaes76
Oldbie
 
Posts: 743
Joined: 2011-3-23 @ 09:31
Location: Hungary

Next

Return to System Specs

Who is online

Users browsing this forum: Google [Bot] and 1 guest