VOGONS


A couple of retros I'm working on.

Topic actions

Reply 240 of 452, by IanB

User metadata
Rank Member
Rank
Member
Vipersan wrote:

Just finished making my 6 floppy Win3.1 Installation..
so fingers crossed I don't run into more problems..

FYI The standard windows 3.1(1) 32bit disk driver won't work as it only supports drives up to 528MB but the 32 bit disk driver that comes with drive overlay software will work.
Also earlier you mentioned getting into the BIOS, I've never found any key combination that will work and you normally get in by using the TEST3.EXE app or pulling the CMOS battery.

Vipersan wrote:

I'm using the Keyboard borrowed from the T3200SX ..and it is proving problematic ..
Double and often triple bounce key repeats ..so chances are I'll return to the original 5200 KB ..and canabalise the 3200KB for switches..

If you pull the keytops off, you get access to the top of the switches which have holes (at least on mine) and a squirt of switch/contact cleaner down those holes will fix that.
You can get a keycap puller from ebay or amazon which makes the job a lot easier.

Reply 241 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

Nice ..
I guess I'll do some reassembly soon ..
and fit the new 2gb hard drive plus standard floppy Drive with custom cable ..
Of course ..the story wont end here ..as I want to eventually get windows 95 on it..
😁

..Thanx for sharing your Bios Hamby ...and for ALL your cool mods Ian.
Now ..about that memory upgrade ???
🤣

My Connor 100mb HD is now 'officially' retired
😉

Attachments

  • DSCF0041.JPG
    Filename
    DSCF0041.JPG
    File size
    309.74 KiB
    Views
    355 views
    File license
    Fair use/fair dealing exception
  • DSCF0040.JPG
    Filename
    DSCF0040.JPG
    File size
    324.15 KiB
    Views
    355 views
    File license
    Fair use/fair dealing exception

Reply 242 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

Partially reassembled..
..or at least 'tested' with the ageing plasma screen..

Attachments

  • DSCF0043.JPG
    Filename
    DSCF0043.JPG
    File size
    311.09 KiB
    Views
    349 views
    File license
    Fair use/fair dealing exception

Reply 244 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie
IanB wrote:
Vipersan wrote:

Now ..about that memory upgrade ???

Well... You asked for it!

Toshiba T5200 mods and upgrades

EEeeek!!! ..
I think I'll take that on at some point...but gonna require several coats of pondering first I think..
I have some old sims but not sure I have anything suitable ..
Perhaps Ian ..should you find something suitable on fleabay ...you could link to it ?
that way I wont be buying the wrong thing.
Could you post the simm details (part numbers) of _exactly_ what you used ?
cheers
VS

Reply 245 of 452, by IanB

User metadata
Rank Member
Rank
Member
Vipersan wrote:

EEeeek!!! ..

It's not as easy as the T3200SX RAM mod detailed earlier in this thread is it! 🤣
Although it only took an evening and it's not like it's a surface mount mod!

Vipersan wrote:

Could you post the simm details (part numbers) of _exactly_ what you used ?

I think the chances of finding an exact part number match are very slim. All the 8MB FPM parity simms I've tried so far worked though.

Vipersan wrote:

Perhaps Ian ..should you find something suitable on fleabay ...you could link to it ?

I bought the last one on ebay UK last week to do this mod! Nothing new (in the UK) has shown up since.
However There is this in Germany:
https://www.ebay.co.uk/itm/8-MB-FPM-RAM-mit-P … -6/182832983847
Which is reasonable price and free delivery so I think I'll order one myself as a spare. I can test this with the other RAM mod as that has 72 pin SIMM sockets. If that works you can get one of those as they have plenty in stock by the look of it.

Also noticed some other cheap 27C1024 Eproms which are a different make to the ones you are having problems programming:
https://www.ebay.co.uk/itm/1-x-MBM27C1024-20Z … 40/282818768024

Reply 246 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

Ignore my PM Ian ..
I just ordered one stick from Germany ..
It may be a while ..but I'm in no hurry to start this mod ..
🤣
As for the eproms ..I have some Atmel on order already ..so I will wait for those ..
in the meantime I've added those linked to my watch list.
rgds

Reply 247 of 452, by Hamby

User metadata
Rank Member
Rank
Member
Vipersan wrote:
Just finished making my 6 floppy Win3.1 Installation.. so fingers crossed I don't run into more problems.. I'm using the Keyboar […]
Show full quote

Just finished making my 6 floppy Win3.1 Installation..
so fingers crossed I don't run into more problems..
I'm using the Keyboard borrowed from the T3200SX ..and it is proving problematic ..
Double and often triple bounce key repeats ..so chances are I'll return to the original 5200 KB ..and canabalise the 3200KB for switches..
rgds
VS

Odd thing about my keyboard. I said the enter key was flaky, and that the left-alt was dead...

But.. the left alt works for Ctrl-Alt-Del. Not pressing it, just Ctrl-Del, doesn't result in a warm boot, but Ctrl-Alt-Del does. Otherwise the left-alt doesn't do a thing.

What could be the cause of that, I wonder?

Reply 248 of 452, by IanB

User metadata
Rank Member
Rank
Member
Hamby wrote:

But.. the left alt works for Ctrl-Alt-Del. Not pressing it, just Ctrl-Del, doesn't result in a warm boot, but Ctrl-Alt-Del does. Otherwise the left-alt doesn't do a thing. What could be the cause of that, I wonder?

Maybe some keyboard driver issue? CTRL-ALT-DEL would be picked up by the BIOS but other interpretation of the Alt key could be varied by the driver or any TSR that's loaded.

As I menioned to Vipersan, remove the keytops and squirt in contact cleaner to fix flaky keys (Deoxit is a US brand of contact cleaner spray I believe but there are probably other cheaper ones as well)

Reply 249 of 452, by IanB

User metadata
Rank Member
Rank
Member
Vipersan wrote:

In the meantime I pulled the 1024 from my cracked screen 3200sx for you to look at ..
find attached zip

I had a quick look at this and it's a Phoenix BIOS with version 3.10 which has not been available online previously. It also has the 32K VGA BIOS in the first half.
Is there a separate VGA BIOS for the T3200SX or is that incorporated in the main BIOS EPROM?
It just occurred to me that the 32K VGA BIOS may also support the LCD versions of these machines and that might be one of the reasons for the extra code.

This website has other T3200SX BIOS versions
http://omolini.steptail.com/t3200sx/files.php
The "3I" version is Award V5.30
The "3C" version is Award V1.10

To sum up:
For the T5200 we have the following BIOS versions
V1.20 Award ("002A") (I have this but haven't posted it or patched it as it is buggy and won't recognise the 8MB ram option)
V1.30 Award (from me)
V3.00 Phoenix (from vipersan)
V5.30 Award (from hamby)

I've patched all the above except the buggy V1.20

For the T3200SX we have:
V1.10 Award ("3C")
V3.10 Phoenix (from vipersan)
V5.30 Award ("3I")

I've made an untested patch for V1.10 above but it seems like I should be patching the V5.30 one as well.
Only the V1.xx Award versions for both machines will boot any drive and allow you to use a drive overlay.

Vipersan / Hamby what is written on the labels of your original BIOS chips (both T5200 and T3200SX)? should be something like the above 002A 012A 3C 3I etc

Anyone else have any different BIOS versions?

Last edited by IanB on 2018-02-05, 11:59. Edited 1 time in total.

Reply 250 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

The label on my T3200SX bios reads > 003E
The T5200 label reads > 006A
Time for some sut eye ..having finally got my pcmcia sound blaster /CD combo working on one of those T4900CT
laptops..
I couldn't get the install setup to even recognise Panasonic PCMCIA card ..nor install any drivers..
I had to manually shoehorn all the missing drivers in ..by finding them on the floppies then pointing windows at them in the Control menu..
The CD now appears as drive D:
and I can have either/or internal sound ...or external via the pcmcia sound card and addon speakers..
Not both ..
I have to manually disble one or the other (disable in this profile)
You'd think plugging into the card bus would automatically disable internal sound..but it doesn't.
Still 3 hours of messing got results.
I'd forgotten how unforgiving and manual manipulation orientated win 95 was..
these days ..we just dont know how lucky we are..
🤣

Reply 251 of 452, by jaZz_KCS

User metadata
Rank Oldbie
Rank
Oldbie

YEah my original BIOS out of the T3200SX is also version 003E. But the one I am using now is the patched version from HighTreason, which is the "CH" version that is found on omolini as well linked above.

@IanB: It's supposedly the "vga bios from version 003I (supposedly faster VGA BIOS) with base bios 003C. Can you open it up and have a look and confirm that / see what has been altered? I think only the HDD bits are changed as it detects everything as 40MB drive, so it's unlocked in that regard but I would like to know whether anything else is different comapred to the original 003E I have.

PS: With the original BIOS chip there is a keystroke that you can hold to get into BIOS directly after boot on the T3200SX, Ctrl-Shift-F1 (or Ctrl-Shift-Esc). This only seems to work with my original BIOS though, not the modified one.

Reply 252 of 452, by IanB

User metadata
Rank Member
Rank
Member
jaZz_KCS wrote:

YEah my original BIOS out of the T3200SX is also version 003E. But the one I am using now is the patched version from HighTreason, which is the "CH" version that is found on omolini as well linked above.
@IanB: It's supposedly the "vga bios from version 003I (supposedly faster VGA BIOS) with base bios 003C. Can you open it up and have a look and confirm that / see what has been altered? I think only the HDD bits are changed as it detects everything as 40MB drive, so it's unlocked in that regard but I would like to know whether anything else is different comapred to the original 003E I have.

The BIOS/VGA arrangement on the T3200SX differs from the T5200:
In the T5200 the 64K BIOS is in the top half of the 27C1024 and the bottom half is blank with the VGA BIOS on a separate 32K 27C256 EPROM on the video board.
In the T3200SX, the VGA BIOS is in the first 32K of the 27C1024 with the main BIOS in the last 64K leaving a 32K gap between them.

For the T3200SX:
The VGA BIOS in "3E" is the same as "3I" but we don't have a confirmed rip of the VGA BIOS from 3C
The 64k BIOS part of the "CH" version is identical to the "3C" version, the VGA part contains a 32K VGA BIOS which is similar to "3E"/"3I" but not binary identical so likely a slightly different version and I don't know where that came from.

There is a version number in the BIOS but it is only visible when displayed on startup and not directly visible as a string in the code.
Unfortunately, the VGA BIOS banner with version number is only displayed as a brief flash on power up or warm boot so can be difficult to confirm. I eventually used my phone to record the startup and played back the video a frame at a time:
On the T5200:
the 24K BIOS displays Phoenix Advanced Video BIOS Version 1.04 01
the 32K BIOS displays Phoenix Advanced Video BIOS Version 1.04 09

vipersan / jaZz_KCS can you confirm the VGA BIOS version number displayed on startup on your T3200SX machines?
(vipersan's is from "3E" / "3I" and jaZz_KCS is of unknown origin from "CH")

Reply 255 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

A couple more ???
I made an impulse purchase over a while back ..
mainly cos I thought ..
If nothing else there may be spares for my T4900 .
Anyway ..
Anyhoo ..they just arrived ..beautifully packed and intact ..at least externally.
Not tried powering either up yet.
Watch this space.
But ..you can see why I was drawn to them ..
I do like Toshiba..
I do like this basic design.
rgds
VS

Attachments

  • DSCF0045.JPG
    Filename
    DSCF0045.JPG
    File size
    313.16 KiB
    Views
    255 views
    File license
    Fair use/fair dealing exception

Reply 256 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

Just powered up the 510CDT ..and it runs ..
2.1gb hard drive ..and running what maybe a factory installed win98 ..
This laptop alone was worth the £40 including postage I paid for both ..
😁

Reply 258 of 452, by Vipersan

User metadata
Rank Oldbie
Rank
Oldbie

I suspect the one on the right was intended for use with 3.1
It is a T4500C ...so not a TFT screen..
I cannot test it yet as I dont yet own a 15v psu brick ..
there is slight case damage though ..but..we shall see
rgds
VS

Reply 259 of 452, by jaZz_KCS

User metadata
Rank Oldbie
Rank
Oldbie

Vipersan, the keyboard has arrived. And from what I can see it is in very good condition, and must have been under storage for a very long time.

Normally with these laptop keyboards from the early nineties, after several months of medium usage (or after several years of light usage) the matte finish of these keyboards starts to turn sheen and reflective rather quickly. This keyboard however has only light signs of wear, might not even be yellowed at all, and doesn't even have dust under the keys.

If I would have to guess then I would say this keyboard came out of a machine that was defective rather quickly after purchase.

Box also has part number printed on a label with dot matrix 😀

In either case I think this was a good buy, see for yourself:

https://imgur.com/a/GjxjI