VOGONS


First post, by chinny22

User metadata
Rank l33t
Rank
l33t

Someone on Freecycle was giving away a bunch of "Amstrad computers" not far from where I live last month
Not really my thing but the wife likes watching "The Apprentice" so thought she would get a kick out of the Alan Sugar connection. I have a little play then pass it onto someone else.

I replied to the add, giving a very brief explanation that I like old PC's and this would go well with my 486. He responded that all the Amstrad's had gone but did also have a 486 if I was interested. You bet I said yes!

What I got was a Crown badged Tatung TCS 9510
Front.jpg

Spec was
CPU: DX2/50
M/:B Tatung TCS 9510, No cache
RAM: 16MB EDO, Possibly upgraded from 8MB as the first pair of Simms' don't match the 2nd pair
Video: Onboard Cirrus Logic 5428 VLB
Sound: Mad 16 (82C928 chip)
FDD: Standard 3.25 drive
HDD: Seagate ST3290A, 260MB
CD-ROM: 4x NEC CDR-273

it also came with a nice DEC keyboard that goes upto F14 and a CRT that I didn't realize till I got home was actually a CGA monitor! namely a rebadged Daewoo CMC-1424S.

Talking to the guy at collection it was actually his neighbors who had passed away and he was helping clear the house.
Booted the PC up and found a nice clean install of Win95, IE4, Comptens 3D World access, Office 97 Pro, Thumbs+CD and a printer. That was it.
Looks like it was used between 99-2001 and briefly again in 2006 by a retired ship captain to type up letters to naval security boards (kind of interesting)
Couldn't see any evidence of the PC ever being on the internet which explains why it still ran pretty well. It's got an asset tag and a lot of the hardware is dated from 95 so he looks to be the 2nd owner.

PC was pretty clean on the outside and inside was ok for a PC for its age
MB.jpg

Even still after confirming it worked first thing I did was give it a clean, the Gold lettering on Crown comes off pretty easy. and sorry to say I butcherd the face plate 🙁
When reassembling it wouldn't fit properly on the case, I thought I must of warped it so went crazy with superglue. Went to put the lid back on... damn it! forgot the faceplate mounts to that not the front of the case and had to end up snapping most the plastic clips to get it off. Lucky you wouldn't know my mistake by looking at it, but the right side of the faceplate is a bit loose.

Next I upgraded the cache with help from here to 256MB and maxed out the ram at 64MB with 2x 32MB sticks. I tried my luck 128MB but seems the documentation is correct and it indeed only recognizes 64.
That's fine, even with 64MB half of it gets assigned to a RAM drive anyway.

The DX2/50 was a good choice of CPU as it needs a voltage regulator board for anything much faster, I just happen to have a "anything" POD 83 to be exact so that got moved to this and PC that came out of has a 5x86 133 now so don't think it's upset.

Also fitted it a Gotek (obviously form pic above) a NIB VLB Network card I got from the Pentium Pro Haul of 2018 -yep that's 3 VLB devices in this rig 😀

I wanted a CF card as a secondary HDD so have had to unplug the CD drive for now (I find I dont really need CD drives necerry in dos PC's as long as you have large HDD's and networking anyway)
BIOS only supports 500MB drives so have a 4GB CF card with DDO. First time using DDO and impressed.

Now running Dos 6.22 Windows for Workgroups 3.11

Finished.jpg

Finally some benchmarks:
50Mhz No Cache
3DBench 28.9
PC Player Bench 6.9
doom 2134 gametics in 4476 realtics
Quake 4.3 fps

83 Mhz No Cache
3DBench 49.3
PC Player Bench 13.2
doom 2134 gametics in 2679 realtics
Quake fps 10.1

83 With Cache
3DBench 57.1
PC Player Bench 13.5
doom 2134 gametics in 2466 realtics
Quake fps 11.1

Freecycle been good to me lately though! I also ended up getting a 17" CRT that month, haven't really tested yet (It does turn on) then twist of fate one of those Amstrad's came back up few weeks ago and managed to grab this time.
Freecycle.jpg

Future plans:
Test if the onboard gameport works with my SC-55, that would be helpful because…
Replace the soundcard. The Mad16 is ok but can't seem to get sound in Doom and only doom. Music is ok and sound works in EVERY other game I have. Haven't fully troubleshooted this yet though.

Reply 1 of 2, by chinny22

User metadata
Rank l33t
Rank
l33t

Had a good play with this over the weekend.

So far all 3 VLB devices are playing nice together, I dont know why but this makes me very happy when I know it's typical for even 2 to fight.

The Cirrus Logic 5428 looks to be a pretty good chip. it's always up the top in Phils VLB tests (although he's missing the holy grail cards) https://youtu.be/39pNCEKJK3Q
And ended up playing 1/2 the Warcraft missions when testing if I had the noise issue, which I don't 😀
https://gona.mactar.hu/DOS_TESTS_VLB

If anyone has ideas on Doom sound I'd be grateful though?

Reply 2 of 2, by Hezus

User metadata
Rank Newbie
Rank
Newbie

Nice pc! As for the Doom sounds, this could be conflict setup conflict. This has happened to me before where the 220 address was accessible for the music but the IRQ and/or DMA channel was taken by another device.

I often use Snooper to check the usage of the channels. It's strange though how other games work fine. See if those other games actually use digitized sounds and not just rely on adlib.