Red Baron no sound with xp and opengl

General information and assistance with OpenGLide.

Red Baron no sound with xp and opengl

Postby Otter » 2003-1-01 @ 19:06

I was rather excited to see the fix for this problem here on this forum. I followed the procedure stated by Snover -(thanks for the help by the way :D )
and found that it worked.... until I close down the game and try and play again. I have closely followed the procedure and short of deleting the RBPREFS.DAT file everytime I still can't get any sound. Any other help would be appreciated greatly :confused:

thanks,
Otter
Otter
Newbie
 
Posts: 3
Joined: 2003-1-01 @ 18:51

Postby Unregistered » 2003-1-01 @ 22:56

SAME PROBLEM HERE.....SORRY I CANNOT HELP AT THIS TIME
Unregistered
 

Re: Red Baron no sound with xp and opengl

Postby Nicht Sehr Gut » 2003-1-02 @ 03:06

Originally posted by Otter [B]found that it worked.... until I close down the game and try and play again
Unless you forgot to set the READ ONLY attribute, that shouldn't be happening.

Try it again. This time, after you set your preferences and the read only attribute (note the time), now go to the menu just before you actually quit and do nothing for a few minutes, then quit. After you quit, check the timestamp on your RBPREFS.DAT file.

Is it set to the time you set the READ ONLY attribute?
Or the time you quit the program?
User avatar
Nicht Sehr Gut
l33t
 
Posts: 3630
Joined: 2002-6-30 @ 17:32

Re: Re: Red Baron no sound with xp and opengl

Postby Otter » 2003-1-02 @ 03:46

Nicht Sehr Gut wrote:Unless you forgot to set the READ ONLY attribute, that shouldn't be happening.

Try it again. This time, after you set your preferences and the read only attribute (note the time), now go to the menu just before you actually quit and do nothing for a few minutes, then quit. After you quit, check the timestamp on your RBPREFS.DAT file.

Is it set to the time you set the READ ONLY attribute?
Or the time you quit the program?


Went through your suggested procedure. It time stamps the RBPREFS.DAT file after adjusting the read only attribute. Still no sound. This is a bit flustering. Thanks for the suggestions though. To answer Craig's post, the origional problem occurs (to quote Snover)

"For some reason, RB is upset by USB joysticks when running XP. It detects a non-existent conflict with your sound card and disables the sound for you; making the RBPREFS.DAT read-only stops RB from doing this"

He's right in addressing the pref dat file because upon deleting I do have glorious sound on RB, but it disappears after I exit and reboot Rb. Any other Ideas guys?
Otter
Newbie
 
Posts: 3
Joined: 2003-1-01 @ 18:51

Re: Re: Re: Red Baron no sound with xp and opengl

Postby Nicht Sehr Gut » 2003-1-02 @ 05:22

Originally posted by Otter [B]It time stamps the RBPREFS.DAT file after adjusting the read only attribute.
Well that makes a whole lot of no sense. All I can suggest at the moment is to set up a batch file that copies your good RBPREFS.DAT file on top of the corrupted one from a backup directory after starting each game.
User avatar
Nicht Sehr Gut
l33t
 
Posts: 3630
Joined: 2002-6-30 @ 17:32

Postby Snover » 2003-1-02 @ 06:12

So, you
  1. Deleted RBPREFS.DAT
  2. Started Red Baron
  3. Alt+Tab'd out of Red Baron while it was running
  4. Turned on the Read-Only attribute of RBPREFS.DAT
?
If you don't have sound to begin with, this won't fix it.
Snover
l33t++
 
Posts: 5209
Joined: 2002-6-30 @ 04:47

Re: Re: Red Baron no sound with xp and opengl

Postby Glidos » 2003-1-02 @ 09:06

Nicht Sehr Gut wrote:Try it again. This time, after you set your preferences and the read only attribute (note the time), now go to the menu just before you actually quit and do nothing for a few minutes, then quit. After you quit, check the timestamp on your RBPREFS.DAT file.

Is it set to the time you set the READ ONLY attribute?
Or the time you quit the program?


Like it Nicht. What an excellent bit of remote fault finding.
User avatar
Glidos
l33t
 
Posts: 3116
Joined: 2002-8-08 @ 02:55

yes

Postby Unregistered » 2003-1-02 @ 10:02

Snover wrote:So, you
  1. Deleted RBPREFS.DAT
  2. Started Red Baron
  3. Alt+Tab'd out of Red Baron while it was running
  4. Turned on the Read-Only attribute of RBPREFS.DAT
?
If you don't have sound to begin with, this won't fix it.


I do have sound prior to exiting red baron. It's only upon reboot.
Found a curious notation about it here;

http://www.wings-of-valor.org/files/documents/xpworkarounds.pdf

guess I'm not the only one having this problem. In the pdf the also suggested unplugging the usb joystick prior to booting the game. This seems to work everytime, but not a particularly attractive way to fix it. Somewhere in the middle of this and patching the game with sierra's last update I've now lost my forcefeedback *sigh* if this game didn't kick arse I"d quit on it long ago.

thanks again guys,
Otter
Unregistered
 


Return to OpenGLide General

Who is online

Users browsing this forum: No registered users and 1 guest