Real MT-32 not playing correctly with DosBox

General information and assistance with Munt.

Real MT-32 not playing correctly with DosBox

Postby UseRope » 2017-5-29 @ 13:34

Having an issue with games that use CM-32L effects not playing the correct sounds on my MT-32. This is only occurring in DosBox and does not affect native MT-32 Games. For example:
Monkey Island, Space Quest 3 - Work fine :happy:
Fate of Atlantis, Monkey 2, DOTT - Play the wrong instruments and sound nasty :dead:

Only happens in DosBox as, the same games piped through SCUMMVM sound perfect on the MT-32.

Anyone else experiencing this issue?
User avatar
UseRope
Newbie
 
Posts: 3
Joined: 2017-5-23 @ 11:42

Re: Real MT-32 not playing correctly with DosBox

Postby UseRope » 2018-1-13 @ 02:17

In case anyone else comes across this looking for answers:
Turns out this was simply a cycle issue. Apparently the later games were either running faster in the same DosBox instance or else handled the speed differently than the older titles... Where SCUMMVM must have more precise handling of this in place as it is designed and tested for a finite set of games. Regardless, slowing things down in DosBox BEFORE launching the game allowed the MT32 time to get the correct instrument information. All of this is moot at this point for me as I finally have my 486SX system up and running and all is right with the world.
User avatar
UseRope
Newbie
 
Posts: 3
Joined: 2017-5-23 @ 11:42


Return to MT-32 General

Who is online

Users browsing this forum: No registered users and 1 guest