VOGONS


First post, by killingjoke96

User metadata
Rank Newbie
Rank
Newbie

I have a problem that I haven't been able to find an answer to through searching online. Whenever I have Munt play a MIDI file, it sounds like there are instruments missing. This also applies to when I run a game in DOSBox. I have Munt set up for use with DOSBox, but it still doesn't play all the instruments in a song when I run a game. Does anyone know how to fix this? I'm running it on Windows 10, in case you need to know.

Reply 2 of 5, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Best record what you mean so people with real MT32 devices can evaluate it.

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 3 of 5, by killingjoke96

User metadata
Rank Newbie
Rank
Newbie

This is a recording I made of a MIDI of the intro song for System Shock. Only the rhythm section is played when I have Munt play the file.

Filename
System Shock intro with Munt.mp3
File size
2.59 MiB
Downloads
25 downloads
File license
Fair use/fair dealing exception

Reply 4 of 5, by CrossBow777

User metadata
Rank Member
Rank
Member

Wow...quite interesting.

You didn't specify which version of System Shock you are using here but I think you are using the floppy version? Eitherway here is what I've found out as I do have an actual MT-32 and 2 other GM sound modules all connected I can enable on the fly.

If you manually modify the cyb.cfg and change the music card to "5". Then the install program will show your music card to be Roland MT-32. However, when you play the game, you only get the drums or rhythm channel exactly like your sound recording above. If you change the music card to "12", then it will choose the music card as a General Midi instrument. But on the MT-32 you still only hear the drums/rhythm channels like before. However, regardless of whether I have MT-32 or general midi as my active music card, I will hear full instrumentation on my MT-200 module.

Now the Roland MT-32 by itself is NOT a selectable item from the music card list and only the general Midi and sound blaster/adlibs are in the floppy version. But you can enable lots of other cards if you just change the music card number manually in the cyb.cfg folder to others that aren't in the available list but do apparently exist in the sound driver itself.

I also as a test, ran the MTGM.mid file to remap the MT-32 as a general midi instrument, but this made NO difference in the playback and you still only get drum rhythm sounds.

So in a nutshell, it appears the MT-32 isn't being setup on the sound drive to the proper midi instrument channels and the sound driver is stuck using the GM instrument channels. As a result the MT-32 intereprets the instruments as only being drum/rhythm instruments and you get what you are getting.

MUNT is working exactly the same way as an actual MT-32 does with System Shock. BTW, I did the same testing using the CDrom version of the game and get the same results with the MT-32 but I didn't mess with the cyb.cfg files in the same ways and so was only using the General midi option for that version of the game.

g883j7-2.png
Midi Modules: MT-32 (OLD), MT-200, MT-90, SD-20

Reply 5 of 5, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

see Did System Shock supported MT-32? about System Shock and MT32.

@Killingjoke, any other examples or was this the only one?

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox