VOGONS


Munt issue with Windows 10

Topic actions

First post, by ghuber

User metadata
Rank Newbie
Rank
Newbie

Hi,

I have installed MUNT 2.3.0-amd64 with driver and Windows plays midi files perfectly. However when I start DOSBox (0.74.3)

mixer /listmidi

only shows the default Windows GS driver.

I tried to reinstall MUNT and it seemed to work briefly, but after a restart, again, no MT32 in DOSBox. Still, the MUNT GUI plays midi-files like a charm. Does anyone have an idea, what could be wrong?

Thanks for your help

Georg

PS (Win10 x64, build 19041).

Last edited by DosFreak on 2020-05-29, 13:31. Edited 1 time in total.

Reply 1 of 66, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Hi Georg,

It's an interesting problem. This may be an issue with the windows MIDI driver installer. Do you mind taking registry dumps when it's working and when isn't?
The following commands:

reg.exe export "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32" midi32.reg /reg:32
reg.exe export "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32" midi64.reg /reg:64

will create two files midi32.reg and midi64.reg showing how the MIDI driver was installed and whether it conflicts with some other driver.

In the past, it was quite common that some 64-bit drivers replaced the munt one, though I can't recall anything like not-working-in-the-DOSBox-only problem. Note, the munt installer actually sets up two MIDI drivers, for 32-bit applications and for 64-bit ones. In case they get de-synced for some reason, it's possible that 64-bit applications can use the munt driver but 32-bit applications can't find it. As we know, the official DOSBox binaries are 32-bit; could it be that you use a 64-bit MIDI player?

Reply 2 of 66, by ghuber

User metadata
Rank Newbie
Rank
Newbie

Hi,

thanks for your answer. attached is when it DOESN'T work. I'll try to reinstall and make new reg files.

BTW: I saw that MUNT ist 2.4.0 now on GitHub, but the installer on SourceForge is "still" 2.3.0. Will that be updated?

Georg

Attachments

  • Filename
    RegMidi.7z
    File size
    647 Bytes
    Downloads
    17 downloads
    File license
    Public domain

Reply 3 of 66, by ghuber

User metadata
Rank Newbie
Rank
Newbie

And here it is "working".

I have also installed DOSBox ECE (separate directory) with the MT32 patch. When I use "mididevice=mt32" in the config file, MUNT works.

Attachments

  • Filename
    MuntWorkingReg.7z
    File size
    668 Bytes
    Downloads
    17 downloads
    File license
    Public domain

Reply 4 of 66, by sergm

User metadata
Rank Oldbie
Rank
Oldbie
ghuber wrote on 2020-05-23, 16:44:

thanks for your answer. attached is when it DOESN'T work. I'll try to reinstall and make new reg files.

Apparently, when munt MIDI driver isn't working on your system, the reference to mt32emu.dll is simply absent in the registry. I'm a little surprised by a claim that it works with a MIDI player, though it could be the glorious Falcosoft Soundfont Midi Player which uses the MT-32 emulation library built-in. Am I right? 😀

I'm not sure how to fix this anyway. Possibly, the driver is uninstalled by some antiviral software, or something alike. As a workaround, you might start the drvsetup.exe program (from mt32emu_win32drv-1.5.0-win32-amd64.zip) in the "repair" mode, which is intended exactly for such situations.

[/quote]
BTW: I saw that MUNT ist 2.4.0 now on GitHub, but the installer on SourceForge is "still" 2.3.0. Will that be updated?
[/quote]

Sure thing, 2.4.0 is upcoming. I'm working on improvements in the UI application atm, and when it's done, the release will be rolled out.

Reply 5 of 66, by collector

User metadata
Rank l33t
Rank
l33t

I have some memory of when I wrote my Munt installer (when Win7 was new) that duplicate wdmaud.drv entries took up all of the "midi#" spots, leaving no place for mt32emu to be added.

The Sierra Help Pages -- New Sierra Game Installers -- Sierra Game Patches -- New Non-Sierra Game Installers

Reply 6 of 66, by ghuber

User metadata
Rank Newbie
Rank
Newbie
sergm wrote on 2020-05-23, 17:24:
ghuber wrote on 2020-05-23, 16:44:

thanks for your answer. attached is when it DOESN'T work. I'll try to reinstall and make new reg files.

Apparently, when munt MIDI driver isn't working on your system, the reference to mt32emu.dll is simply absent in the registry. I'm a little surprised by a claim that it works with a MIDI player, though it could be the glorious Falcosoft Soundfont Midi Player which uses the MT-32 emulation library built-in. Am I right? 😀

I'm not sure how to fix this anyway. Possibly, the driver is uninstalled by some antiviral software, or something alike. As a workaround, you might start the drvsetup.exe program (from mt32emu_win32drv-1.5.0-win32-amd64.zip) in the "repair" mode, which is intended exactly for such situations.

Hmmm.... I have no "real" antivir software, only the basic ms/security.... And this MS Security doesn't give a warning of any kind of violation...

As I do not recall having problemns under Win 10 1009, could the problem be caused by Win 10 2004?

Georg

Reply 7 of 66, by Kaminari

User metadata
Rank Oldbie
Rank
Oldbie

It looks like a similar problem with VirtualMIDISynth, which has been happening in Win10 since December. The MIDI driver is automatically disabled by Windows on every reboot.

Ryzen 2600X 4.0 GHz | Vega 56 8 GB | DDR4 16 GB | Win7-64 Ultimate | Win10-64 Pro

Reply 8 of 66, by sergm

User metadata
Rank Oldbie
Rank
Oldbie
Kaminari wrote on 2020-05-23, 19:15:

It looks like a similar problem with VirtualMIDISynth, which has been happening in Win10 since December. The MIDI driver is automatically disabled by Windows on every reboot.

Peachy. I didn't expect windows to become any less unusable with the new release... That's why I given it up and use another OS these days 😀

Reply 9 of 66, by ghuber

User metadata
Rank Newbie
Rank
Newbie
sergm wrote on 2020-05-23, 20:27:
Kaminari wrote on 2020-05-23, 19:15:

It looks like a similar problem with VirtualMIDISynth, which has been happening in Win10 since December. The MIDI driver is automatically disabled by Windows on every reboot.

Peachy. I didn't expect windows to become any less unusable with the new release... That's why I given it up and use another OS these days 😀

That would have to be FreeBSD then 😀

But as long as DOSBox ECE manages to work with MUNT included, I guess I can live with it.

Thanks for your quick answer, anyway!

Georg

Reply 10 of 66, by Dagar

User metadata
Rank Newbie
Rank
Newbie

Just came across the problem today after installing the Windows 10 May 2020 Update version 2004

Both MUNT and VirtualMidiSynth are both disabled on every reboot.

Not for just DOSBox, but any application that uses it. Frustrating !

Reply 11 of 66, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Amazing that it still works somehow. I bet windows won't let it to run at all after the next update.

Still, I'm not going to buy the developer certificate for windows kernel drivers. Better be DOSBox implementing another API for connecting such software synth as plugins, or somehow. Probably, VSTi support would be just perfect, but I'm not a big fan of it too 😀

BTW, RTP-MIDI is a viable alternative, also it's truly cross-platform.

Reply 12 of 66, by Dagar

User metadata
Rank Newbie
Rank
Newbie
sergm wrote on 2020-05-28, 16:46:

Amazing that it still works somehow. I bet windows won't let it to run at all after the next update.

Still, I'm not going to buy the developer certificate for windows kernel drivers. Better be DOSBox implementing another API for connecting such software synth as plugins, or somehow. Probably, VSTi support would be just perfect, but I'm not a big fan of it too 😀

BTW, RTP-MIDI is a viable alternative, also it's truly cross-platform.

Also read about the expensive code-signing certificate in the Coolsoft forums posted by the author in the bug reports section.
Hopefully something other than that can be worked out.

Reply 13 of 66, by darry

User metadata
Rank l33t
Rank
l33t

<RANT>

Windows should either let it install and leave it or not let it install to begin with . Silently uninstalling in the background makes no sense . It's like the OS can't even agree with itself . Oh, and if this was at least documented in some way, it would be really nice .

If this behaviour is entirely be design, somebody on the dev team needs anti-psychotic meds .

Thank you Microsoft .

</RANT>

Reply 14 of 66, by darry

User metadata
Rank l33t
Rank
l33t

On a more useful note, a way around this, for Munt, would be running it in a VM along with Virtualmidi and two USB to MIDI interfaces, one assigned to the VM and the other to the host OS. Then all you need to do is plug a MIDI cable between both USB interfaces and Bob's your uncle !

You may be laughing now, but it may actually come to that .

Reply 15 of 66, by darry

User metadata
Rank l33t
Rank
l33t
Dagar wrote on 2020-05-28, 16:24:

Just came across the problem today after installing the Windows 10 May 2020 Update version 2004

Both MUNT and VirtualMidiSynth are both disabled on every reboot.

Not for just DOSBox, but any application that uses it. Frustrating !

The very useful Coolsoft Midi Mapper is affected too .

Reply 17 of 66, by Dagar

User metadata
Rank Newbie
Rank
Newbie
darry wrote on 2020-05-29, 00:30:

On a more useful note, a way around this, for Munt, would be running it in a VM along with Virtualmidi and two USB to MIDI interfaces, one assigned to the VM and the other to the host OS. Then all you need to do is plug a MIDI cable between both USB interfaces and Bob's your uncle !

You may be laughing now, but it may actually come to that .

Going through all that I can tell you one thing .... Bob is not my uncle 😉

Reply 18 of 66, by darry

User metadata
Rank l33t
Rank
l33t
Dagar wrote on 2020-05-29, 02:56:
darry wrote on 2020-05-29, 00:30:

On a more useful note, a way around this, for Munt, would be running it in a VM along with Virtualmidi and two USB to MIDI interfaces, one assigned to the VM and the other to the host OS. Then all you need to do is plug a MIDI cable between both USB interfaces and Bob's your uncle !

You may be laughing now, but it may actually come to that .

Going through all that I can tell you one thing .... Bob is not my uncle 😉

At that point, running Munt on Raspberry Pi would probably make more sense .

Reply 19 of 66, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Actually, there is a nice solution for it found quite some time ago by Tobias Erichsen.
There is just one drawback with this approach: "This software is NOT freeware or shareware. This software is copyrighted by Tobias Erichsen".

Although, using just his loopmidi driver for routing MIDI is way easier than that USB-MIDI+VM setup described 😜
and mt32emu-qt is already capable to communicate with other applications that way.