VOGONS


First post, by Whirlinurd

User metadata
Rank Newbie
Rank
Newbie

Hi.

Using Dosbox under Retropie for gaming for some time now. I found some tutorials that I could install Munt under Retropie. This was a tutorial originally for Raspberry pi 2 and also one for the Raspberry pi 3 with some build modifications also for a Raspberry pi 3 or 4. I combined the two tutorials tweaking some packages and using Munt 2.4.0 instead of 2.2.0. This worked perfectly now having Roland Midi output under dos.

The only thing is I use the 3.5mm jack for audio. This works fine for all other audio outputs that Retropie uses. When I finished installing Munt audio it is coming out of the HDMI output. The only way I have found until now is by disabling all HDMI audio and forcing all to the audio jack. I have discussed this in the Retropie forum and they think this is not the solution to my problem.

Until now we haven't found anything that works.

This is the tutorial I have used to install Munt:

https://retropie.org.uk/forum/topic/12549/tut … lation-on-rpi-3

After discussing a lot the last thing we tried is changing Step 11 in the tutorial that says '/usr/local/bin/mt32d -i 12&' in '/etc/rc.local' that seems to start Munt with the system to the following:

./mt32d -i 12 -d dmix:CARD=Headphones,DEV=0

I have tried searching around to find anything to fix this but most people use Munt under Windows or with a Retropie setup just leave all audio to HDMI.

I would like to know how it is possible to change the default HDMI output that Munt uses to change this to a Raspberry pi 3.5mm audio output?

Thanks.

Reply 1 of 3, by Whirlinurd

User metadata
Rank Newbie
Rank
Newbie

Since several versions of Retropie the audio is not set in raspi-config and it stays on HDMI. Could this be a separate alsa mixer next to the alsa mixer retropie uses. In the Munt tutorial there is also a Munt Alsa Mixer. Everything keeps on mixing everywhere.

This is my aplay -L list:

null
Discard all samples (playback) or generate zero samples (capture)
default
output
sysdefault:CARD=b1
bcm2835 HDMI 1, bcm2835 HDMI 1
Default Audio Device
dmix:CARD=b1,DEV=0
bcm2835 HDMI 1, bcm2835 HDMI 1
Direct sample mixing device
dsnoop:CARD=b1,DEV=0
bcm2835 HDMI 1, bcm2835 HDMI 1
Direct sample snooping device
hw:CARD=b1,DEV=0
bcm2835 HDMI 1, bcm2835 HDMI 1
Direct hardware device without any conversions
plughw:CARD=b1,DEV=0
bcm2835 HDMI 1, bcm2835 HDMI 1
Hardware device with all software conversions
sysdefault:CARD=Headphones
bcm2835 Headphones, bcm2835 Headphones
Default Audio Device
dmix:CARD=Headphones,DEV=0
bcm2835 Headphones, bcm2835 Headphones
Direct sample mixing device
dsnoop:CARD=Headphones,DEV=0
bcm2835 Headphones, bcm2835 Headphones
Direct sample snooping device
hw:CARD=Headphones,DEV=0
bcm2835 Headphones, bcm2835 Headphones
Direct hardware device without any conversions
plughw:CARD=Headphones,DEV=0
bcm2835 Headphones, bcm2835 Headphones
Hardware device with all software conversions

Most of the things are set to Headphones. These are probably the mixer settings of Retropie. Maybe the top ones are from the system mixer raspi-config uses. Or they are just all outputs the mixer has. I do not know. If this is true that the raspi-config mixer sticks to HDMI and it is also the system mixer Munt outputs to it then it keeps using the HDMI audio.

Not sure if I can ever fix this properly. Should I fix something in Retropie... Is it a problem with Munt or is Dosbox doing strange things. I do not know. Does Munt has a config file somewhere or some kind of configuration utility? I am not sure.

The only thing I did until now is this. An alternative for the amixer cset numid thingy that Retropie does not use anymore.

Step 1: Hardware – Default, Headphones, Mixer Alsa
Step 3: sudo nano /boot/cmdline.txt

snd_bcm2835.enable_compat_alsa=1
Step 6: sudo nano /boot/config.txt
hdmi_ignore_edid_audio=1
audio_pwm_mode=2
Step 7a: sudo nano /home/pi/.asoundrc
defaults.pcm.card 1
defaults.ctl.card 1
Step 7b: sudo nano /usr/share/alsa/alsa.conf
defaults.pcm.card 1
defaults.ctl.card 1

This disables all HDMI audio and pushes all audio to the 3.5mm jack.

Is there really no way to properly configure the output of Munt to a specific audio output?

Reply 2 of 3, by Whirlinurd

User metadata
Rank Newbie
Rank
Newbie

I feel a bit dumb. Did not know to much about how things work on linux and stuff. It seems that the './mt32d -i 12 -d dmix:CARD=Headphones,DEV=0' is a valid output line but gives no sound output. I was so focused that I was doing something wrong. Finally I tried some other output devices and tried the first one.

/usr/local/bin/mt32d -i 12 -d sysdefault:CARD=Headphones

Just hoping that it would do something else and it worked the first time. If I knew it was this simple.

Thanks. Bye bye.

Reply 3 of 3, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Thanks for your rant! It will prove useful for someone else! And I love everything munt+pie 😀

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox