VOGONS

Common searches


Need help plz (very noob to DOSBox....)

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by Kharn

User metadata

😅 ok i own the original cd to daggerfall i install the game (wont let me install more then 105 mb 😠 ) well when i go to play it says theres no cd in the drive 😒 or i dont have the correct cd can ne 1 plz help me.
TY in advance 😁

Reply 2 of 18, by red_avatar

User metadata
Rank Oldbie
Rank
Oldbie

There's a few things that will almost certainly help:

- Find out the number of the CD/DVD drive that has the CD - using the -usecd command you can achieve far better "emulation" and this is often what makes a game detect the CD for me. Read the readme for info on how to discover this number and the correct settings

- This method takes some time but is nearly always successful for one-CD games: make an ISO of the CD (UltraISo will do this) and use imgmount in DOSBOX to mount it as an image. This usually solves the tougher games

Reply 3 of 18, by Kharn

User metadata

TY for the help.
🤣 I cant run the game i install the game fine but when i type in
Z:\> C:
C:\> cd dagger
C:\DAGGER> DAGGER.exe
it comes up with
TES: Daggerfall v1.0 - 09/06/96 13:00:00
Copyright 1994,96 Bethesda Softworks

ERROR: Looks like you inserted the wrong CD. Please insert your Daggerfall CD in your cdrom and try again

(press a key)

🤣 i dont know what to do 😅 it just wont work 😖

Reply 6 of 18, by eL_PuSHeR

User metadata
Rank Moderator
Rank
Moderator

You need to provide label name after label parameter. To find out what a volume label is just right-click on a drive from My PC > properties or open a cmd.exe window (or use execute) and issue a VOL X: command, where X: is the drive...

E.G.

vol f:

volume F: label is DAGGERFALL

When mounting CD drive in DOSBox...

mount f f:\ -t cdrom -ioctl -label DAGGERFALL

(Drive F mounted as cd-rom)

Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
8 GB GeForce GTX 1070 G1 Gaming (Gigabyte)

Reply 8 of 18, by Snejs

User metadata
Rank Newbie
Rank
Newbie

Please correct me if I'm wrong Kharn.

But as I've understood your description, you've installed Daggerfrall from within Windows and then mounted the cd in dosbox and tried to start it?

Have you tried to mount the cd in dosbox and do the install from within dosbox?

Reply 9 of 18, by Kharn

User metadata

This is what i did
opened dosbox
mount C "C:\DOS Games\"
mount D D:\ -t cdrom -ioctl -label Daggerfall
Z:\> D:
D:\>dir
*shows all the files*
*look for install*
D:\>install
*installs the game, it wont let me install over 105 megs so i have to install the medium installation*
*games finishes installing*
D:\> C:
C:\>cd DAGGER
C:\DAGGER>DAGGER.exe
*Then is comes up with the no cd message*

Reply 12 of 18, by Kharn

User metadata

nope still not working....figures
lol emulations must really hate me.
ne way i must be doing something wrong i'll type in wat i do.
Z:\> mount C "C:\DOS Games"
Z:\> mount D "D:\" -t cdrom -ioctl -label Daggerfall
Z:\> D:
D:\>install
*install game*
D:\> C:
C:\>cd dagger
C:\DAGGER>dagger
and it brings up a message about no cd.
If ne 1 has ne idea how to get it to work plz tell me. ive tried imgmount and normally mounting it ive tried the readme it doesnt help -.- dunno what to do plz help ty.

Reply 13 of 18, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Search the forum for the word "Daggerfall" and read the posts as this has been gone over before. IIRC, you have to specify the configuration fall at the command line "dagger z.cfg" or somesuch. I'll have to look at my list again to make sure.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline