VOGONS

Common searches


First post, by mrpijey

User metadata
Rank Newbie
Rank
Newbie

I downloaded and installed the new 0.65 version today! But i immediately discovered a few issues with it.

1: No hotkeys work. I can't increase/decrease cpu cycles, enable/disable fullscreen, start video capture or do anything else that uses dosbox hotkeys. Worked in 0.63.

2: Sound is stuttering. No matter what CPU cycles i use the sound skips all the time. Never did in 0.63.

I did a complete reinstall of DOSBox... new folder, new config file. I also tried with different CPU modes and video outputs. Remapping keys was also tried, but no matter what i press it's fed into DOSBox emulation and not DOSBox itself.

My system: AMD A64 3200+, 1GB RAM, NVidia 7800GS, no apps in bg except for fraps (tried without). Running newest DOSBox 0.65 and with no conf-file alterations except the ones i did above. Games tested: Wing Commander, Another World, Test Drive 3. Same problems with all.

What is so radically different in 0.65 to cause these problems since 0.63 worked like a charm?

Reply 3 of 11, by foxyshadis

User metadata
Rank Newbie
Rank
Newbie

The whole of dosbox is pretty radically different, it has been quite a while since .63. 😉

Did you try other renderers? Also, perhaps try one of the cvs compiles with D3D; at least in my case, it runs faster and with less stutters, but I'm on ATI (ogl supposedly should work better with nvidia).

Reply 4 of 11, by mrpijey

User metadata
Rank Newbie
Rank
Newbie

I tried other renderers with the exact same problem and stutter intervals. I even matched the configuration in my old 0.63 config in 0.65 with the same result. Where 0.63 worked perfectly 0.65 doesn't... OK, perhaps the sound is choppy... but if none of the quickkeys work then DOSBox is useless since i can't control its behavior... So I need that first to work.

Reply 5 of 11, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

hmm yes. there hasn't been any changes to that code.
you might want to try setting usescancodes=false.
Then you would have a 0.63 like keyboard control

Water flows down the stream
How to ask questions the smart way!

Reply 6 of 11, by Darkfalz

User metadata
Rank Member
Rank
Member

We really need "hardware2x" in place of "normal2x" since its now done in software with no hardware assist, which sucks.

Window sometimes moves up when going to windowed from full screen, eventually so the title bar is off screen and you can't move it back (exposing a pet peeve of Windows in general, not being able to move windows when you can't see their title bars, even though there's a "move" option in the right click task button menu).

Reply 7 of 11, by Zup

User metadata
Rank Oldbie
Rank
Oldbie

Are you using a Microsoft/Logitech keyboard with a "F-Lock" key?

I have traveled across the universe and through the years to find Her.
Sometimes going all the way is just a start...

I'm selling some stuff!

Reply 8 of 11, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Are you using a Microsoft/Logitech keyboard with a "F-Lock" key?

if you do, here is a site to get rid of that damn thing :
http://www.ben.pope.name/logitech.html

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 9 of 11, by NoVaTuRiEnT

User metadata
Rank Newbie
Rank
Newbie

I discovered problems with DOsbox 0.65 aswell. Sound is also stuttering for me, and I really don't think that should be so. I don't get it, my pc should be fast enough to run this emulator. With 0.63 the sound didn't stutter at all for me.

The same problem's happen with the latest cvs builds.

I've also have another problem. When I choose direct3d as the output, it crashes when I exit a game - Sometimes it displays stuffed up graphics when I exit any game (After i've been playing it for a while). This same problem happens to OpenGL, cept I get strange graphical problems on textures in the games aswell. This also happened to Dosbox 0.63 however, wasn't as bad though. Oh, and just before when I was playing Tyrian - The FPS dropped dramatically all of a sudden, and sound/music was stuttering a lot more (Was using Direct3d at the time) - Then Dosbox crashed when I exited the game.

I have a total of 8 Services running, and the only processors I have *normally* running while playing are:

csrss.exe
khotkeys.exe
lsass.exe
LtcyCfgSvc.exe
services.exe
smss.exe
svchost.exe
svchost.exe
svchost.exe
System Idle Process
System Process
winlogon.exe
xfire.exe

Btw here are my complete specs:
CPU: AMD 64 4000+ San Diago
GPU: ASUS V9999GT 256bit/256GDDR3 (GeForce 6800GT)
Sound Card: Creative Soundblaster audigy 2 ZS
RAM: 2GB Corsair XMS3200 Dual-Channel
MotherBoard: Soltek K8TPro
PSU: Antec SmartPower 2.0 500W
Operating System: WinXP Home SP2
Hard Drive: WD 200GB 8mb cache 72,000rpm IDE
Monitor: Proview TFT LCD 17"Inch
- Upgrading in a few weeks time....

i7 965 @ 3.20GHz | GTX480 | 12GB DDR3 RAM @ 7-7-7-20 1T 1333MHz
2x Velociraptor (600+300GB) HD | 1x WD MyBook 1TB External USB3 | BenQ XL2410T 120Hz
Logitech G9x/G15 | ASUS Xonar D2X PCI-E | Win7 x64 Home Premium

Reply 10 of 11, by MusicallyInspired

User metadata
Rank Oldbie
Rank
Oldbie

Strange. The only difference in .65 from .63 to me is that Elder Scrolls Arena works like a charm while it was unplayable in .63.