VOGONS

Common searches


D-Fend Reloaded (DOSBox frontend)

Topic actions

Reply 1980 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

@vorpal886:
Confirmed and will be fixed in 1.4.0b2.

@sst:
Thank you very much but development on 1.4.0 is not completed yet. There will be more new language strings in 1.4.0b2. 1.4.0b2 will be string complete to 1.4.0 then.

@Staticblast:
That's strange. Maybe there was something wrong on updating your data reader configuration file. From 1.3.5 to 1.3.6 the configuration file format has been extended and so not to break data reader for old version completely I have stopped uploading new configuration files but directly delivered a configuration file with a higher version number (10) than on the server (7). So 1.3.6 and 1.4.0b1 should use its initial configuration file (with version number 10) and old installations should not get an incompatible configuration file. But because 1.3.6 has been released long enough time ago, I have uploaded the configuration file version 10 to the server now. This means if you update your data reader configuration file (Help|Search for updates) everything should be fine again for you, too. You can have a look in your configuration file here: [your profile]\D-Fend Reloaded\Settings\DataReader.xml. If there is written version='7' you still have the old file; version='10' is the new one.

@huma79:
I'm still using Delphi 2007 because I don't want to buy an new version at the moment. The DFR source should be ready to be compiled without any special configuration.

At the moment there is still one thing on the feature wish list to be implemented before 1.4.0b2.

Reply 1981 of 2264, by Staticblast

User metadata
Rank Newbie
Rank
Newbie

The old DataReader version seems to have indeed been the issue. It also explains why uninstalling & reinstalling did nothing, since I chose to keep my profile folder on uninstall. 😊

Thanks for the assistance!

EDIT: I was wondering if there's a way to pull Mobygames data for an already existing game profile. Occasionally, though very rarely, it's something I want to be able to do, for instance if there are new boxshots added to a game listing.

4-in-1 build (thanks Phil!): AMD K6-III+ 450 / SOYO 5EMA+ / 128MB SDRAM / 80GB Seagate HDD / Voodoo 3 3000 / Orchid Righteous 3D / Sound Blaster CT2960 / MPU-401 PCMIDI Clone / HxC Floppy Emulator / 15" CRT monitor

Reply 1982 of 2264, by amix

User metadata
Rank Newbie
Rank
Newbie
IIGS_User wrote:
Alexander wrote:

mobygames has changed again.

I think it's a Cat & Mouse Game.

Why not use http://thegamesdb.net ? They offer an API and encourage its use. The reason they exist is to allow clients to gather game's metadata.

Reply 1983 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

Hi amix,

I didn't know thegamesdb.net yet. Very interessting. I will have a look at it as soon as possible.

EDIT:
Accessing thegamesdb.net is really easy. DFR 1.4.0b2 will be able to access MobyGames and TheGamesDB. Complete code for reading thegamesdb.net is done, is working fine and is much faster than reading data from mobygames.com. Only GUI for letting the user select which source to be used has to be written.

Reply 1986 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

Hi Combest,
"Systemressourcen erschöpft" means "Out of system resources". The TreeView runtime library component is used to display the filter tree on the left of the program window. If an error like this occurs in the runtime library code its likely there is something wrong on your system in general. If you want to see what D-Fend Reloaded is doing just before the error occurs, you can create an empty file named D-Fend-Reloaded-Log.txt in your desktop folder. Then DFR will log its start-up process there.

Reply 1987 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

Hi everybody,
I have just released the second beta release of DFR 1.4. The main new feature of beta 2 is the new option to choose between Moby Games and The Games DB as source when loading game meta information.

Reply 1988 of 2264, by amix

User metadata
Rank Newbie
Rank
Newbie
Alexander wrote:

DFR 1.4.0b2 will be able to access MobyGames and TheGamesDB.

Wow! That is good news! Thank you so much 😀

On a sidenote: would it be possible to have the list in the package-manager sortable? You know, by clicking the table headers. Also, when re-downloading a packages-list, it would be nice to be able to see what is new.

Also, are you aware of any sites, that offer packages with icons or screenshots or any other resources like auto-setup templates etc.? I found liquiddoom and there should have been a demos-list on dos.rc55.com, but that is a 404.

Reply 1989 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

Hi amix,
making the packages list sortable will be added in 1.4rc1. Because DFR is not storing the old list when downloading a new list emphasizing new entries would require bigger changes and will not be implemented. As far as I know there are no sites offering download packages for DFR.

Reply 1992 of 2264, by sst

User metadata
Rank Member
Rank
Member

Français Canada, French Canada 2014-06-28
Français, French 2014-06-28

See files included, ...
Voir les fichiers inclus, ...

@sst:
Thank you very much but development on 1.4.0 is not completed yet. There will be more new language strings in 1.4.0b2. 1.4.0b2 will be string complete to 1.4.0 then.

@Alexander:
You have released 1.4.0rc1, then i have complete the 1.4.0 translation, i hope it's correct that time.

Attachments

  • Filename
    French.ini
    File size
    140.02 KiB
    Downloads
    93 downloads
    File comment
    Français, French 2014-06-28
    File license
    Fair use/fair dealing exception
  • Filename
    French Canada.ini
    File size
    139.98 KiB
    Downloads
    97 downloads
    File comment
    Français Canada, French Canada 2014-06-28
    File license
    Fair use/fair dealing exception

Reply 1994 of 2264, by SentaiBrad

User metadata
Rank Newbie
Rank
Newbie

So I have been having a problem for quite a few versions now with D-Fend and because I have so many games its getting worse and worse as I try to search them through MobyGames or GamesDB now.

So I love the search function to fill out info and download images because it helps me sort my huge collection, but after so many successful searches I get an error which causes the entire program to close and I have to restart it, and it happens every time after several searches.

First I get:
"Error reading data from dfendreloaded.sourceforge.net

then I get:
"Access violation at address 005C3421 in the module 'DFend.exe'. Read of address 00000010.

I am running the latest built 1.4.0 but like I said I've had this issue for a very long time. Any thoughts or help?

Reply 1995 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

After two month of beta phase I'm releasing D-Fend Reloaded 1.4.0 and even before writing a "New version is out" message here I get a "Not working" post. Why now? Why not yesterday or last week? Always when I'm thinking a new version is done and I won't need to work on DFR the next weeks something like this happens.

The address 005C3421 cannot be linked to a source code line. "Error reading data from dfendreloaded.sourceforge.net" means the process of updating the data reader configuration file (which is located on dfendreloaded.sourceforge.net and is read before connecting mobygames) can not be loaded. Maybe there is a problem on your internet connection.

For me D-Fend Reloaded 1.4.0 is working fine: I can access MobyGames and also TheGamesDB. I can't reproduce your problem so I don't know how to help you.

Reply 1996 of 2264, by SentaiBrad

User metadata
Rank Newbie
Rank
Newbie

I can access them just fine, and import data just fine, but after a few tries it gives me that error. I've just lived with it for a very long time and several versions, so I was curious if anyone could shed light on it is all. I'm sorry 😜

Reply 1997 of 2264, by amix

User metadata
Rank Newbie
Rank
Newbie

Hi Alexander,
the "sort columns in datapackage manager" function is much slower than in the main library window and considers 999KB to be bigger than 99MB.

There may be downloadable packages the user already has installed, but the dentification is different from the installed one. For example "Foo Bar 2" (that's how it appears in the main library) vs. "Foo Bar II: Return of the Bar" (that's how it appears in the package manager, coming from another source) The game is the same. Could there be an option, to manually hide packages from display in the package manager?

P.S. Seeing your other post, I downloaded the 1.4RC yesterday and just came around to test it today. That's the pain of software development: It always goes on and on and on and on and on. And sometimes it is a very thanless job 😉 You know the Internets...

Reply 1998 of 2264, by Alexander

User metadata
Rank Oldbie
Rank
Oldbie

I'm working on a first release candidate of a 1.4.1 version addressing the described problems. What I have done so far:

  • The moby games data reader will react more relaxed when trying to update the configuration on startup but the server is not responding (and at least an outdated configuration file is still available). This should reduce the chance to see an "Error reading data from dfendreloaded.sourceforge.net" message.
  • Rebuilding the packages list after resorting should be faster now. (But I still do not understand why the list building speed of a list of 15 entries should be of any meaning.)
  • When sorting the lists in the package manager by download sizes, the list will be sorted by size and not lexicographic.
  • Updated Italian translation.
  • Records can be manually deleted from the package manager via the context menu. (A better automatic detecting which games are already installed is not possible. DFR is comparing the real game exe md5 checksums with the game exe md5 checksum stored in the package description. If they are different DFR thinks the game is another version and offers it for installation.)

I really do not understand why things like this are of any importance. The package system was once meant as a thing like the Firefox extension system but never worked - nobody offered any packages. So this is a dead feature for me and I'm thinking about removing it because it's just making problems. And now again I have spent my whole weekend on improving this pointless thing and will have to make a whole release for it.