"Lib error 3" on DOSBOX 0.58

General information and assistance with DOSBox.

"Lib error 3" on DOSBOX 0.58

Postby fangorn1ent » 2003-8-15 @ 16:48

WinXP, up-to-date: The "Lib error 3" message occurs after clicking on Start a new game with Kyrandia 2 (The Hand of Fate) which I downloaded from C:DOS. Kyrandia 1 worked fine and many other old DOS games on DOSBOX 0.58 work as expected. Could anyone tell me where this message is coming from? I grepped all of the source tree but could not find a place where "Lib" error reports are being generated.

Interestingly enough, I get the identical symptom with DOSBOX 0.58 that I built on a Redhat Linux 9 (up2date) machine.

Both environments are very different hardware and, obviously, different OSes. So, it sounds like a package issue.

Anyone see this symptom before? Any clues or suggestions on pursuit? When I get some free time, I will pursue this on Linux as I have no development kit for Windoze.
Posts: 1
Joined: 2003-8-15 @ 16:01

Postby Qbix » 2003-8-16 @ 20:00

This lib 3 error:
Does it apear in the dosbox window (the one in which you type your commands/move your mouse )

or does it apear in the littlewindow in the back (or the xterm under linux)

if it's case 1 :-> the game doesn't like a certain feature of dosbox or dosbox doesn't do what the game expects.

if it's case 2 :-> dosbox doesn't like the game. game uses unsupported features.

both cases are hard to fix. But I advice you to try it with current CVS first. (and try running it with sound disabled)

Water flows down the stream
How to ask questions the smart way!
User avatar
DOSBox Author
Posts: 10919
Joined: 2002-11-27 @ 14:50
Location: Fryslan

Postby Finster » 2003-8-16 @ 23:59

Kyrandia 2 doesnt work with current cvs either. The error is a bit different though. The error message is generated by the game and is independant of the used operating system. I'm quite sure it worked earlier, so probably some functionality was broken. There seems to be no way to get this game working in dosbox atm. Looks like a debugging session is needed...
DOSBox Author
Posts: 28
Joined: 2003-8-16 @ 23:50

Return to DOSBox General

Who is online

Users browsing this forum: No registered users and 2 guests