VOGONS

Common searches


First post, by TeaRex

User metadata
Rank Member
Rank
Member

"...try an output different from surface."

I did try all other options (overlay, opengl, openglnb) but it doesn't seem to change anything - I still end up with a small content area surrounded by large black borders in fullscreen mode. DOSBox shows NO error messages of any kind (e.g. "falling back to surface mode" or some such) when started. And when I type "output" at the prompt I always get the right answer.

I'm on Ubuntu 13.04, using their NVIDIA 313.30 drivers on a GTX 260 card. The problem appeared when I finally replaced my trusty old CRT with a flat panel display and got rid of all my special X Modelines. I used to run DOSBox at the native DOS resolutions and refresh rates, now I'd like it to work at (and make full use of) 1280x1024x60Hz.

My dosbox.conf and xorg.conf are attached.

I'd be thankful for any ideas...

Attachments

  • Filename
    xorg.conf
    File size
    3.52 KiB
    Downloads
    34 downloads
    File license
    Fair use/fair dealing exception
  • Filename
    dosbox.conf
    File size
    10.94 KiB
    Downloads
    40 downloads
    File license
    Fair use/fair dealing exception

tearex

Reply 1 of 6, by NY00123

User metadata
Rank Member
Rank
Member

Hey,

In case you haven't yet done so, make sure you update to a more recent SVN build. With that, fullresolution=desktop (or fullresolution=0x0) should do the job.

Alternatively, in your case you can also try fullresolution=1280x1024.

Reply 2 of 6, by TeaRex

User metadata
Rank Member
Rank
Member

Thanks NY00123. I'm building from current SVN code. Unfortunately, none of your fullresolution= suggestions seem to make any difference.

I should add that "scaler=normal2x" or "scaler=normal3x" does nothing either. Appending "forced" to the scaler line causes DOSBox to fail at startup - "normal2x forced" fails with an X server error, "normal3x forced" fails with a segmentation fault.

I tried exult (for another SDL app) and it has the same problem, but in exult you can at least enable a 4x Point scaler and aspect correction, and then it works.

tearex

Reply 3 of 6, by NY00123

User metadata
Rank Member
Rank
Member

That sounds a bit weird to me. If possible without destroying a lot of things I'd start from scratch with a clean xorg.conf file. What is probably more helpful, though: Move dosbox.conf to a temp location and simply use a newly created ~/.dosbox/dosbox-SVN.conf file. Once the latter is (re)created, fullresolution=0x0 (or desktop or 1280x1024) should do the job with recent SVN builds.

Note that anything that uses a textual mode (like the DOS prompt) may not fill much of the screen the way you'd expect it to. Basically, the "aspect" setting is ignored in such a case (by design) and so do the scalers (without the "forced" keyword).

Oh yeah, you seem to have "machine=vgaonly". When combined with "output=surface" and "scaler=normal2x forced", that may be the cause of the crash. You see, the DOSBox prompt should have a pixel resolution of 720x400 on startup when "machine=vgaonly" is specified. If you also add "scaler=normal2x forced", DOSBox tries to output 1440x800 pixels. The behavior is undefined in such a case, at least with "output=surface", since your display's pixel width is less than 1440.

Reply 5 of 6, by TeaRex

User metadata
Rank Member
Rank
Member

Looks like "machine=vgaonly" was the culprit. With "machine=svga_s3" everything works as it should, even without any scalers. Now I'm just wondering why vgaonly is so problematic.

@collector: I'm trying to fill a full screen. At least to the point where there's black bars only at the top and bottom rather than on all four sides.

tearex

Reply 6 of 6, by NY00123

User metadata
Rank Member
Rank
Member
TeaRex wrote:

Looks like "machine=vgaonly" was the culprit. With "machine=svga_s3" everything works as it should, even without any scalers. Now I'm just wondering why vgaonly is so problematic.

Oh yeah, before I forget: When you specify "machine=vgaonly", "output=surface" is practically forced (even if this is not what is set in the configuration file). Well, maybe there is a case I have missed where it is not occuring, but this is what I seem to experience so far. Anyway, that must explain why isn't your screen filled as it does with "machine=svga_s3". Unfortunately, I'm afraid you'll have to live with it, unless you can somehow scale things by changing driver settings. Anyway, for games that don't benefit from "machine=vgaonly" (for things like copper effects), other choices probably bring better performance.