VOGONS

Common searches


First post, by lukeman3000

User metadata
Rank Member
Rank
Member

Edit: Figured out the problem. Doxbox seems to not play nicely with G-Sync. I have a G-Sync monitor and have it enabled. On a whim, I disabled it and the problem was resolved. That said, does anyone know what the underlying issue might be and how to correct it so that I don't have to manually disabled G-Sync every time I want to play a game in Dosbox?

Furthermore, what should my Nvidia control panel settings be for Dosbox? Here's what they look like now:

http://imgur.com/a/Vl48O

I originally noticed this problem while playing Space Quest IV but it has manifested in other games such as King's Quest IV and […]
Show full quote

I originally noticed this problem while playing Space Quest IV but it has manifested in other games such as King's Quest IV and Quest for Glory II. While playing, if I move the mouse cursor the game and the game's audio will stutter. An example can be seen here:

https://youtu.be/k11fjOJLO1g?t=28

I am running Dosbox 0.74 on the following machine:

Windows 10 64-bit
Titan X Pascal
256 GB SSD
8 GB DDR3 RAM
Razer Deathadder Chroma mouse
Razer Blackwidow Chroma keyboard

Dosbox conf file:

# This DOSBox configuration file was automatically created by D-Fend Reloaded.
# Changes made to this file will NOT be transfered to D-Rend Reloaded profiles list.
# D-Fend Reloaded will delete this file from temp directory on program close.

# Command line used when starting DOSBox:
# -CONF "C:\Users\lmill\AppData\Local\Temp\Space Quest IV - Roger Wilco and the Time Rippers.conf" -NOCONSOLE

# Config file for profile "Space Quest IV - Roger Wilco and the Time Rippers"

[sdl]
fullscreen=true
fulldouble=false
fullresolution=1920x1080
windowresolution=1024x768
output=overlay
autolock=true
sensitivity=100
waitonerror=true
usescancodes=true
priority=higher,normal
mapperfile=L:\Games\D-Fend Reloaded\mapper.map

[dosbox]
machine=svga_s3
captures=L:\Games\D-Fend Reloaded\Capture\Sierra41\
memsize=16

[render]
frameskip=0
aspect=true
scaler=normal3x

[cpu]
core=normal
cputype=auto
cycles=fixed 10000
cycleup=10
cycledown=20

[mixer]
nosound=false
rate=44100
blocksize=1024
prebuffer=10

[midi]
mpu401=intelligent
mididevice=default
midiconfig=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplrate=44100
oplemu=default
Show last 48 lines

[gus]
gus=false
gusrate=44100
gusbase=240
gusirq=5
gusdma=1
ultradir=C:\ULTRASND

[speaker]
pcspeaker=true
pcrate=44100
tandy=auto
tandyrate=44100
disney=true

[dos]
xms=true
ems=true
umb=true
keyboardlayout=US

[joystick]
joysticktype=none
timed=true
autofire=false
swap34=false
buttonwrap=false

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[autoexec]
@echo off
SET PATH=Z:\
keyb US 437
mount C "L:\Games\D-FEND~1\VIRTUA~1\"
echo.
C:
cd\
cd \GAMES\SQ4
Z:\config.com -securemode > nul
SIERRA.EXE
exit

Reply 1 of 5, by NY00123

User metadata
Rank Member
Rank
Member

Just a couple of suggestions:

- Try changing the value of the DOSBox "output" setting to any of the other choices.
- NVidia's "Vertical sync" may have an effect. Truly, since NVidia's setting is configured to respect DOSBox' behaviors (which means to disable VSync when opengl/openglnb output is used), I don't think this should have an effect, but I'm still mentioning this, just in case.

Reply 2 of 5, by YaketyYakumo

User metadata
Rank Newbie
Rank
Newbie

I'm having the same issue, but it's not G-Sync related (I have an AMD card and two non-Freesync monitors). Seems to appear regardless of output options. Any ideas?

So far it's been an issue in Carmageddon and Wing Commander III - it'll be running just fine but as soon as I jiggle the mouse, stutter city.

EDIT: Rebooting fixed it, must have been something I had running in the background?

Reply 4 of 5, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

I haven't specifically tested gsync with DOSBox but I do have a gsync monitor.

I thought by default gsync only applies to fullscreen?

Have you tried other DOSBox output options?

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 5 of 5, by hwh

User metadata
Rank Member
Rank
Member

Was having this issue.
I am using openglnb and don't want to change that since that drastically lowers quality.

MiniMax recommended

Try forcing the core=dynamic and set frameskip=1.

Now, unsure which of those two seemingly did it, or if that's what I will stay with, but the effect was immediate.