Dosbox 0.74 on Linux - Static Sound

General information and assistance with DOSBox.

Dosbox 0.74 on Linux - Static Sound

Postby a4orce84 » 2017-12-24 @ 06:50

Hello Everyone,

I've recently installed DosBox 0.74 on Arch-Linux on my new Dell XPS 13. I use DosBox to play a lot of old school games (Doom, Commander Keen, etc.). I have installed it in the past on several different Windows Versions and MacOS without any issues. However, under Linux I am getting the following issue:

Issue:
It appears that sometimes I get a static sound coming from my speakers when playing most of my DOS games. Running DosBox in the terminal (command line), I get the following output:
------------------------------------------------------------------------------------------------------------------------------------
[aahmad@aahmad-pc .dosbox]$ dosbox
DOSBox version 0.74
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file /home/aahmad/.dosbox/dosbox-0.74.conf
MIXER:Got different values from SDL: freq 44100, blocksize 512
ALSA:Can't subscribe to MIDI port (65:0) nor (17:0)
MIDI:Opened device:none
------------------------------------------------------------------------------------------------------------------------------------

I am not sure if this explains why I am experiencing static in most of the games that I play, but wanted to include all the information. Does anyone have any ideas on how to 'clean up' my sound, and have all the games sounding perfectly during gameplay?

Thanks in advance for everyone's time and help, it is greatly appreciated!

Thanks,
Ace
a4orce84
Newbie
 
Posts: 12
Joined: 2014-7-15 @ 15:21

Re: Dosbox 0.74 on Linux - Static Sound

Postby gdjacobs » 2017-12-24 @ 20:13

Those warnings are common and shouldn't cause issues. Do you have Pulseaudio enabled in Arch?
User avatar
gdjacobs
l33t++
 
Posts: 5157
Joined: 2015-11-03 @ 05:51
Location: The Great White North

Re: Dosbox 0.74 on Linux - Static Sound

Postby a4orce84 » 2017-12-24 @ 20:56

gdjacobs wrote:Those warnings are common and shouldn't cause issues. Do you have Pulseaudio enabled in Arch?


I do, and it works perfectly fine in other applications. Chrome, FireFox, Music, Videos, etc. play fine without any static. It's just at times DosBox has a static sound that becomes louder and more audible when playing a game with a lot of sound / sound-effects going on.

Please let me know if I can provide any additional information to assist in the troubleshooting process. TIA.
a4orce84
Newbie
 
Posts: 12
Joined: 2014-7-15 @ 15:21

Re: Dosbox 0.74 on Linux - Static Sound

Postby gdjacobs » 2017-12-25 @ 05:13

I've had issues in the past where the buffer / scheduling woo that PA uses caused distortion and clicking. I eventually switched to JACK out of frustration and will never, ever switch back.
https://wiki.archlinux.org/index.php/Pu ... _crackling

It's certainly possible that this isn't the issue in your case, but disabling PA and piping straight into ALSA is probably a good troubleshooting step.
User avatar
gdjacobs
l33t++
 
Posts: 5157
Joined: 2015-11-03 @ 05:51
Location: The Great White North


Return to DOSBox General

Who is online

Users browsing this forum: No registered users and 2 guests