VOGONS

Common searches


First post, by OpenRift

User metadata
Rank Newbie
Rank
Newbie

Recently, for some reason, there's this occasional but very noticeable stutter in the video, audio, and MIDI. I've tried pretty much everything suggested online but it's not working. The only solution I've found is switching from OpenGL to a different output which fixes the problem. The thing is, I want to be able to use GLSL shaders (see SVN builds) with DOSBox so I can play with a CRT shader, which of course requires me to use OpenGL output to enable.

Things I've tried
- Audio blocksize/prebuffer
- Adjusting cycles/core
- Changing program settings from nvidia control panel
- Adjusting frameskip
- adjusting vsync
- some others I've probably forgotten
- disabling shaders

Initially I suspected it had to do with virtualmidisynth, but even when I uninstalled it the stuttering remained.

With all that said, any suggestions on how to fix this?

Reply 2 of 6, by OpenRift

User metadata
Rank Newbie
Rank
Newbie
ripsaw8080 wrote on 2020-10-09, 19:42:

Disable vsync, unless that's what you meant by "adjusting" it. OpenGL output with vsync enabled is known to cause stutter.

That is what I mean. That doesn't work either, as I've had vsync disabled by default. And yes, I've tried with it on and it yields the same results.

Reply 3 of 6, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

The fact that it's only OpenGL output affected is a very strong indicator. There have been others who made similar reports saying vsync made no difference, only to come back later and admit it wasn't disabled after all because they didn't change the setting in the right place.

Reply 4 of 6, by OpenRift

User metadata
Rank Newbie
Rank
Newbie
ripsaw8080 wrote on 2020-10-09, 20:16:

The fact that it's only OpenGL output affected is a very strong indicator. There have been others who made similar reports saying vsync made no difference, only to come back later and admit it wasn't disabled after all because they didn't change the setting in the right place.

For reference, I've tried turning off vsync in the conf file and the nvidia control panel, if there's somewhere else I should try, please let me know.

Reply 6 of 6, by OpenRift

User metadata
Rank Newbie
Rank
Newbie
ripsaw8080 wrote on 2020-10-10, 00:37:

In the conf file? I guess you're using an unofficial build, and those aren't supported here.

Yes, but here's the thing, I've tested with both the vanilla SVN builds and DOSBox-staging and they both have the same result.