VOGONS

Common searches


First post, by mike_canada

User metadata
Rank Newbie
Rank
Newbie

Ok, so I am running DOSBOX on linux with webserv downloaded for DOSBOX from rubbermallet.org and sometimes it serves pages fine to my linux browser and other times, I get reported "connection reset by peer" messages.

I borrowed DOSBOX networking ideas from this url:
https://www.dosbox.com/wiki/Slip_configuration_on_linux_host

and I changed baud rate setting from 9600 to 115200 and for slattach and socat, I added the -v option to see all network activity between DOSBOX and linux

As activity happens, I see a date and time stamp along with the number of bytes that got passed along with data. When I look at the raw log, it looks as if all the data has been sent from DOSBOX because I see the closing HTML tag which is what I always add to the end of my HTML webpages that I create.

If I use linux curl to access some of my pages (which DOSBOX already produced HTML output with correct headers), I see only the correct headers show up and receive the following error:

* Recv failure: Connection reset by peer
* Closing connection #0
curl: (56) Recv failure: Connection reset by peer

Attempting the same page gives me a less helpful answer in Seamonkey browser:

Connection Interrupted
The document contains no data.
The network link was interrupted while negotiating a connection. Please try again.

The only thing I can think of is that a certain byte or set of bytes are being passed between DOSBOX and linux and one of linux's utilities (socat and/or slattach) is converting those set of bytes to data that indicates premature ending to the HTML to linux yet the logs from those utilities (from using the -v switch to both) show full HTML has been received.

Why do I suspect this? because I remembered when I was outputting data to the serial port in linux one time to an actual piece of hardware connected to the serial port, the data wouldn't flow because I was using character codes 10 and 13 which I later found out online was software flow control.

Could there be a better way of setting up a network between linux host and dosbox so dosbox has access to internet and that linux won't take a sequence of characters as if the data is supposed to end when it shouldnt?

Reply 1 of 1, by mike_canada

User metadata
Rank Newbie
Rank
Newbie

Ok I figured things out.

When loading the network packet driver in dosbox, I use this because I'm using COM2 at high speed and I use -p to prevent packets not designed for the box from coming in:

ethersl -p 0x60 3 0x2F8 115200

Then I needed to make use of the following parameters appended to ifconfig in my linux script. I tried a value after txqueuelen lower than 10 (which was the default) and it made matters worse, so I tried a higher value and things worked alot better.

mtu 1524 txqueuelen 15240