VOGONS

Common searches


First post, by yoann

User metadata
Rank Newbie
Rank
Newbie

Hello everybody out there!

I am running DOSBox 0.74-3 on Linux. I am using a French keyboard. On such a keyboard, the right <Alt> key is actually a specific <AltGr> key, which allows for writing down some special characters. For instance, on such a keyboard, <AltGr> + <2> writes “~”, which is useful to mount some directory into DOSBox.

However, it turns out that whenever I hit the <AltGr> key inside DOSBox, I get a carriage return. Therefore, I cannot write down some characters, such as “~”. Is this a known issue? I have not found anything on the matter on the Internet. Anyway, I guess it is possible to change this behaviour, but I have not found a way to do so.

Can somebody help me out this?

Best regards.

Reply 4 of 12, by yoann

User metadata
Rank Newbie
Rank
Newbie

Hello every body out there!

Well, I have made some research, there are two Wayland related DOSBox bugs reported in Debian:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837381

https://bugs.debian.org/cgi-bin/bugreport.cgi … ug=928046;msg=2

I will try and do some tests with X.org.

Best regards.

Reply 5 of 12, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Are you experiencing those issues?

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 6 of 12, by yoann

User metadata
Rank Newbie
Rank
Newbie
DosFreak wrote on 2021-02-24, 20:58:

Are you experiencing those issues?

I cannot say yet, because the issue with the <AltGr> key prevent me to mount directory with DOS games.

I did not had the opportunity to restart with X.org yet, I will try and keep you in touch.

Reply 7 of 12, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

the evdev detection might go wrong as if evdev is detected then:

 sdlkey_map[0x64]=SDLK_RALT;

and if it is not detected

sdlkey_map[0x64]=SDLK_KP_ENTER;

which kinda matches your behaviour of enter being pressed instead of the right alt.

(this is code that dosbox executes on startup in the keymapper to map the keyboard correctly)

Does usescancodes make a difference for you ?

Water flows down the stream
How to ask questions the smart way!

Reply 8 of 12, by yoann

User metadata
Rank Newbie
Rank
Newbie

Hello everybody out there!

Qbix wrote on 2021-02-25, 15:43:

Does usescancodes make a difference for you ?

Well, as far as I understand, it does not: when I enter KeyMapper (<Ctrl> + <F1>) and click on the right <Alt> key, here is the setting:

EVENT:keyr_alt
BIND:Key right alt

Best regards.

Reply 9 of 12, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

usescancodes is an option in the configuration file of dosbox, was that what you changed ?

Water flows down the stream
How to ask questions the smart way!

Reply 10 of 12, by yoann

User metadata
Rank Newbie
Rank
Newbie

Hello everybody out there!

Qbix wrote on 2021-02-25, 17:35:

usescancodes is an option in the configuration file of dosbox, was that what you changed ?

No, I did not change anything.

Now, I have switched back to X.org and then there were no problem any more: the right <Alt> key was recognized as <AltGr>. I have launch Another World, I have been able to play the entire game without any problem.

Well, it turns out DOSBox has some trouble with Wayland.

Best regards.

Reply 11 of 12, by _Rob

User metadata
Rank Member
Rank
Member

Just want to say that this is an issue with SDL1. DOSBox forks using SDL2 are not effected by this and AltGr works fine.

For SDL1 DOSBox builds (including forks), if you have a non-US keyboard you should set usescancodes=true but it will not solve the AltGr problem.

Reply 12 of 12, by yoann

User metadata
Rank Newbie
Rank
Newbie

Hello everybody out there!

_Rob wrote on 2021-03-11, 21:24:

Just want to say that this is an issue with SDL1. DOSBox forks using SDL2 are not effected by this and AltGr works fine.

For SDL1 DOSBox builds (including forks), if you have a non-US keyboard you should set usescancodes=true but it will not solve the AltGr problem.

Thank you for this answer.

Is there a plan for DOSBox to switch to SDL2?

Best regards.