VOGONS


First post, by g_turrisi

User metadata
Rank Newbie
Rank
Newbie

Hi all 😀

It's great to be here 😀

I was trying to compile latest Dosbox ECE from the source on my Raspbian Buster.

Compilation had some problem first with mt32emu (solved installing the munt package), then with gfx voodoo support...

I discovered there was some patches to make everything work, but they seems a bit outdated 🙁

I didn't succed to compile Dosbox ece for my Raspbian buster.

Is there any updated patch to apply to DosBox ECE sources to make it compile w/out any problem on Raspberry Pi?

Thanks in adavance,
Giuseppe

Reply 5 of 5, by ashurasai

User metadata
Rank Newbie
Rank
Newbie

The problem with the compilation of DOSBox-ECE I think can be solved if openglide can be ported to use OpenGLES in place of OpenGL. The DOSBox-ECE makefile references sdk2_glide.h which can be found in openglide. The openglide git repo is here: https://github.com/voyageur/openglide it's not been touched for a few years. If anyone has any experience with porting opengl calls to opengles it might work. I'm not an expert with this though, and I don't think I've got the time to learn. If it compiles straightaway on the pi I'll reply to this post shortly. If not then future generations can assume that it didn't work and they'll need to fork openglide to work on opengles. To compile DOSBox-ECE on opengl compliant systems you need to make sure that the makefile points to the header and the library for openglide properly, the autogen.sh script doesn't always do this, though it might be that my installation is a bit weird.