VOGONS


First post, by L@Zar0

User metadata
Rank Newbie
Rank
Newbie

Hi,

first, thanks a lot for this great job of doing DOSBox. It is an impressive tool for play with old games among other things. Congratulations.

This is my first post, until now I had not though in posting here because DOSBox is doing excellent job with things I'm doing. I'm a translator of games from english to spanish. You can find me in www.clandlan.net.

Now I'm trying to translate the GOG version of Crusader - No Regret into spanish. It has spanish version, but never was updated to English v1.06.

I can do near all the job, but I found an issue which makes that the open exclamation char "¡" is not well displayed in the cinematics. But I'm not sure which is the problem. Ok. I will put two images.

This image is of the execution of the game with "keyboardlayout=auto" parameter in .conf file:

MS51vCa.jpg

This image is of the execution of the game with "keyboardlayout=ES":

vRHzwku.jpg

Do you see the opening exclamation mark in "¡Joystick no detectado!"?
It is different when using one codepage or another. AND, it should be the same glpyh (for opening and closing exclamation marks).

The first image uses (if I press keyb) 437 codepage. The second one uses 850 codepage.

Could the opening exclamation mark be changed in 437 codepage as the one in 850 codepage?

I think the game uses the same charset font for the cinematics, and it has this problem (different exclamation marks) using any codepage. So the problem is worst.

I hope you can help. Thanks a lot.

Last edited by L@Zar0 on 2021-02-23, 15:22. Edited 1 time in total.

Reply 1 of 2, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Hello, dosbox-staging isn't supported here. For that fork you'll need to open an issue on their site. This forum is for the official version of dosbox.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 2 of 2, by L@Zar0

User metadata
Rank Newbie
Rank
Newbie

I beg you pardon. I have updated the images with the DOSBox version that comes with the GOG release of Crusader - No Remorse.

I had tested staging because I wanted to check if the problem was the same and I had done the images over it. And it happens the same, of course.

The procedure and result is the same.

This is the result when playing and using the exclamation marks in-game (cinematic):

AzY6Lmg.jpg

It does not happens when executing the game (makes some checks) and outputs some lines, having changed the codepage to 850. It uses svga resolution.
But it does not matter the codepage used in the cinematics, it seems to print always the opening exclamation mark with the same glyph (0xAD of the 437codepage?)

PD: Ok, I think it is part of the font file of the own game. I though it was using the font of the system, but not.