VOGONS


First post, by Giuliano

User metadata
Rank Newbie
Rank
Newbie

Hi all,

DOSBox has a plethora of configuration options regarding image generation, allowing us to play our favorite retro games. For my taste, the best DOSBox options are:

[sdl]
fullscreen = true
fulldouble = false
fullresolution = desktop
windowresolution = original
output = opengl

[dosbox]
machine = svga_s3

[render]
aspect = true
scaler = none
glshader = sharp

What are your preferences?

Reply 1 of 5, by leileilol

User metadata
Rank l33t++
Rank
l33t++

At least have scaler=normal2x because VGA was doublescanned. Similarly, there's situations where machine=vgaonly is important to get games to render properly (and at this point, looks the most accurate for VGA it can be but doesn't have any of the VBE in there).

There's no one best rendering config. The default DOSbox config covers a lot of common use bases and the best performance, but doesn't reach the exotic demos, VGA scanline trick games or the early CGA palette trickers.

apsosig.png
long live PCem

Reply 3 of 5, by buckeye

User metadata
Rank Oldbie
Rank
Oldbie

I usually keep to the default settings but there is one game I wish there was a way to spruce up the visuals and that's Front Page Sports
Football Pro 95 by Sierra/Dynamix. Maybe later on another post I'll attach a screenshot and perhaps someone can offer some insight.

Intel D865GL Pentium 4 2.4ghz. 512MB DDR 400 Geforce2 GTS 64MB SB Audigy 500W 98SE
Intel SE440BX P3 450 256MB 40GB Voodoo 3000 16MB SB 32pnp 350W 98SE
MSI x570 Gaming Pro Carbon Ryzen 3700x 32GB DDR4 Zotac RTX 3070 8GB WD Black 1TB 850W

Reply 4 of 5, by Giuliano

User metadata
Rank Newbie
Rank
Newbie
leileilol wrote on 2022-09-18, 20:53:

At least have scaler=normal2x because VGA was doublescanned.

Hi, leileilol, I've changed from scaler=none to scaler=normal2x, and I didn't notice any improvement in the images. I've attached two images of a 1990's game called Red Baron, one for each scaler.

Should it have improved?

I am not a developer, so I don't understand the inner workings of DOSBox. I may be completely wrong in the next statement, but I believe that when I choose fullresolution=desktop and/or glshader=sharp, the scaler option is ignored.

Cheers!

Attachments

Reply 5 of 5, by Giuliano

User metadata
Rank Newbie
Rank
Newbie
BardBun wrote on 2022-09-20, 22:26:

output=openglnb

aspect=false

Hi BardBun, I haven't tried openglnb yet. Will give it a try next week.

As for aspect=false, I don't like the distorted image it generates. For instance, in the Red Baron game, the original image is 320x200 px, and the VGA card transformed it to 640x480 in orther to fit it correctly in a 4:3 monitor screen. So, with aspect true, the cockpit's dials appear correctely round. But with aspect false, they appear oval.

Attachments