Duke Nukem 3D

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by Devilforgemaster45

User metadata
Rank Newbie

I can't get this to run. I have the disc as an image file on my comp, it installed fine but when I mount it through alcohol 120% and then dosbox, when the game gets ready to start it checks a few things and then it says to insert the cd. I tried the imgmount command too and it still did not work. Any help would be greatly appreciated. Thanks in advance.

Reply 2 of 14, by franpa

User metadata
Rank Oldbie

tried installing through DOSBox? or did you just install from the CD then try and play it from DOSBox?

AMD Ryzen 3700X | ASUS Crosshair Hero VIII (WiFi) | 16GB DDR4 3600MHz RAM | MSI Geforce 1070Ti 8GB | Windows 10 Pro x64.

my website

Reply 4 of 14, by Xelasarg

User metadata
Rank Member

DOSBox Readme FAQ:

Q: The game/application can't find its CD-ROM. A: Be sure to mount the CD-ROM with -t cdrom switch, this will enable the MSCD […]
Show full quote

Q: The game/application can't find its CD-ROM.
A: Be sure to mount the CD-ROM with -t cdrom switch, this will enable the
MSCDEX interface required by DOS games to interface with CD-ROMs.
Also try adding the correct label (-label LABEL). To enable lower-level
CD-ROM support, add the following switch to mount: -usecd #, where # is
the number of your CD-ROM drive reported by mount -cd. Under Windows you
can specify -ioctl, -aspi or -noioctl. Look at the description elsewhere
in this document for their meaning.
Try creating a CD-ROM image (preferably CUE/BIN pair) and use the
DOSBox-internal IMGMOUNT tool to mount the image. This enables very
good low-level CD-ROM support on any operating system.

Have you tried this?

"What's a paladin?!"

Reply 8 of 14, by ripsaw8080

User metadata
Rank DOSBox Author
DOSBox Author

I recommend trying the things mentioned here:


Particularly the stuff regarding the CDROM.INI file, and maybe the patch to version 1.5 if you don't already have that version.

I have the Atomic Edition 1.5 running pretty well in DOSBox 0.7x without a CD at all, just by copying ALL the files into the install folder and editing the CDROM.INI file to make it empty.

Reply 9 of 14, by vogon player

User metadata
Rank Newbie

Ripsaw8080 is correct. Duke Nukem 3D 1.5 Atomic version needs to be able to locate the 'Support' folder from the CD. Whether this is accomplished by mounting an image of the CD or just copying the files over to your hard drive does not matter, but you do need to modify the CDROM.INI file so that it points to the path for this folder.

I use an iso image to mount my CD as drive D:\. First I created a batch file that I use within DOSBox to mount the image as follows:

imgmount d C:\CD\ATOMIC15.iso -t iso
call duke3d
mount -u d

For the command lines above, use the path within DOSBox, not the actual path.

Example: I have the iso stored in C:\DOSBoxRoot\CD\ on my hard drive, but when I run DOSBox, I mount C:\DOSBoxRoot\ as C:\, this means that my batch file needs to locate the iso image file in C:\CD\

Next you need to modify the CDROM.INI file in your Duke 3D folder so that it can locate the 'Support' folder on the CD as follows:


Be sure to include the trailing back slash at the end. If I recall, the game will not be able to locate the folder if its not there.

I hope this helps.


The method outlined above also works for NAM/Napalm, and WWII GI 😉

Reply 13 of 14, by JonnyBoy

User metadata
Rank Newbie

2 get duek nukem 3d to run INSTALL under vista or xp do the followingf:

  • Install duke nukem under - c:\duke3d
    Next drag the duke.cfg file untop of the dosbox icons to load the file in dosbox
    Next doesbox will load showing an error but just hit enter then type c:\duke3d & the game will load, but only with no sound,