insert cd and insufficient hard disk space error

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by DANZEMAN

User metadata
Rank Newbie

Hi, I have dosbox .63 running on Vista, the problem I have is it says there is not enough disk space for a 400mb game when I have about 80gig free?

This is exactly what i type in dos- mount c c:\retro (then) mount e:\ -t cdrom (then) e:install

Now i have 3 options mini install 2mb, normal60mb or full 400mb,..........it will install the 1st 2 but not the 400mb one. anyway I tried playing with the 1st 2 but it goes to load then flicks back to command promp sayin cd must be inserted in cdrom error...that is why i wanted the 400mb cos u dont need cd to play.

it is an image iso file burnt onto cd disk, also tried power iso same error!

Last minute notes:
I tried compatability modes screen res and colour to no avail.
The game is called constructor.
all my other games work like sensi soccer, settlers etc.......

Come on you guys dont let me keep fighting this frustrating battle alone i need reinforcments!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Reply 1 of 8, by MiniMax

User metadata
Rank Moderator

1) 0.63 is quite old. Very old in fact. Get 0.72.

2) I hope that is not exactly what you typed: mount e:\ -t cdrom.

3) Line 362 in here: http://tinyurl.com/jqa3n

DOSBox 60 seconds guide | How to ask questions
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Fedora 32

Reply 2 of 8, by DANZEMAN

User metadata
Rank Newbie

Thanks for getting back to me...... No that is not exactly what I type sorry, the exact way I do it is this:-
Z:mount c c:\retro then mount d e:\ -t cdrom -usecd 0 -aspi (it says d is mounted as cdrom).
then i type e: (then) e:\install
it then goes to the install options Minimum 2mb Normal 60mb or maximum 400mb.
It wont let me install 400mb one, it says there is not enough hard disk space available!
when i install the 60mb to C:\retro (then) type c:\retro\acclaim\cn\game (sub folders created automaticly by computer) it tries to run upto the part where it gives you the coyright 1994 thingy in dos, then it goes all black an says cd must be inserted in cdrom, thats it.
I will install .73 and try that but do get back in the mean time pls thx dan

Reply 6 of 8, by DANZEMAN

User metadata
Rank Newbie

Yeah that worked and installed the 400mb full version........
Then it still asked for cd......... man what am i doin wrong i read the read me and it says use switch cd an all that stuff but i dont understand what exactly i need to type in, is it mount d e:\ -t cdrom ???
or mount d e:\ -t cdrom usecd 0 or mount d e:\ -t cdrom -usecd 0 -noioctl or same as above with -aspi?????
Like I said im on vista (The crapest windows ever) running dosbox 0.72 in windows 98/ME compatability mode.

why wont it find the cd I try mounting the image file of constructor imgmount but again dunno what to type properly it dont explain exactly what to do on that one?????

pls HELP I desperatly need a good sleep but cant untill I crack this DosBox!!!
THX for the free up 1gig tip though, ur not supposed to need cd after full install i dont no why dosbox wants it?????