VOGONS


Bad graphic in Lemmings

Topic actions

  • This topic is locked. You cannot reply or edit posts.

Reply 21 of 29, by red_avatar

User metadata
Rank Oldbie
Rank
Oldbie
wd wrote:

This won't be fixed.

So we'll be stuck with the tiny resolution? It makes it virtually useless in windowed mode then though unless you drastically lower Windows resolution (which doesn't really help its looks on any LCD screen). Guess I won't get to use the vgaonly mode then and just live with the slight palette errors.

Reply 23 of 29, by MrFlibble

User metadata
Rank Member
Rank
Member

I'm getting the messed up colours on the level preview screen in the demo (found here) in vanilla v074-3 even with machine=vgaonly, CPU cycles at 2750 and running in compatibility mode.

I played the same demo, as well as demos of ONML and various Holiday/X-Mas Lemmings a while ago under Linux in 64-bit version of DOSBox (v0.74) and IIRC setting machine=vgaonly helped get around the glitch in all of them, but somehow not now. Doesn't work in DOSBox SVN Daum and DOSBox ECE either.

DOS Games Archive | List of free open source games | List of free closed source games

Reply 24 of 29, by jmarsh

User metadata
Rank Oldbie
Rank
Oldbie

I just checked it and it works fine.
If you're hand-editing the .conf file, make sure it's the right file for the copy of DOSBox you're running. Otherwise if you're changing the machine type at the command line, you have to save the config and restart DOSBox for it to take effect.

Reply 25 of 29, by MrFlibble

User metadata
Rank Member
Rank
Member
jmarsh wrote on 2020-06-05, 15:52:

Otherwise if you're changing the machine type at the command line, you have to save the config and restart DOSBox for it to take effect.

So

config -set "dosbox machine=vgaonly"

won't do the trick? I suspected that this might be the case, but why?

DOS Games Archive | List of free open source games | List of free closed source games