VOGONS


First post, by P4R4D0X

User metadata
Rank Newbie
Rank
Newbie

While I was looking for some differences between the two CD-ROM versions of Jazz Jackrabbit, I found some really weird sound crackling when the music volume is set really low. Then I checked earlier versions and they have it as well. Doesn't matter if it's a shareware version or even the registered ones. It can be reproduced even in Holiday Hare 1995.

Tested some other levels and seems like some instruments/samples are missing as well. If I make the music a little bit louder I hear almost everything plus the crackling as well. Turning up the music volume even more removes the crackling. Tried messing in the config file but couldn't fix it. The only two workarounds I found was to use Gravis Ultrasound or using the built in mixer. But that needs sbmixer=false, because every time the get's launched it set's back everything to max volume.

I can't see anything special in the debugger, only a flood of SBLASTER:Raising IRQ messages, that goes on, and on, and on!

Both 0.74 and SVN has this issue, but I'm not sure if it's an emulation bug. I don't remember if this can be reproduced on real hardware. Never changed the music volume back then. Can anybody check if I'm not the only one who has the issue? Testing on real hardware would be awesome as well. If the game is buggy by design, shame on you Epic! Nah just kidding... still love Jazz Jackrabbit. 😀

Reply 2 of 4, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

No music crackling here with any volume level set in the game options. I tried 0.74 and SVN with default settings running the commercial floppy version of Jazz. Used SETUP.EXE to configure SB16 and "ultra high" quality sound.

Reply 3 of 4, by P4R4D0X

User metadata
Rank Newbie
Rank
Newbie

I don't know... still sounds wrong to me. Did a test recording, and I checked the waveform with Audacity. Looks really weird at the quiet parts. Same settings, here as well... Sound Blaster 16 and Ultra high quality. Maybe take a listen to the recording. Should have posted that in the first post so you guys know what to look for.

Link: http://www.mediafire.com/listen/al8tbgp6slboh … v/jazz_sb16.wav

The file is what I got from DOSBox. It sounds like the opposite of the "loudness war" phenomenon, expect it's quiet. Waveform looks very similar in the quiet parts and some samples and instruments are completely missing. Great example is the Turtemple planet music. Also bonus level stages sounds really odd. Quality is definitely lost.

Is my Athlon 64 X2 4600+ too slow? Tried the rest of the oplemu options and all sound pretty much the same. The game in GUS mode sounds crips and clear even with the minimum music volume. Maybe I'm an audiophile or something... I can hear that weird noise. By the way I'm using headphones. 😢

Reply 4 of 4, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

There is some grittiness and instrument dropout at low volume. I think of a different kind of noise for crackle.

The game sets the SB mixer to max volume on both channels at startup, and the mixer is not subsequently adjusted when the game's volume controls are moved. So, the samples are scaled in software (meaning the game's code) to handle volume, and the scaling is probably the cause of any distortion at low volume. I don't notice it as much when I turn the game volume up and my soundcard volume down, even with headphones.