Insert 2nd Disk problem

Having problems with a specific game or application? Post your problems here!

Insert 2nd Disk problem

Postby pkrsfreak » 2019-1-02 @ 03:23

I'm trying to play an old game called Pyramid: Challenge of the Pharaohs Dream, and I'm running into an issue where it will not recognize that I have in the second disk, which makes the game freeze on the prompt for the second disk.
I'm fairly new to using DOSbox, but I have managed to get that part running fine. I installed windows 3.1 fine, got video and sound drivers with no problem. I was able to install drivers for cdrom on windows 3.1 with no issue, and can see the CD drive and the game file on the disk inside said drive. But the game still will not recognize that the second disk is available.

I DID set up windows 3.1 to use a local file for Disk 1 which allowed it to run the game with no disk just fine, but there is only one file on disk 2 and it has the same name as a file from disk 1, so i'm not able to use the same solution for disk 2 without a conflict that would delete the disk 1 file of the same name. I don't believe that this is the issue, although if you have more information as to why that would cause this issue i'd be happy to listen.

Has anyone else successfully gotten a game with 2 disks to run properly, and if so how did you manage it? Would I be better off mounting the two disks and switching between them using ctrl f4 in the DOSbox commands? Any help that could be provided would be very much appreciated!

(I posted this in DOS before realizing that there was a DOSbox section, I'm sorry!)

Update: I have tried assigning the actual CD drive on my PC as the drive for "D:" in DOSbox and inserting the physical disk, I have tried an ISO of disk 2 (Made from my physical disk), a CUE of disk 2 (downloaded from a ROM for the game, just to make sure it wasnt my physical disk corrupted for some reason), making the file for disk 2 local but renamed with the identifier for disk 2, and mounting both images then switching between them with ctrl f4, but to no avail. The game itself runs fine, and the disk is definitely being read by windows 3.1 because I can see the disk and look at the file in file manager. The game plays fine, until halfway through when it prompts for the second disk at which point I get stuck. If I could figure out what the actual issue is then I could troubleshoot further but as of now I can't even identify the issue. There is no error code, and the disk is available to the computer, the game simply doesnt seem to recognize that disk 2 is available (which makes no sense).
This is particularly frustrating because the second disk contains only cinematics and isnt necessary to play further into the game, but in order to skip the cinematic the disk needs to be read.
I believe this is an issue with this particular game, more than an issue of getting the disk to be read by windows 3.1 as per above. If anyone has any experience getting it to work, I'd really appreciate the help, its a gift for my younger sister (Who bought the game, not knowing it was 16 bit and couldnt run on a new PC). Thanks guys
Posts: 4
Joined: 2019-1-02 @ 03:09

Return to DOSBox Games/Apps

Who is online

Users browsing this forum: No registered users and 2 guests