GTA1 - up arrow "stops" after a while

Having problems with a specific game or application? Post your problems here!

GTA1 - up arrow "stops" after a while

Postby junglemontana » 2019-7-18 @ 15:53

I noticed this problem while playing GTA1 ("high color" version, installed from CD).

If you walk forwards (or backwards) for some time, the character suddenly stops and you have to release the up arrow (or down arrow) key and press it again to continue. This only happens in fullscreen mode, and it only happens if you use another key while walking, e.g. arrows to turn, or Ctrl to shoot.

Has anyone else noticed this?

Dosbox is r4252 from SVN and system is Arch Linux. I've tried KDE and Enlightenment desktops.
junglemontana
Newbie
 
Posts: 41
Joined: 2019-2-16 @ 17:37

Re: GTA1 - up arrow "stops" after a while

Postby FulValBot » 2019-8-03 @ 10:11

Try to disable bloc num (but i suggest to change keys)
FulValBot
Newbie
 
Posts: 75
Joined: 2008-3-01 @ 18:43

Re: GTA1 - up arrow "stops" after a while

Postby junglemontana » 2019-8-17 @ 18:35

FulValBot wrote:Try to disable bloc num (but i suggest to change keys)


Do you mean Num lock? It doesn't seem to help, I tried with Num lock on and off but the problem occurred in both cases.
junglemontana
Newbie
 
Posts: 41
Joined: 2019-2-16 @ 17:37

Re: GTA1 - up arrow "stops" after a while

Postby krcroft » 2019-8-17 @ 21:10

Also see: viewtopic.php?f=31&t=66491

(Might want to add to that thread)
User avatar
krcroft
Member
 
Posts: 394
Joined: 2017-4-29 @ 15:07
Location: Ogden's Retreat


Return to DOSBox Games/Apps

Who is online

Users browsing this forum: No registered users and 1 guest