VOGONS


First post, by Yesterplay80

User metadata
Rank Member
Rank
Member

I recently bought "Jim Power - The Lost Dimension" on Steam and I really like the game. It's beautiful, colorful and the music is great! But there's one thing bugging me and ruining the gameplay a bit: f you set the cycles to anything higher than 4000, the game will lock up between level transitions or when using your last live. The music continues to play, but apart from that, nothing more happens. Of course I could run the game with limited cycles, but it makes the gameplay less smooth, especially the fights with the large bosses get very choppy this way.

I played around with the CPU settings in the conf file, but so far couldn't find anything that worked better. Does anyone know or have a solution or walkaround to this problem?

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 1 of 18, by leileilol

User metadata
Rank l33t++
Rank
l33t++

FWIW the freezing's mutual on PCem too with the same symptoms. I could only play it on a 386SX config there. Given the design clumsiness of the port (the whole using-320x200-making-jumps-a-risky-gamble especially), i'd almost blame the game...

apsosig.png

Reply 2 of 18, by Yesterplay80

User metadata
Rank Member
Rank
Member

Awww, that's too bad. So I'd rather stick to the SNES versions included in the Steam package, even though I like the DOS version more.

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 3 of 18, by Akuma

User metadata
Rank Member
Rank
Member

Mine seems to lock up randomly at last life around 8500 cycles and it gets more consistent if I increase the cycles beyond that.

Also I found out it also depends on how far I proceed in the game, so when dying in the in the beginning I can sometimes get to the retry/credit screen with 10000 cycles. Later on it just hangs.

When it hangs I can get to the credit screen by taking this jump, but its beyond me to figure out why it does not take it.

01AB:628E  C6D083              mov  al,83
01AB:6291 3C00 cmp al,00
-> 01AB:6293 7431 je 000062C6 ($+31) (no jmp)
01AB:6295 8BC6 mov ax,si
01AB:6297 8706C8D0 xchg [D0C8],ax ds:[D0C8]=0640
01AB:629B A3C6D0 mov [D0C6],ax ds:[D0C6]=4041
01AB:629E FB sti
01AB:629F C7040000 mov word [si],0000 ds:[00B0]=6868
01AB:62A3 83C602 add si,0002
01AB:62A6 89366AD9 mov [D96A],si ds:[D96A]=453F

@ripsaw8080: I'm out of idea's (tried the svn, regular, staging, loadfix, but the game bug seems consistent)

Reply 4 of 18, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

It appears to be a timing bug. Messing with that logic tends to cause glitches in the sound and/or video, so I opted for an "as needed" sort of workaround. Extract the attached program into the game directory and run it to start the game, then press the END key to clear any hangs that occur. I only tested when running out of lives; let me know if end of level hangs aren't cleared.

Attachments

  • Filename
    jimfix.zip
    File size
    249 Bytes
    Downloads
    38 downloads
    File license
    Fair use/fair dealing exception
Last edited by ripsaw8080 on 2020-03-17, 23:56. Edited 1 time in total.

Reply 6 of 18, by Yesterplay80

User metadata
Rank Member
Rank
Member

ripsaw8080, you're a genius! 😁

I ran the game smoothly with 50000 cycles and both level transitions and losing the last life worked by pressing END, thanks to your fix tool!

My full-featured DOSBox SVN builds (without debugger) for Windows: Vanilla DOSBox and DOSBox ECE (Enhanced Community Edition)

Reply 8 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

My JimPower does not detect the sound correctly. So the game starts and plays 2 seconds and then completely silence.

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 10 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

It is on "5". There is no config-dialog. Someone wrote it should be "7" but no chance for "7" on my PC-Board.

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 12 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

That does not work. I have checked out the issue.

On my system IRQ7 does work on SB but due to res-conflicts only for 2 seconds.
So I am sure that JimPower always switches to IRQ7 and plays two seconds music.

The goal is to switch the game to use IRQ5 on SB. It's a game from 1993 so IRQ5
should be possible if the autodetection fails with IRQ7.

I have to figure out, where the sound-settings are stored and changed.

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 13 of 18, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

The IRQ is the first byte in JIM.CFG, but the last byte is a modulo checksum which should be adjusted if you make changes. The game will not load the settings if the checksum is not correct. However, if the game didn't detect the IRQ when JIM.CFG is recreated then editing the config data will probably not help you.

Reply 14 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

That's pretty bad or a stupid behavior of the program. Is this part of the copy-protection?
Or can someone with dosbox working and IRQ5 Setup send it's jim.cfg. That should work
for me too?

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 15 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

Did some further testing on other systems. Soundengine seems to be hardwired to IRQ7...what a stupidity.

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 17 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

On my real-machines I had no luck of getting sound. Seems to be another "tricky" sound-engine. But it's obvious worth of getting it to run. Perhaps I can find a patch for that game. Perhaps in connection with a trainer...lot's of shareware archives to browse through.

Last edited by dr.zeissler on 2020-07-31, 17:14. Edited 1 time in total.

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes

Reply 18 of 18, by dr.zeissler

User metadata
Rank Oldbie
Rank
Oldbie

I tested jimpower against seven retro-machines. sound worked only on ESS-Solo PIII/600 with disabled caches and PII-233 with yamaha audician32. Soundblaster, aztech, crystal all failed. I can use SFX on my soundblaster, but playing the game without the (fantastic) music...no!

Retro-Gamer
PowerMac 6100/66 - Houdini 486/66 PC-Card MacOS7/Dos622
PowerMac G4- Cube 450/Rage128pro
Macintosh LC - Apple IIe Card
Acorn A4000 Archimedes