VOGONS


First post, by El nostalgico

User metadata
Rank Newbie
Rank
Newbie

Hello. I have a prblem with game MetalMut. I have started about 120 games under DosBOX without problems (these are all game which i have ). But after all I found the MetMut (the game 121), and I downloaded it. After many and many variable configuration can not start it.

Of course it have been start, but when i chosed the F1 VGA (or F2 CGA) it was frooze.

Why???

Did you have a same problem??? Please help.

Maybe I have a vrong version. But its work under XP without Dos BOX (but its working like a lazy slurm except sound).

I lowe this game, I want to play it.

Heeeeeeeeeeeeeeeelp

Reply 1 of 16, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

You're right. I just tested the Underdogs version:
http://www.the-underdogs.org/game.php?id=702

After choosing a video mode (either one), the mode changes but nothing appears.

I remember having a pirated French version of this game back in the day - it ran fine on a 8MHz 286 I think.

Hopefully the DOSBox developers will look into this 😀

EDIT: On a hunch, I switch to the "full" CPU core in DOSBox, and when I select VGA in the game I see a bunch of "Illegal opcode" messages in the DOSBox console window.

Reply 2 of 16, by eL_PuSHeR

User metadata
Rank Moderator
Rank
Moderator

It works using VDMSound if you run it with the -s command-line parameter. It works also under a regular Windows XP cmd.exe box.
Don't know why it doesn't work using DOSBox 0.63 (it doesn't work even after running it with metal.exe -s).

UPDATE: No need to use VDMSound at all after disabling sound altogether. Just run it with the -s parameter under a regular cmd.exe box. BTW - Forgot to specify i have Spanish version, but I think it doesn't matter.

Reply 4 of 16, by eL_PuSHeR

User metadata
Rank Moderator
Rank
Moderator

Agreed. It seems it has heavy timer issues because of digitised internal speaker sounds.

After thorough testing under DOSBox, it doesn't seem to work no matter what combination you try. I just get a black screen after selecting video mode.

UPDATE:

Oddly enough, COLORADO, TARGHAN and STARBLADE; more games from the same Silmarils timeline, work perfectly (even with digitised sound) under DOSBox 0.63 - What gives?

Reply 5 of 16, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

I'm guessing that it's related to that "illegal opcode" message I was getting - probably the game is trying to ask the CPU to do something that DOSBox doesn't know how to emulate. Or, it's asking the CPU to do something stupid that would be ignored by a real PC but that causes DOSBox to freak out instead.

Just a guess.

Reply 7 of 16, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

it's not that easy to debug.
the trapflag is triggered by
0137:00007170 iret

the stack seems to corrupt at that place as the a few lines above that the contents of ax=cs (after a pop ax)

they seem to count how many times they are in the timer loop.

Oh well maybe somebody else can figure out why that iret sets the flags to 0

Water flows down the stream
How to ask questions the smart way!

Reply 9 of 16, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

it's all a matter of time hunterZ
I can probably figure it out given time.
I just report this information so it saves others some work.

Water flows down the stream
How to ask questions the smart way!

Reply 11 of 16, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

Hmm... Yeah, I got a hold of a French version again (doh!) and it seems to work, although sometimes a loud tone is heard when it tries to play sounds. Now I just need to find an English version I guess.

EDIT: No luck finding one. In desparation, replaced the METAL.EXE from the Underdogs version with the one from the French version I found and it seems to work in English. Not sure if that will re-enable the copy protection or not though.

I tried downloading the "crack" on Underdogs - it's just another exectuable called START.EXE that seems to be another version of METAL.EXE that freezes at the same place. It doesn't have that "Joker" pirate text at the beginning though *shrug*

Reply 14 of 16, by DrJones

User metadata
Rank Newbie
Rank
Newbie

I've found a way to fix the sound problem in the game, as well as the hang bug.

You need the french version exe, as mentioned earlier, and put it with the underdogs version. This will get you a running english version.

Now, to fix the sound. What I did is start the game with 30.000 cycles. As the Silmarils logo did its blinking and the long beep that such speed it results in, decrease the cycles to 10024, which will fix the sound to an acceptable level.

Hope this helps.

Reply 16 of 16, by El nostalgico

User metadata
Rank Newbie
Rank
Newbie

Thanks for advices.

I think this topic could be turn off.

Solution:

1. find french version (buy it 😵)
2. load exe file from french version to your english one (if you are french just play your version 😉 )
3. of course delet or rewrite your original (english) exe file
4. And now you can play

Thanks all of you I am sooooooooooooooooooooo happy