VOGONS


First post, by d0k

User metadata
Rank Newbie
Rank
Newbie

spirometer, the program worked well but could not suddenly open the COM port. Where there may be a problem ?
Thanks

Last edited by d0k on 2020-07-14, 10:08. Edited 1 time in total.

Reply 1 of 7, by _Rob

User metadata
Rank Member
Rank
Member

Some additional details as to what your trying to do would have been helpful. I also don't know what this spirometer program is.

If it is trying to communicate to your real COM port (serial port), you need to configure your dosbox config file as follows, assuming your on a Windows system:

[serial]
serial1=directserial realport:com1

That way any program in DOSBox that uses COM1 will use the real COM1 on your Windows PC. This is also mentioned on the Wiki:
https://www.dosbox.com/wiki/Configuration:SerialPort

Reply 5 of 7, by evasive

User metadata
Rank Member
Rank
Member

We did but that is with a USB-to-serial device in windows 10. So not relevant.

You could try and see if there's any activity on the serial port with something like teraterm or any other terminal software tool.

Reply 6 of 7, by junglemontana

User metadata
Rank Newbie
Rank
Newbie

From that Sophos blog link:

When Microsoft first shipped this feature as an upgrade, you had to enable it. In fresh installations of Windows, it was turned on by default.

So if it was enabled by an update, maybe try disabling it? Have you tried that?

Reply 7 of 7, by evasive

User metadata
Rank Member
Rank
Member
junglemontana wrote on 2020-07-17, 08:05:

From that Sophos blog link:

When Microsoft first shipped this feature as an upgrade, you had to enable it. In fresh installations of Windows, it was turned on by default.

So if it was enabled by an update, maybe try disabling it? Have you tried that?

There's a GPO to show the switch to turn it off. Once you do turn it off the driver works. You cannot turn it back on again afterwards 😀

My beef with this is, there is no automated way to turn it off. I don't feel like walking around the buildings doing that on computers that have legacy hardware connected. Thanks Microsoft!