VOGONS


First post, by MrFlibble

User metadata
Rank Member
Rank
Member

Dear VOGONSites, I request your help once more!

This time I'm trying to run the demo version of Renegade: Battle for Jacob's Star. No matter what I do, the demo freezes DOSBox once I try to launch the actual mission.

I have tried setting CPU core to normal, loadfix, turning off EMS, and using JEMM instead of built-in extended memory stuff, as well as SET DOS16M as described here -- if I run RENEGADE.EXE with dos32a I get the DOS/16M memory 40 message. I also tried changing machine type to vesa_nolfb and vesa_oldvbe. It always freezes when it needs to start COMBAT.EXE.

I also tried SVN Daum and DOSBox ECE in addition to the regular build. Same results no matter what. There are no error messages in the console and no crashes, everything just freezes. I can still close DOSBox as normal via Ctrl+F9.

It does not seem like the demo is missing any files, I tried three different versions I could find (two different SSI installers and one from Interactive Entertainment) and they are all the same.

DOS Games Archive | List of free open source games | List of free closed source games

Reply 1 of 3, by Akuma

User metadata
Rank Member
Rank
Member

Confirmed, I experience the same thing.

When I open the debugger I end up here:

0180:1FE4D5  81E1FFFF0000        and  ecx,0000FFFF
0180:1FE4DB 668BEB mov bp,bx
0180:1FE4DE EC in al,dx
0180:1FE4DF 8AD8 mov bl,al
0180:1FE4E1 F6D0 not eal
0180:1FE4E3 22C4 and al,ah
0180:1FE4E5 7510 jne 001FE4F7 ($+10) (no jmp)
0180:1FE4E7 EC in al,dx
0180:1FE4E8 38D8 cmp al,bl
0180:1FE4EA E1FB loope 001FE4E7 ($-5)

When I change it to this the game continues although it then has other problems.

0180:1FE4D5  B800000000          mov  eax,00000000
0180:1FE4DA C3 ret

@ripsaw8080: leaving it up to you 😁, I'm at my limit here.

Reply 2 of 3, by ripsaw8080

User metadata
Rank DOSBox Author
Rank
DOSBox Author

Hangs like that when there's no joystick -- nice programming.

Maybe there's a way (command line switch or so) to allow keyboard instead, but if not then a joykey mapping in DOSBox will suffice if you don't have a joystick.