VOGONS


First post, by FerroceneCloud

User metadata
Rank Newbie
Rank
Newbie

Edit:

I did go back and check and this was due to changing the renderer from the default. I went and checked file timestamps and can see I never ran this application again since making the change, and every other application I tried worked fine. Hope this is useful if anyone else has the same problem.

Hi all,

I have recently got a new system, having moved from Intel to an AMD Zen 3 processor, and am having issues running a particular game (Network Q RAC Rally Championship). I have run this game for years using Dosbox with no problems, including on 0.74-3. I am using the same working configuration, and the game files have been copied over from a working machine.

I have a suspicion that this is something to do with running an AMD CPU. I do have hardware virtualisation enabled, if this makes any difference.

If I run the main executable, I get an instant Dosbox crash with no error message.

If I mount the disc image and attempt to run executables, I get a DOS/4GW exceptions due to invalid opcodes (see attached screenshots).

If anyone has any ideas it would be much appreciated. I haven't yet come across any other errors, just this one game.

Thanks.

Attachments

  • Error2.png
    Filename
    Error2.png
    File size
    161.08 KiB
    Views
    76 views
    File license
    Public domain
  • Error1.png
    Filename
    Error1.png
    File size
    50.29 KiB
    Views
    76 views
    File license
    Public domain