VOGONS


First post, by KainXVIII

User metadata
Rank Member
Rank
Member

I have some serious issue with Munt 2.3.0 amd64(+two updates https://sourceforge.net/projects/munt/files/m … /2.3.0-Updates/) - once in a while Windows 10 (64-bit) stops detecting it (like you can't choose munt in ScummVM or its don't shown after dosbox mixer /listmidi command), so i need to reinstall this program frequently. I don't remember this problem before though! Any help?

Reply 1 of 9, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Depends on what you mean by "(+two updates https://sourceforge.net/projects/munt/files/m … /2.3.0-Updates/)". The update mt32emu_win32drv-1.5.1-win32-amd64.zip is dedicated to solve the problem with Windows 10 2004 compatibility. Did you install the updated driver or just reinstall the munt-2.3.0 package?

Reply 3 of 9, by KainXVIII

User metadata
Rank Member
Rank
Member
sergm wrote on 2020-08-03, 15:35:

More info on the matter can be found in this topic.

Thanks! Wow, its a long thread, can you direct me to solution of this problem (if there any of course)?

Reply 4 of 9, by sergm

User metadata
Rank Oldbie
Rank
Oldbie

Yes, sure. Just download mt32emu_win32drv-1.5.1-win32-amd64.zip from SourceForge and have a look at README.md.
I hope that running

drvsetup.exe repair

will be enough to fix the issue.

Reply 5 of 9, by KainXVIII

User metadata
Rank Member
Rank
Member
sergm wrote on 2020-08-04, 07:24:
Yes, sure. Just download mt32emu_win32drv-1.5.1-win32-amd64.zip from SourceForge and have a look at README.md. I hope that runni […]
Show full quote

Yes, sure. Just download mt32emu_win32drv-1.5.1-win32-amd64.zip from SourceForge and have a look at README.md.
I hope that running

drvsetup.exe repair

will be enough to fix the issue.

Thank you, fixed my issue (so far) 😊

Reply 7 of 9, by CHiLL72

User metadata
Rank Member
Rank
Member

The repair fixes it for me, but only until the next reboot of Windows 10....
I hope there will be an updated version.

Waveblaster MIDI boards: http://members.home.nl/c.kersten (site will go offline soon, looking for space elsewhere)

Reply 8 of 9, by Daemonrunner

User metadata
Rank Newbie
Rank
Newbie

I had the same problem and I found it useful to remove the driver using drvsetup uninstall from the C:\Program Files\munt\mt32emu_win32drv directory using the Command Prompt.

Then I use loopMidi and create an new MT-32 Midi port.

From within Munt, I simply click New Midi Port and select the MT-32 Midi.

The only "drawback" is that you have to select that MT-32 Midi port every time you start a new session of Munt. But really, just leave Munt open the whole time and just keep it minimized in the Task Bar.

The loopMidi port stays the same within DOSBox no matter how many times you reboot your machine.