VOGONS


First post, by doctor_k

User metadata
Rank Newbie
Rank
Newbie

We both have Warcraft II setup and working. Trying to set up to play Warcraft II over an IPX network.

Have enabled ipx=true and are both able to startserver in DOSBox.

The problem is that neither one of us is able to connect to the others server, regardless of who is the server and who is the client.

I have a Mac running OS 10.5.5 and roommate has a Dell running XP. Both are using DOSBox v0.72.

Can anybody help? We run a wireless network and tried accessing the router to disable the firewall, but it didn't seem to approve of that too much. DOSBox is enabled to pass through each of our individual computer's firewall.

Reply 4 of 11, by MiniMax

User metadata
Rank Moderator
Rank
Moderator

If both the PC and Mac are connected "behind" the same router/firewall they should have free access to each other, and you will not need to create any special rules that allows them to "talk" to each other.

Details please. IP-addresses of each system, commands used to start the IPX-service in DOSBox, results from PING and STATUS commands...

DOSBox 0.73 ReadMe | DOSBox Wiki | DOSBox 60 seconds guide | How to ask questions
_________________
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Win 10 Pro

Reply 5 of 11, by h-a-l-9000

User metadata
Rank DOSBox Author
Rank
DOSBox Author

Oops 😉

Cracks have been problematic with mulitplayer Warcraft 2 in the past.

Is this a PowerPC MAC? did anybody succeed in playing IPX network PowerPC - PC?

1+1=10

Reply 7 of 11, by Metron4

User metadata
Rank Newbie
Rank
Newbie

Not sure if this helps, but I ran into a similar situation recently. On two Windows XP computers, I was trying to run Doom 2. I could run either one with IPXNET STARTSERVER or tunnel to each other using IPXNET CONNECT 192.168.1.x, but the game never started. Turns out I had forgot to enable...sharing of some kind (sorry, I suddenly forgot what it was I did, I'm really helpful 😖 )

Reply 8 of 11, by freak-a-zoid

User metadata
Rank Newbie
Rank
Newbie

I got IPX to work correctly, Tunneling through the internet using Hamachi for a VPN solution.

One problem tho, the game runs good in multiplayer one on one. But as soon as i get a 3rd person in the game, it lags horribly. any isdeas of how to fix this???

Reply 10 of 11, by freak-a-zoid

User metadata
Rank Newbie
Rank
Newbie

nah, all of the computers are newer, within the last year. all are multi core... blah blah blah...

just strange that it work fine one on one to any person of the 3, just slows down when a 3rd person is added to the same game

Reply 11 of 11, by freak-a-zoid

User metadata
Rank Newbie
Rank
Newbie

I believe I may have fixed the problem, dunno just yet tho. I have to wait a week until the other 2 people that I play the game with are available to play. unless i can get some people that are willing to try it.