VOGONS


First post, by EmanuelePulciDoria

User metadata
Rank Newbie
Rank
Newbie

Motherboard: Dell Latitude 5501
Processor type and speed: Intel Corei5 9th Gen. 2496 MHz
Amount and type of RAM: 16GB
Video board w/ RAM amount and type: Nvidia GeForce MX150 (TDP 25 W), VRAM 2GB
Sound board: Realtek ALC3204
Operating system: Windows 10 Version 1809
Game name: 688 Attack Sub, 1989
Description of problem: Multiplayer mode not working neither with nullmodem connection nor with modem connection
Reproducibility of problem: always
Sound mode used: AD LIB SOUND BOARD
Video mode: VGA - MCGA, 256 colours
Version of emulator: DOSBox 0.74.3

Steps already attempted to solve the problem:
I am trying to test 688 Attack Sub with the multiplayer game mode without any success. I am testing the connection on 2 DOSBox instances on the same machine through
IP 127.0.0.1
There are 2 possible options: either through nullmodem or through a modem (dial) connection.
To learn how to use the 2 methods properly I tested them on Doom2 I am able to start the multiplayer mode in that game in both ways.
When I repeat the same process in 688 with the nullmodem connection I get Overrun errors whatever the rxdelay I use as reported as well in the following post:
Re: Null Modem Overrun Errors.
On the other side I am not able to use the modem connection as it is because the game GUI gives you the possibility to dial only numbers (no dots) and no more than 11 so I cannot type 127.0.0.1 as 127000000001. This problem is reported as well in the following post:
688 Attack Sub and modem support or How to dial an IP address through an 11 (or less) digit number..
The solution in the latter is to create some sort of phonelist that translate 11 ciphers phone numbers in IP adresses recompiling DOSBox. This is not a solution at my level honestly.
However it looks like a phonelist can be setup in the config file according to the following post, exactly to get around the issue of GUIs that do not let you type proper IP address:
Directserial and Modem Guide
but h-a-l-9000's reply suggests this function is only present into a patch and probably not included in the latest DOSBox 0.74.3 version. I tried it anyway and it is not working. If you dial only the number 3 in order to dial the 3rd phone number in the list DOSBox just calls the IP address 3 (that clearly means nothing) and nothing happens.
I find hard to believe that since 2012 this problem has not been solved in some way. Is there a way to use the phonelist mentioned before? Is there any other way to get round the Overrun error for the nullmodem connection?
Some help here would be really appreciated.