How to enable "It's Now Safe To Turn Off Your Computer"

Discussion about old PC hardware.

How to enable "It's Now Safe To Turn Off Your Computer"

Postby relo999 » 2018-4-20 @ 13:27

How do I turn on the It's Now Safe To Turn Off Your Computer" message in windows 98 SE? I have an AT case with a GA-5AA inside but only get a black screen on shutdown, so every time I'm gambling a bit if it's properly shut down, or at least feels like that.
relo999
Newbie
 
Posts: 32
Joined: 2017-6-24 @ 22:46
Location: Netherlands

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby yawetaG » 2018-4-20 @ 14:41

Disable ACPI in the BIOS.
yawetaG
Oldbie
 
Posts: 1124
Joined: 2016-6-14 @ 14:36
Location: Netherlands

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby relo999 » 2018-4-20 @ 15:39

yawetaG wrote:Disable ACPI in the BIOS.

Don't have such an option in the bios
relo999
Newbie
 
Posts: 32
Joined: 2017-6-24 @ 22:46
Location: Netherlands

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby bjwil1991 » 2018-4-20 @ 16:22

Are you using the ATX PSU? If so, switch to another PSU, change the jumper (if there is one) or the BIOS setting (power management) to utilize the AT PSU. In fact, disable the APM under the Power Management settings in the BIOS.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 462, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1929
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby mockingbird » 2018-4-20 @ 16:57

relo999 wrote:
yawetaG wrote:Disable ACPI in the BIOS.

Don't have such an option in the bios

Try changing ACPI in Device Manager to Standard PC... Not sure if it's applicable to 98, but it's worth a shot.
Image
mockingbird
Member
 
Posts: 426
Joined: 2013-6-17 @ 02:57

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby derSammler » 2018-4-20 @ 17:43

yawetaG wrote:Disable ACPI in the BIOS.

Doing that when Windows was installed with ACPI enabled will render the system unusable. You can only enable ACPI afterwards, but not disable it.

Anyway, the black screen is a common bug in Win98SE. There's a shutdown patch for it (Q239887).
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby bjwil1991 » 2018-4-20 @ 18:15

Also, go to Start > Run (Win Key + R), type in msconfig and click OK or hit enter, click Advanced, and make sure the Disable Fast Shutdown is checked. Click OK twice and restart. Also, make sure there aren't any IRQ conflict by right-clicking on My Computer > Properties (or Win Key + Pause/Break) > Device Management, Highlight computer, and click Properties, and select IRQ.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 462, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1929
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby relo999 » 2018-4-20 @ 21:44

derSammler wrote:
bjwil1991 wrote:Also, go to Start > Run (Win Key + R), type in msconfig and click OK or hit enter, click Advanced, and make sure the Disable Fast Shutdown is checked. Click OK twice and restart. Also, make sure there aren't any IRQ conflict by right-clicking on My Computer > Properties (or Win Key + Pause/Break) > Device Management, Highlight computer, and click Properties, and select IRQ.

Some things are on the same IRQ, but non that complain about it. (and most make sense, like the master and secondary IDE controller being on the same IRQ) and fast shut down disabled doesn't seem to do anything.

derSammler wrote:
yawetaG wrote:Disable ACPI in the BIOS.

Doing that when Windows was installed with ACPI enabled will render the system unusable. You can only enable ACPI afterwards, but not disable it.

Anyway, the black screen is a common bug in Win98SE. There's a shutdown patch for it (Q239887).

Installed the new patches for 98SE, I now get a "windows is shutting down" screen. Still no "It's Now Safe To Turn Off Your Computer" message now though.

bjwil1991 wrote:Are you using the ATX PSU? If so, switch to another PSU, change the jumper (if there is one) or the BIOS setting (power management) to utilize the AT PSU. In fact, disable the APM under the Power Management settings in the BIOS.
[/quote]
No, AT power supply and with apm disabled already. and no motherboard or bios switch.
relo999
Newbie
 
Posts: 32
Joined: 2017-6-24 @ 22:46
Location: Netherlands

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby yawetaG » 2018-4-21 @ 11:03

derSammler wrote:
yawetaG wrote:Disable ACPI in the BIOS.

Doing that when Windows was installed with ACPI enabled will render the system unusable. You can only enable ACPI afterwards, but not disable it.


Interesting, because I did disable it on a system with a Japanese copy of Windows 98 installed, and Win98 simply reinstalled certain hardware support components afterwards.
yawetaG
Oldbie
 
Posts: 1124
Joined: 2016-6-14 @ 14:36
Location: Netherlands

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby keropi » 2018-4-21 @ 11:18

I would go as far as to say that if you enable/disable ACPI you need to re-install win9x .
The "normal" behavior is the system to not boot windows like derSammler mentions - I've also had 1 system that worked OK but everything else just needed a complete re-install.
User avatar
keropi
l33t++
 
Posts: 6646
Joined: 2003-9-08 @ 06:45
Location: Greece

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby F2bnp » 2018-4-21 @ 11:20

This is a bug with Ali Aladdin V as far as I can tell. I have a P5A-B with the same issue and the only solution I've found is to install Windows 98 with APM instead of ACPI. To do this you have to use a switch during installation, can't remember it off the top of my head but it was something like:

D:\win98\setup.exe /p i
User avatar
F2bnp
l33t
 
Posts: 3496
Joined: 2007-9-23 @ 10:19

Re: How to enable "It's Now Safe To Turn Off Your Computer"

Postby relo999 » 2018-4-21 @ 22:32

F2bnp wrote:This is a bug with Ali Aladdin V as far as I can tell. I have a P5A-B with the same issue and the only solution I've found is to install Windows 98 with APM instead of ACPI. To do this you have to use a switch during installation, can't remember it off the top of my head but it was something like:

D:\win98\setup.exe /p i

This fixed it. Thanks!
relo999
Newbie
 
Posts: 32
Joined: 2017-6-24 @ 22:46
Location: Netherlands


Return to General Old Hardware

Who is online

Users browsing this forum: No registered users and 7 guests