VOGONS


First post, by matti157

User metadata
Rank Member
Rank
Member

This guide is for making a DIAL-UP connection without having an actual phone line.

You can connect your old computer to the Internet, and thanks to a local IP address and the magic of routing, you can also browse everything on your LAN (I tried to access my NAS)

In this guide I have combined and summarized what I have learned from these guides, which are definitely better made than mine. So, a thank you to the original authors; it's all thanks to them.

References:
https://web.archive.org/web/20240324110826/ht … ata-dialup.html
https://web.archive.org/web/20240304210734/ht … ata-config.html
https://web.archive.org/web/20240304210356/ht … es/ras_2k3.html
https://web.archive.org/web/20240324110840/ht … ticles/ras.html
https://web.archive.org/web/20240418214026/ht … m-isp-in-a-box/ - Thanks also to Mark of serialport.org for the suggestions sent by email.


What do you need?

  • A DIAL-UP server, which can be of 3 types, many devices can serve as DIAL-UP servers, types I know of includes:

-----Any computer or virtual machine running Windows Server 2000-2022, connected to your LAN (also in wifi) and with access to a physical modem
-----An old CISCO router with a 56K modem card (they can be found on ebay for very little money)
-----A raspberry PI with 56K RS232 modem connected with USB-RS232 adapter (not covered by this guide)

In this tutorial we will look at the first 2 server types (Win and Cisco), I have not had time to try it with raspberry but I know it is fattible. You are free to supplement the guide

  • A telephone line simulator, which is responsible for providing both 56K modems with the illusion that they are connected to a real telephone line. To do this you can use small devices that were used to connect traditional telephones to a VOIP line.

You can find them on ebay for a few €.
Some models:

  • Cisco SPA2102
  • Linksys SPA2102
  • Linksys PAP2T
  • Cisco SPA122
  • Sipura SPA2100

I found one Linksys SPA2102 for €10


Connection scheme

scheme.png
Filename
scheme.png
File size
105.55 KiB
Views
417 views
File license
Public domain

Server setup
The server takes care of providing authentication for the connection (you set the user and password here) and takes care of routing the traffic between the dialup connection and your LAN network.
Choose one of the 2 solutions listed here

Windows Server as dialup server
If you have chosen to use a Windows server, you must configure the RRAS (routing and remote access) role. It’s easy! Connect your server to your LAN via cable or WiFi and Follow this guide step by step https://web.archive.org/web/20240304210356/ht … es/ras_2k3.html
Notes:

  • The steps are very similar for newer Windows servers too
  • Follow the "preamble", "procedures" sections in order and before finishing read "troubleshooting". The "authentication" section is useful to know, I left MS-CHAP and MS-CHAP V2 as I only connected with Windows clients)
  • If you are on Windows 2008 or higher, the "Remote Access Policies" section has been changed to "Remote access logging & policies", right-click on the folder and click on "launch nps", the options are then very similar to 2000/2003
  • In the properties of the RRAS server (right click on the name of your server, properties, IPv4 tab, at the bottom "adapter" make sure that the network card connected to your LAN is selected, by doing so your home router will assign the IP addresses of your LAN to the devices you connect in dialup.

Cisco router as dialup server
Source of this configuration: https://web.archive.org/web/20240418214026/ht … m-isp-in-a-box/ - Thanks also to Mark of serialport.org for the suggestions sent by email.
Notes:

  • I use a Cisco 1841 IOS 12.4 with 2 built-in Ethernet ports + a wic-1am-v2 card (but wic-1am also works)
  • The router has 2 Ethernet ports, the 0 is configured as WAN and has to be connected to your home router. The 1 is configured as an additional LAN port and can remain disconnected
  • My home LAN is class 192.168.0.X
  • 192.168.0.1 is my router
  • 192.168.1.X is the ip class assigned to devices connected to LAN1 port (which can remain disconnected - useless for this tutorial)
  • Devices that connect via dialup get an IP 172.16.1.X, which with this configuration can still access resources on your LAN
SHOW configuration
show run
Building configuration...

Current configuration : 2918 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default if-needed local
aaa authorization exec default local
aaa authorization network default local
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.2 192.168.1.25
!
ip dhcp pool DHCP-LAN-Pool-1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.0.1 1.1.1.1 8.8.8.8
!
ip dhcp pool dialup
network 172.16.1.0 255.255.255.0
dns-server 192.168.0.1 1.1.1.1 8.8.8.8
default-router 172.16.1.1
!
!
ip name-server 1.1.1.1
ip name-server 8.8.8.8
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username [here username for router and dialup connection] privilege 15 password 0 [here password for router and dialup connection]
!
!
!
!
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
Show last 65 lines
!
interface FastEthernet0/0
description WANPORT
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description LANPORT
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Async0/0/0
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
encapsulation ppp
ip tcp header-compression
dialer in-band
dialer-group 1
async mode dedicated
peer default ip address dhcp-pool dialup
ppp authentication pap chap
routing dynamic
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 172.16.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 0/0/0
modem Dialin
modem autoconfigure type default
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
!
scheduler allocate 20000 1000
ntp clock-period 17179870
ntp update-calendar
ntp server 193.204.114.232
end

VOIP device setup

You need to access the WEB interface of the device and then follow this guide, section “Using a single ATA”
https://web.archive.org/web/20240304210734/ht … ata-config.html
Notes:

  • As the guide says, the device must be left connected to any LAN, otherwise for some reason the telephone part does not work.
  • The part we are interested in is: “Using a single ATA”
  • When you configure the “dialplan” you will see a number inside the string “9095551010”, replace it with the number you want to call

Start!
Now take an old pc, old laptop or PDA with a modem card and connect them to the free phone port of the VOIP device. Configure the connection with the number set up on the VOIP, put in the user and password you chose when you set up the server, and connect!
I connected with an old Thinkpad with Windows 2000 and via dialup I was able to surf internet and even open a shared folder on the NAS at home!
Please note that the connection will never reach 56K, but will always be 33K

PDF version: https://archive.org/download/setup-a-low-cost … hone%20line.pdf

Reply 2 of 7, by pengan

User metadata
Rank Newbie
Rank
Newbie

VoIP networks have their complications, I remember having to set voice codec to G.711 instead of G.729 if I wanted the Modem to get through. fax seems to have a bit of other problems, T.38 doesn't always work.
For someone want PSTN/PABX experience, "Excelltel" PABX on Aliexpress is the straightforward and budget firendly option, a 8 extensions SOHO PABX only $45 USD
I was used it to mimic a full function teleco in classroom, the Excelltel(blue box in the video) paired with a Nitsuko Portrait as "long distance exchange" to each other.
Check the working video here: https://zhuanlan.zhihu.com/p/452451018

The Conexant ACF modem on Aliexpress around $15 worked fine on the Raspberry Pi. A modem pool can be built very cheaply and mimics early 90's unix shell providers, pppd also works.

Attachments

Reply 3 of 7, by matti157

User metadata
Rank Member
Rank
Member
pengan wrote on 2024-05-10, 20:42:
VoIP networks have their complications, I remember having to set voice codec to G.711 instead of G.729 if I wanted the Modem to […]
Show full quote

VoIP networks have their complications, I remember having to set voice codec to G.711 instead of G.729 if I wanted the Modem to get through. fax seems to have a bit of other problems, T.38 doesn't always work.
For someone want PSTN/PABX experience, "Excelltel" PABX on Aliexpress is the straightforward and budget firendly option, a 8 extensions SOHO PABX only $45 USD
I was used it to mimic a full function teleco in classroom, the Excelltel(blue box in the video) paired with a Nitsuko Portrait as "long distance exchange" to each other.
Check the working video here: https://zhuanlan.zhihu.com/p/452451018

The Conexant ACF modem on Aliexpress around $15 worked fine on the Raspberry Pi. A modem pool can be built very cheaply and mimics early 90's unix shell providers, pppd also works.

The Cisco SPA122 device and all its similar ones are used to simulate the telephone line, at the voip level there is nothing to manage

I put here a screenshot of the parameters set, in the end it is a matter of disabling all the items related to fax and to enable the tick that it is a modem line

As a codec I left the default G711u

Screenshot 2024-05-16 212229.png
Filename
Screenshot 2024-05-16 212229.png
File size
72.07 KiB
Views
175 views
File license
Public domain

Reply 4 of 7, by kingcake

User metadata
Rank Oldbie
Rank
Oldbie

Cathode Ray Dude (CRD) on Youtube has good videos and blogs on this topic.

The devices you listed are VOIP POTS gateways, NOT phone line simulators. Phone line simulators are old analog devices that have nothing to do with VOIP.

Reply 5 of 7, by matti157

User metadata
Rank Member
Rank
Member
kingcake wrote on 2024-05-16, 21:50:

Cathode Ray Dude (CRD) on Youtube has good videos and blogs on this topic.

The devices you listed are VOIP POTS gateways, NOT phone line simulators. Phone line simulators are old analog devices that have nothing to do with VOIP.

I was using the wrong term. Yes basically they receive a call on one of the telephone ports and through the software they forward it to the other port where there is the modem ready to answer

Reply 7 of 7, by matti157

User metadata
Rank Member
Rank
Member
kotel wrote on Yesterday, 18:04:

Anyone got this to work on Windows server 2012 r2? I'm having troubles finding the correct settings and with dial up.

I did it on 2008 R2, what problem do you have in detail?

I expect no or very little difference on RRAS role between 2008 and 2012